Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

bootloader gelöscht ?

geschrieben von haderlump 
bootloader gelöscht ?
23. September 2015 14:12
Hallo zusammen
wie es scheint habe ich in meinem Arduini Duoboard (ormerod1) den Bootloader gelöscht.
Wenn ich es an den PC anstecke wird es nicht mehr erkannt, ich kann deshalb die Firmware nicht mehr einspielen.
Gibt es die Möglichkeit einen neuen Bootloader per SPI-Schnittstelle (ich habe ein Programmierboard) einzuspielen.
Wenn ja, wie geht das , und wo bekomme ich die Grundsoftware her?

Gruß Fritz
Re: bootloader gelöscht ?
23. September 2015 15:21
huhu!

Ich würde es mit einem zweiten Arduino machen, schau mal hier:

https://learn.sparkfun.com/tutorials/installing-an-arduino-bootloader
Re: bootloader gelöscht ?
23. September 2015 15:41
Der Bootloader vom Arduino Due funktioniert etwas anders als der Bootloader der anderen Arduinos (z.B. Mega). Die offizielle Arduino-Seiten erklären wie man vorgehen kann/muss und wie der Bootloader genau funktioniert.


--
Microsoft MVP in den Kategorien DirectX/XNA * Visual C++ * Visual Studio and Development Technologies seit 2011

  • Mein Erster (RAMPS 1.4, Selbstbau WolfStrap-Derivat mit Linearführungen, Wade Extruder und E3D lite6 Hotend)
  • Cub44 (Selbstbau Dual Wire Gantry Derivat mit Zahnriemen und Linearschienen, RADDS 1.5 und DUE, Custom Hotend - E3D like, Compact Bowden Extruder)
  • HexMax (sechseckiger Delta (eigenes Design) mit Druckraum 300mm Durchmesser und >=400mm Höhe, RADDS 1.5, 24V, Custom Hotend, Compact Bowden Extruder)

Andere Projekte: FSR Board (ABL-Sensor-Platine inkl. Firmware) * ThirtyTwo (32Bit RepRap-Firmware)
Re: bootloader gelöscht ?
23. September 2015 16:05
Quote
reprappro
Firmware update problems

Problem
Cannot update firmware
After firmware update, Duet no longer visible

Solution
Check the instructions, and follow them carefully
If the ‘bossac’ command fails, make a note of the error, and contact support
If the error is to do with the port not being found, try sending the update command without this part: ‘–port=COMxx -U true’
If the board is inaccessible following a firmware update, but then does reappear after the ‘erase’ and ‘reset’ buttons are pressed.
When you send the bossac command, leave the ‘-R’ off the end. Once the flash has completed, wait for 10 seconds, then press ‘reset’ button on the board,
and see if the board shows up correctly

[reprappro.com]

Herzl. Grüße
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen