Probleme mit Bed-Leveling
08. May 2016 04:34
Hallo,

bisher lief mein Delta-Drucker mit Repetier von den mechanischen Bewegungsabläufen eigentlich immer so wie ich es erwartet hatte.
Heute habe ich mal etwas größeres drucken wollen und bin auf Probleme gestoßen, die ich mir zunächst nicht erklären konnte.

Ich hab jetzt auf dem Eckigem Heiz-Bett 200x200mm ein quadratischen Objekt mit der Grundfläche 120x120mm drucken wollen.
Dazu habe ich bei Slic3r Skirt und Brim so angepasst, dass alles druckbar ist.

Es ergibt sich bei dem Druck folgendes:
- Das Hotend fährt in normaler Geschwindigkeit zum Startpunkt rechts
- Das Hotend verfährt viel zu langsam nach hinten
- auf der Geraden wird kaum Filament aufgetragen. sie erscheint mir zudem leicht kreisförmig
- an der ersten Ecke (rechts hinten; sind wegen des Brim eigentlich Rundungen). Wird viel Filament aufgetragen.
- auf der Geraden danach wieder kaum Auftrag. Dafür drückt sich die Düse immer weiter auf die Glasplatte, bis Riemenzähne überspringen. (5x habe ich hier dann schon abgebrochen)
- die Linke hintere Ecke wird in der Luft gedruckt: Das Hotend fährt koordiniert langsam hoch, so als wäre es in einer art Steilkurve.
- zum Anfang der nächsten Geraden berührt die Düse wieder das Druckbett.
- Manueller Abbruch

Kleinere Objekte kann ich problemlos drucken, daher gehe ich davon aus das die Grundeinstellungen wie Armlänge und Abstände alle in Ordnung sind (Oder? Wie testen?). Wenn ich manuell in x und y verfahren nach g1 z0 kann ich in dem 100mm Radius alle Koordinaten ohne zu starken Kontakt zum Druckbett anfahren. (Es springen keine Riemen durch und das Bett wird auch nicht durchgebogen.)


Ich habe auch eine Vermutung, woran es liegen könnte - weiß aber nicht so richtig was ich dagegen machen kann:
Ich denke die Daten vom Bed-Leveling sind entweder fehlerhaft oder werden zu den Rändern des zuvor abgetasteten Bereiches sehr schnell sehr schlecht - stelle mir das wie so ein Ploynom vor, das in einem Bereich zwar annähernd die Form hat, die es haben soll - sich dafür neben diesem Bereich aber extrem aufschwingen muss.
Macht das in euren Augen Sinn?

Ich blicke bei den Einstellungen ehrlich gesagt nicht so ganz durch. Optimum wäre, dass allen Softwares bekannt ist welche Form und Größe mein Druckbett hat.
Ich habe irgendwie 3 Möglichkeiten die Druckbettform einzustellen und keine AHnung welche davon in welcher Situation dominiert:
- In der Repetier Firmware (ich gehe mal davon aus das diese Werte denen in der Repetier EEPROM Konfig entsprechen)
- In den Repetier Druckereinstellungen unter Druckerform
- Im Slic3r unter Printer Settings/ Bed shape

was muss ich in meinem Fall jetzt wo einstellen, damit der Befehl "g32 s2" nicht nur eine Kreisfläche abfährt sondern mein ganzes eckiges Bett?
Wenn ich z.B. bei der Height-Map-Messung Werte eingebe, die über die Kreisgrenzen hinausgehen bleibt das Hotend am Rande des Kreises stehen und tastet alle für diese Zeile noch fehlenden Messpunkte an der selben x-y-Koordinate ab.

Oder habt ihr andere Ideen, was die Ursache das beschriebene Fehlerbildes sein könnte?
Re: Probleme mit Bed-Leveling
08. May 2016 05:03
Quote
was muss ich in meinem Fall jetzt wo einstellen, damit der Befehl "g32 s2" nicht nur eine Kreisfläche abfährt sondern mein ganzes eckiges Bett?

Das wird nicht gehen. Ich gehe davon aus, daß Dein Drucker eine kreisrunden Druckbereich von 200 mm hat. Wenn Du darüber hinaus gehst, flippt er halt aus. Ein Quadrat von 200 mm entspricht einer kreisförmigen Druckfläche 282 mm. Verhindern kannst Du das, indem Du in der Firmware und/oder im Slicer die entsprechend kreisrunde Druckfläche von 200 mm einstellst.


Gruß
Niko

NXD evo (Duet Wifi, RepRap Firmware 3.1.1, Duet 3d smart effektor & Haydn Huntley Magrods, Bondtech BMG (flying) extruder.
Re: Probleme mit Bed-Leveling
08. May 2016 06:27
Zwischenzeitlich habe ich überall die Druckbettradien auf 120mm gestellt um ihm mehr Platz zur Entfaltung zu geben - dabei immer drauf geachtet, das Slic3r trotzdem in den Grenzen bleibt und mit Finger auf Notaus.
Hat aber nichts gebracht - obwohl ich das Bed-Leveling vorher nochmal durchgeführt habe.

Versuchsweise bin ich mal auf die Grundeinstellungen von Slic3r zurück. - Mit Erfolg.
Jetzt werde ich schrittweise die Grundeinstellungen an meine EInstellungen angleichen und schauen wann der Fehler wieder auftritt

1-mal bearbeitet. Zuletzt am 08.05.16 06:28.
Re: Probleme mit Bed-Leveling
08. May 2016 07:00
Also es liegt scheinbar an den DruckEReinstellungen. Wenn der Düsendurchmesser auf 0,35 steht läuft der Druck wie gewohnt. Sobald ich auf 0,4 stelle - was meiner Düse tatsächlich entspricht - taucht wieder der beschriebene Fehler auf.
Gibt es da Wechselwirkungen mit den Druckeinstellungen? Oder doch irgendwie mit dem Leveling? Hab alle Bahndicken unter Advanced auf 0,4 und die Layerhöhe auf 0,2 (erster Layer B: 200% und H: 0,3).
Hat das überhaupt einen Einfluss, was ich unter Druckereinstellungen/Extruder einstelle? Überschreiben die Druckeinstellungen/Advanced das nicht ohnehin?
Irgendwelche Ideen???

Zusätzlich ist mir aufgefallen, das der Drucker seit neuestem, manchmal aber nicht immer direkt vor dem Druck eine sehr lange Pause macht.
Also: ich starte den Druck; Druckbett heizt auf; Hotend Fährt auf Mittelposition direkt über dem Bett -> Pause (gefühlt 60 Sekunden)
Macht dann aber irgendwann von selbst weiter.

Vorher hatte ich es oft (in mehr als 60% der Fälle), dass der Drucker, sobald das Hotend unten angekommen ist eine Pause macht - aber eine Richtige, mit dem Repetier Pause-Fenster. Wenn ich dann fortsetzten drücke läuft alles problemlos ohne weitere Pause weiter.
Hat mich bisher nicht gravierend gestört, da ich den ersten Layer eh immer im Auge behalte, bevor ich den Drucker sich selbst überlasse... Aber langfristig will ich das natürlich auch weg bekommen...
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen