ABL in der FW
05. June 2016 14:04
Hallo,
habe die FW 1.1.0- RC5 (Drucker K8200).
Beim ABL muß ja der Abstand des Sensors zur Düse in der FW eingetragen werden.
Wenn ich den Abstand von 76 mm (Sensor rechts neben der Düse) eintrage , kommt immer brim Compilieren eine Fehlermeldung.
Kann jemand bitte helfen, wo und wie es eingetragen werden muß:

mfg mh
Anhänge:
Öffnen | Download - Configuration.h (43.7 KB)
Re: ABL in der FW
05. June 2016 14:13
Die Fehlermeldung wäre bestimmt interessanter grinning smiley

Wahrscheinlich meckert Arduino darüber dass die Z-Probe nicht aufs Bett passt beim messen.
Du musst dann, wenn ich mich richtig erinnere, hier "#define LEFT_PROBE_BED_POSITION" deinen Offset eintragen.

LG
Siggi


Gruß
Siggi


Geeetech I3 Pro B 8mm Acryl - Mega 2560 - Ramps 1.4 - TMC2100 - MK42 - E3DV6-Clone 0,4 - SSR 522-1dd60-40 (A-Senco) - Marlin RC8Bugfix 26.12.2016 - Repetier Host - Windows 7 64 Bit
Vulcanus mit Linearschienen
Anycubic i3 Mega
Re: ABL in der FW
05. June 2016 14:52
Hallo,
danke für die Info.
Aber muß ich denn in der Zeile 601: #define X_PROBE_OFFSET_FROM_EXTRUDER nicht den Versatz eintragen?

mfg mh
Re: ABL in der FW
05. June 2016 15:01
Ja, aber du musst auch den Bewegungsbereich einschränken da sonst der Sensor nicht aufs Bett passt.
Rechne mal zu dem Wert von der rechten Position den Offset hinzu, jetzt kommst du bestimmt auf einen Wert der größer ist wie dein Druckbett.
Ich merke schon dass mir für Erklärungen irgendwie noch die Erfahrung fehlt smiling smiley

LG
Siggi


Gruß
Siggi


Geeetech I3 Pro B 8mm Acryl - Mega 2560 - Ramps 1.4 - TMC2100 - MK42 - E3DV6-Clone 0,4 - SSR 522-1dd60-40 (A-Senco) - Marlin RC8Bugfix 26.12.2016 - Repetier Host - Windows 7 64 Bit
Vulcanus mit Linearschienen
Anycubic i3 Mega
Re: ABL in der FW
05. June 2016 15:05
Hallo,danke für den Hinweis.
Ich werde mal nachrechnen.

mfg mh
Re: ABL in der FW
07. June 2016 13:38
Hallo,
ich kriege es mit den Koordinaten nicht hin.
Kann mir bitte jemand helfen, mein conf. entsprechend zu ändern, eventl. gleich abzuändern
Meine Daten :
- ABL mit induktiven Sensor - er befindet sich 76mm rechts von der Düse (K8200).
- Bettgröße 200x200
- Gitter 3x3
Es läuft jetzt mit ABL und 9-Punkten, aber der Abstand des Sensors stimmt nicht..

mfg mh
Anhänge:
Öffnen | Download - Configuration.h (43.7 KB)
Re: ABL in der FW
09. June 2016 05:12
Ich wills mal probieren, hatte selbst auch Probleme damit

1.
#define X_PROBE_OFFSET_FROM_EXTRUDER 76 // positv, da der Sensor vom Nullpunkt aus rechts sitzt !!!
( gibt es keinen Y-Offset?)

2.
#define LEFT_PROBE_BED_POSITION 86 // 10 + 76 Offset, du hast dort 55 genommen, kann der Extruder so weit raus (ca. 2cm außerhalb des Druckbetts)???
#define RIGHT_PROBE_BED_POSITION 190 // rechts nicht so viel verschenken smiling smiley
#define FRONT_PROBE_BED_POSITION 10
#define BACK_PROBE_BED_POSITION 190


3.
#define Z_SAFE_HOMING // auskommentieren, damit es läuft

4.
#define Z_SAFE_HOMING_X_POINT ((X_MIN_POS + X_MAX_POS) / 2) // X point for Z homing, hier kannst du auch 76 nehmen, dann ist das Nozzle am Nullpunkt
#define Z_SAFE_HOMING_Y_POINT ((Y_MIN_POS + Y_MAX_POS) / 2) // Y point for Z homing, hier kannst du auch den Y-Offset nehmen

Gruß - Werner -

5-mal bearbeitet. Zuletzt am 09.06.16 06:15.
Re: ABL in der FW
10. June 2016 05:47
Hallo,
danke für die Info.
Ich werde das verarbeiten und hoffe das es geht.

mfg mh
Re: ABL in der FW
10. June 2016 07:04
Hallo,
es geht jetzt. Es gibt bloß noch ein Problem.
Ich muß den Abstand der Düse zum Bett noch einstellen.
In der Software Repetier-Host kann ich nach Reset, die Z-Achse nicht nach negativ bewegen, um den Offset-Wert zu bestimmen.
Ich kann den "Fehler" in der conf. nicht erkennen.


mfg mh
Re: ABL in der FW
10. June 2016 14:57
Hallo,
Punkt 4.
#define Z_SAFE_HOMING_X_POINT ((X_MIN_POS + X_MAX_POS) / 2) // X point for Z homing, hier kannst du auch 76 nehmen, dann ist das Nozzle am Nullpunkt
#define Z_SAFE_HOMING_Y_POINT ((Y_MIN_POS + Y_MAX_POS) / 2) // Y point for Z homing, hier kannst du auch den Y-Offset nehmen



wie soll ich denn die 76mm eintragen? - bitte genaue Angabe

mfg mh
Re: ABL in der FW
11. June 2016 04:44
Geht ganz einfach:

#define Z_SAFE_HOMING_X_POINT (76)

Zum Z-Nullpunkt:

Mit G92 Z-0.5 wird der Z-Wert z.B. auf -0.5 eingestellt ohne die Z-Achse zu bewegen. Anschließend kannst du mit G1 Z0 die Düse um 0.5mm anheben.
Wenn du den genauen Wert für den Abstand vom Druckbett ermittelt hast, kannst du ihn auch in Marlin eintragen:

#define Z_PROBE_OFFSET_FROM_EXTRUDER 0.5 //hebt die Düse 0.5 mm an

(alles aber bitte sehr vorsichtig und ohne Gewähr, bin selbst noch Anfänger winking smiley )

2-mal bearbeitet. Zuletzt am 11.06.16 04:52.
Re: ABL in der FW
11. June 2016 05:13
Hallo,
danke für die Info.
Ich habe aber immer im Repetier-Host die Z-Achse nach unten gefahren, bis der Abstand der Düse ca. 0,15mm (Blattstärke) betrug.
Diesen Wert habe ich dann in der Firmware eingetragen.-am Display

mfg mh
Re: ABL in der FW
14. June 2016 04:47
Hast du mal versucht den Z_MIN_SOFTWARE_ENDSTOP zu deaktivieren?


Grüße
Martin
Re: ABL in der FW
14. June 2016 04:59
Hallo,
ich kann Z_MIN_SOFTWARE_ENDSTOP in der configure.h nicht finden.

mfg mh
Re: ABL in der FW
14. June 2016 05:32
Auf der Seite von 3D-Proto gibts ´ne gute Anleitung zum Z-Achse leveln

[www.3d-proto.de]
Re: ABL in der FW
14. June 2016 05:39
danke für den Hinweis.


mfg mh
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen