Simplify3D und Diamond Hotend
11. March 2017 07:45
Hi
Hat schon jemand S3D mit dem Diamond Hotend zum laufen gebracht ?
Bei mir druckt er immer nur mit dem ersten Extruder, auch wenn ich bei einen Dualdruck den Extruder 2 in das Profil mit eingebe.
In der Marlin Software habe ich alles genau wie unter Wicki bei Diamond angegeben alles so eingetragen...???
Wäre über jeden Tip dankbar..
mfg
Martin
Re: Simplify3D und Diamond Hotend
11. March 2017 17:03
Hallo Martin,
Ich bin gerade dabei. Leider muß ich das Hotend wieder auseinander nehmen, weil die Verschraubungen undicht sind.
Ich hatte das Problem, daß im Vollgrafikdisplay nur beim ersten Extruder ein Sollwert für die Temperatur drin war.
Wenn ich am Displaydrehschalter das Vorheizen wähle, bekommt nur der erste Extruder einen Sollwert.
Ich nehme an, daß dann auch nur der erste eine Bewegung ausführen wird.
Ich verwende Simplify3d und habe dort drei Extruder eingerichtet und für alle drei eine Temperatur angegeben.
Drucke ich dann von SD Karte, haben alle drei einen Sollwert. Leider konnte ich nur den ersten ausprobieren
Und muß erst mal alle Gewinde eindichten. Leider kann man die drei Kühltürme nicht vernünftig festziehen.
Ich werde dazu zwei Löcher bohren, dann geht's mit der Spitzzange.
Werde weiter berichten.
Gruß, Michael

1-mal bearbeitet. Zuletzt am 11.03.17 17:04.
Re: Simplify3D und Diamond Hotend
12. March 2017 04:44
Hi Michael
Dann bist Du also genau so weit gekommen wie ich......Deßhalb muß man ja in der Firmware alle 3 Extruder auf die gleichen TEMP PIN's belegen.
aber wie gesagt, S3D interessiert das nicht ...
Martin
Re: Simplify3D und Diamond Hotend
12. March 2017 06:43
Hallo Martin,
Stimmt so nicht ganz, die drei Temperaturen werden auf dem Display mit den Änderungen für Marlin angezeigt.
Aber den eingestellten Sollwert gibt es nur einmal beim ersten Extruder und die beiden anderen haben 0.
Da aber die Temperatur- Istwerte synchron laufen, hat nach dem Aufheizen der erste seine Temperatur erreicht und die beiden anderen
haben Übertemperatur, 0 Grad Sollwert und 200 Grad Istwert, das geht nicht.
Lade ich aber eine Datei von Simplify3d, dann bekomme ich auch für die anderen Extruder die eingestellten Sollwerte.
Mittlerweile konnte ich schon mit 2 Farben drucken, für die dritte fehlt noch der Spulenhalter.
Im zweiten Bild die Modifikation mit den zusätzlichen Bohrungen. Jetzt kann man den Kühler mit einer Segerringzange ordentlich anziehen.
Ich habe noch ein wenig Teflonband aufs Gewinde gegeben. Bis jetzt ist es dicht.
Gruß, Michael

2-mal bearbeitet. Zuletzt am 12.03.17 06:56.
Anhänge:
Öffnen | Download - image.jpeg (99.8 KB)
Öffnen | Download - image.jpeg (94.4 KB)
Re: Simplify3D und Diamond Hotend
13. March 2017 11:19
Hi Michael
Ich habe den Smart Controller mit Display. Bei mir wird leider nur der erste Extruder angezeigt, besser gesagt nur Einer ????
Hast Du auch in Marlin lediglich die Temp Pin's auf 15 geändert ? oder hast Du noch was verändert ?
Mit welchem Programm arbeitest Du ( Repetier, S3D, oder Cura ? )
Welchen Sicer benutzt Du, damit alle 3 angezeigt werden ?
Grüße
Martin
Re: Simplify3D und Diamond Hotend
15. March 2017 01:31
Ich verwende diese Version und musste sie noch zusätzlich anpassen:

[github.com]

Die Erweiterungen für Diamond oder dreifach Extruder erscheinen mir nicht ganz vollständig.
Ich werde die Änderungen noch beschreiben.

Gruß, Michael
Re: Simplify3D und Diamond Hotend
15. March 2017 04:34
Hi Michael
Diese habe ich auch benutzt.
Kannst Du mir mal Deine Config.h,Config.adv.h und Deine Pins.h geben ?

Hast Du Ramps oder Rumba Board ?
mfg
Martin
Re: Simplify3D und Diamond Hotend
18. March 2017 10:15
Hallo,
ich verwende Ramps und das Vollgrafikdisplay.
Gruß, Michael
Anhänge:
Öffnen | Download - configuration.h.docx (495.9 KB)
Öffnen | Download - configuration_adv.h.docx (490.4 KB)
Öffnen | Download - pins.h.docx (503 KB)
Re: Simplify3D und Diamond Hotend
19. March 2017 06:02
Hi
Danke Dir mal, werde mal vergleichen und dann berichten woran es lag...
mfg
Martin
Re: Simplify3D und Diamond Hotend
19. March 2017 06:23
Hallo Martin,
Die Einstellungen in s3d überschreiben zum Großteil die Einstellungen in Marlin. Ich habe zwei verschiedene Extrudertypen. Es war mir nicht möglich, das mit Marlin und s3d richtig einzustellen. Ich habe mir nun für den dritten Extruder den gleichen wie die beiden anderen bestellt. Damit wird es sicher einfacher. Es kommt mir so vor,Mals würde Marlin nur die Einstellungen für den ersten Extruder auf alle anwenden.
Größtes Problem war der Retract bei Werkzeugwechsel und der Vorschub beim Normaldruck. Da müsste ich für den Direktantrieb alles mit einem Faktor beaufschlagen.
Woran ich noch knabbere, ist der Farbwechsel.
In Simplify3d muß man drei Prozesse definieren und diese dann dem jeweiligen Modell zuordnen.
Gruß, Michael
Re: Simplify3D und Diamond Hotend
19. March 2017 13:41
So, der erste Versuch mit drei Farben. Leider sehr unbefriedigend, denn ich wollte eigentlich, daß die Umrandung mit der neuen Farbe gedruckt wird.
Aber er druckt alle mit dem ersten Extruder. Dadurch ist das Ergebnis unbrauchbar.
Wie bekomme ich s3d dazu, daß die Unrandung mit den neuen Werkzeug gedruckt wird?
Anhänge:
Öffnen | Download - image.jpeg (83.1 KB)
Re: Simplify3D und Diamond Hotend
20. March 2017 15:37
Was ist die Umrandung? Ooze Shield? Du kannst dort einstellen, welcher Extruder verwendet werden soll. Am Besten im Preview Mode das Coloring auf Toolhead stellen. Dann siehst du es auch vor dem Drucken.


Piepiep (CoreXY) 290x300x205, ArduinoDUE, RADDS, TMC2100, Z-Riemenantrieb, Raspi3
Re: Simplify3D und Diamond Hotend
06. April 2017 15:06
Hallo,
ich habe das Problem nun ein wenig untersucht. Ich versuche drei Würfel mit drei Farben zu drucken. Jedem Würfel habe ich einen Prozess zugeordnet. Jeder Prozess hat einen der drei Extruder.
Ich habe in jedem Prozess einen Startpfeiler aktiviert. Wenn ich so zur Druckvorbereitung gehe, dann bekomme ich die drei Würfel mit ihren Startpfeilern und kann die auch so drucken.

Wenn ich aber Raft verwende, dann gibt es das Raft nur in der ersten Farbe. Wäre ja nicht so schlecht.
Wenn ich mit Raft nur einen der drei Prozesse drucke, dann gibt es das Raft in der richtigen Farbe und auch den jeweiligen Startpfeiler.

Wenn ich zwei (beliebige) Prozesse drucke, dann gibt es das Raft in der ersten Farbe und zwei Würfel, aber nur einen Startpfeiler. Dieser wird abwechselnd in den jeweiligen Farben gedruckt. Geht ja auch noch...

Wenn ich aber alle drei Würfel drucke, dann gibt es Raft wieder in der ersten Farbe, aber nur einen Startpfeiler und den auch nur in der ersten Farbe. Das ist ganz schlecht.
Denn dann wird der Farbrest nicht ausgeräumt und damit ist der Pfeiler sinnlos.
Das gleiche gibt es auch, wenn ich Schürze/Rand verwende.
Wer weiss Rat?
Gruß, Michael
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen