Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Z-Probe Höhe stimmt nach G32 nicht mehr

geschrieben von GrillSgt 
Z-Probe Höhe stimmt nach G32 nicht mehr
17. April 2017 07:08
Hallo,

ich habe einen P3 mit Repetier als Firmware und ihn vor einigen Monaten um ABL mit einem kapazitiven Sensor erweitert. Nach langem hin und her mit der Repetierfirmware habe ich es nun soweit, dass er schaltet und auch das Bett vermisst (BED_LEVELING_METHOD 1) in der configuration.h

Aber immer habe ich das Problem, dass das Leveln einmal klappt und beim nächsten Mal G32 steht die Düse meist zu hoch über dem Druckbett und ich weiß enfach nicht warum das so ist.
Ich lasse normal immer im GCode machen
M321 (deaktiviert ABL)
M322 (löscht die gespeicherten Werte der letzten Messung)
G28 X0 
G28 Y0
G0 X100 Y100
G32
M320 S2

Eigentlich wäre das Ausführen von G32 vor jedem Druck ja gar nicht nötig, da laut Repetier Seite durch M320 S2 die Werte gespeichert werden und so auch einen Reboot vom Drucker überleben (es würde mich aber auch nicht stören wenn es dann funktionieren würde).

Mache ich aber einen Reset hat der Drucker keine Ahnung mehr wo Z sich befindet (Höhe des letzten Druckobjekts).
M114 liefert dann Z = 0 und auf dem Display bzw. n Repetier Host stehen irgendwelche Werte die völlig sinnfrei sind.
Das wäre ja alles nicht schlimm, da es doch bei einem anschließenden G32 wieder richtig gestellt werden müsste, oder?! - Hier habe ich dann aber das Problem, dass der Abstand dann zum Druckbett trotzdem nicht mehr stimmt (zu hoch um ~0,5 mm).

Z_PROBE_HEIGHT habe ich auch mehrfach schon vermessen. Einen Endstopschalter für Z verwende ich nicht mehr. Empfehlung ist ja Z nach MAX zu homen. Bisher bin ich aber auch nach x-Mal lesen von der Beschreibung bei Repetier (https://www.repetier.com/documentation/repetier-firmware/z-probing/) daraus nicht schlau geworden.
Oder ist die Lösung des Home nach Z max:
G0 Z200 (MAX) nach dem Druck.

Und dann vor jedem Druck
G92 Z200
damit der Drucker weiß wo tatsächlich steht?

Sorry für die Fragen, aber ich seh den Wald vor Bäumen nicht mehr. Bin schon fast soweit, dass ich überlege dass ABL wieder abzubauen.

Hat jmd. von euch hier ne Idee?

Bin für jede Info dankbar!

Viele Grüße
Michael

1-mal bearbeitet. Zuletzt am 17.04.17 07:13.
Re: Z-Probe Höhe stimmt nach G32 nicht mehr
17. April 2017 11:02
G32 S2
Speichert die Werte, so wie ich es lese. Und
M320 S2 ; Activate auto level permanently
aktiviert eben nur autol level permanent. Persönlich habe ich nur 1x M320 S2 gemacht und nach Düsenwechsel mache ich einmal G32 S2.


Piepiep (CoreXY) 290x300x205, ArduinoDUE, RADDS, TMC2100, Z-Riemenantrieb, Raspi3
Re: Z-Probe Höhe stimmt nach G32 nicht mehr
17. April 2017 12:14
Moin moin aus HU.
Wenn ich etwas drucken möchte, mache ich nach dem Einschalten und Aufheizen einmal
G28 X0 Y0; // Homing nur für X und Y
G1 Z10; // wenn er zu nahe am Bett steht funktioniert z-Probe nicht
G32 S2 ; // Autobedleveling und Stand abspeichern
G1 X0 Y0 F9000; // zurück nach Hause.
Das habe ich unter Skript 1 im Host abgelegt. Also einmal die 1 drücken nach dem Aufheizen und gut.
Dann beginne ich mit dem Drucken. Neu leveln tue ich nur, wenn ich den Drucker mal abgeschaltet habe.


Liebe Grüße aus Henstedt-Ulzburg.
Frithjof
Meine Seite
[www.facebook.com]
Re: Z-Probe Höhe stimmt nach G32 nicht mehr
18. April 2017 13:42
Danke für eure Hinweise. Ich probiere Morgen mal eure Tipps und werde berichten.

Aktuell lasse ich nun Z auf 200 fahren (nach dem Druck). Diesen Wert kenne ich dann ja. So lang der Drucker die Verbindung nicht verliert bzw. ein Reset gemacht wird, behält er diese Z-Werte auch bei (benutze Repetier Server). Ansonsten mache ich nun immer (manuell) ein G92 Z200 und beginne dann mit dem Druck. Theoretisch könnte ich ja, im Start GCode immer ein G92 Z200 machen. Aber dann zeigt Reptier Host dass Modell leider fehlerhaft an (200 mm unter 0 - siehe Anhang). Leider scheint mir Repetier Host (+ auch der Server) manchmal etwas buggy zu sein - wenngleich ich es dennoch gern benutze.

Lasse nun auch nicht mehr vor jedem Druck leveln. Mir ist nämlich aufgefallen, dass Slic3r immer erst das Bett aufheizt bevor der Start-GCode zum Tragen kommt. Und beim kapaztiven Sensor kann es dadurch wohl zu Falschmessungen kommen

1-mal bearbeitet. Zuletzt am 18.04.17 13:49.
Anhänge:
Öffnen | Download - z-200.PNG (31.2 KB)
Re: Z-Probe Höhe stimmt nach G32 nicht mehr
19. April 2017 07:40
Die Lösung für mein Problem ist gefunden. Ab Version 1.0.0 ist es in Repetier FW möglich den Z-Probe als Z-Min Endstop zu verwenden.
Re: Z-Probe Höhe stimmt nach G32 nicht mehr
19. May 2017 16:47
Quote
GrillSgt
Die Lösung für mein Problem ist gefunden. Ab Version 1.0.0 ist es in Repetier FW möglich den Z-Probe als Z-Min Endstop zu verwenden.

Morgens,

Da ich mit Englisch nicht gut zurecht komme, könntest Du das erklären? Das mit dem Zmin würde mich sehr interessieren, ich Home immernoch nach Z max, was immer ewig dauert. Hast Du das Problem mit der ändernden Z Probe Höhe gelöst?
Was macht der Drucker wenn er zwischendurch beim Drucken auslöst, oder interessiert ihn das dann nicht mehr?

Danke



Printrbot Simple Metall mit Heizbett und Buildtak Folie

Sparkcube V1.1 XL mit Mega2650, Ramps 1.4, NEMA 17 2,5A. 1,8Grad. [forums.reprap.org]
(Umbau der Z Achse auf Riemen und 4 Führungswellen)

Aktuelle Überlegungen abgeschlossen, es geht los einen Drucker mit Bauraum 400x200x150 und Dualhotend [forums.reprap.org]

————————————————————————————————————————————————————————
Alle sagen es geht nicht. Dann kam einer, hatte keine Ahnung und hat es gemacht!

Wer Rechtschreibfehler findet darf Sie behalten.
Re: Z-Probe Höhe stimmt nach G32 nicht mehr
01. October 2017 12:08
Hallo,

habe das Problem seit Monaten gelöst - ja. ich lasse nur noch ab und an mal das Auto-Bed-Levelling durchführen. Ich weiß nicht mehr genau wie der Sensor als Z-Home definiert wurde in Repetier. Steht aber hier. Und ich home immer nach Z bei X und Y 100.

1-mal bearbeitet. Zuletzt am 01.10.17 12:11.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen