Re: 1/128 Microstepperdriver für RADDS
16. January 2015 12:30
Am Heizbett geht nur ein Mosfet zum Arduino. Warum setzt das dann so sehr die Spannung unter druck? Der Due wird doch über den anderen 12V-Anschluss versorgt. Wenn das so ein Problem ist wird ne Elko oder so die Spannung am Due auch nicht halten. Hat nicht irgendwer was von geschrieben dass nicht die 3.3V sinken, sondern am GND was steigt? Über was habt ihr die 3.3V gemessen, also wo war eure Masse?


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: 1/128 Microstepperdriver für RADDS
16. January 2015 12:48
Wird wohl irgendwie ein Masse Problem sein....
Hast du bitte mal eine Idee ( ohne das arduino due umzubauen), die wir mal ausprobieren könnten wurstnase ?


Mein Club: [hackerspace-ffm.de]
RADDS-Shield -> Commercial [max3dshop.de]
Re: 1/128 Microstepperdriver für RADDS
16. January 2015 14:15
Ne, aber ich denke aber auch nicht dass der kleine Peak unser eigentliches Problem ist. Diese kurzen Aussetzer werden von der Regelung ausgeglichen.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: 1/128 Microstepperdriver für RADDS
17. January 2015 02:07
eigentlich sind solche Peaks der Untergang jeder PID Regelung.
Re: 1/128 Microstepperdriver für RADDS
17. January 2015 05:49
Gebe ich dir recht. Ich habe mich vielleicht falsch ausgedrückt.

Die Peaks wenn die Spannung fällt, sind beim Regeln quasi nicht vorhanden. Zumindest nicht in der Intensität die Angelo beschrieben hat. Diese sind deutlich kürzer und müssten eine andere Ursache haben. Ich guck mir das nochmal genauer an.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: 1/128 Microstepperdriver für RADDS
18. January 2015 05:29
könntest einen Plausibilität filter einbauen grinning smiley und die Peaks einfach rausschmeißen grinning smiley
Re: 1/128 Microstepperdriver für RADDS
18. January 2015 06:17
@Angelo
Das Einschaltproblem vom Heizbett kann ich nachvollziehen. Sobald ich ein SSR dazwischen habe ist es weg.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: 1/128 Microstepperdriver für RADDS
19. January 2015 02:26
Hallo,
erstmal danke an Angelo und Sascha.
ich hab meine Config soweit angepaßt.
Die Motoren für X und Y laufen jetzt bei einer Ref von 1,5V also etwa 1,4A
Der Z Motor brummt und vibriert bei manchen Stellungen. Hier bin ich wieder runter auf 1,1V
Heute Abend hab ich hoffentlich wieder mehr Zeit um das nochmal länger zu beobachten.
Mein Versatzproblem ist geblieben.
Merkwürdigerweise sind es nur einzelne zusammenhängende Layer mal 1 dann 3. also mal 1 Layer um 4/10 verschoben dann wieder normal.
Ich werde Die Tage die Z Achse eh nochmal umbauen. Ich hab ja noch ein generelles Richtproblem der Z Achse, das erklärt die gleichmäßige Wellen aber eigentlich keinen Sprung.
Angehängt mal ein Druck. Layer 0.1mm. Nicht so schön wie der von Angelo, aber mein Sohn wollte so einen haben seitdem ich das Wort 3D-Drucker das erste mal in den Mund genommen hatte. Am Kinn sieht man noch den Layerversatz ganz unten, dann bin ich auf 70% Speed gegangen und habe die Mehrzeit in kauf genommen smiling smiley An der Stirn hat er eine Bahn vergessen,nicht gemacht. Hat einer noch nen Tip für die Vertikalen Streifen an der Stirn ? Kann der erste Strich der Reject sein ( layerwechseln) und die darauf kleineren das sozusagen das Echo bis das Material wieder gleichmäßig fließt?
Lumizenz Blau von ESUN.

Re: 1/128 Microstepperdriver für RADDS
19. January 2015 03:33
Hi Fastsonic,

für den ersten Druck schon mal nicht so schlecht :-)

Hast du die RAPS128 schon mal einfach umgesteckt, um zu sehen ob vielleicht doch ein RAPS128 kaputt ist?
Wenn unwahrscheinlicher weise Ja, sende ich dir umgehend kostenfreien Ersatz und entschuldige mich.
Bitte versuche auch die Elektronik in diesem Fall ordentlich zu Kühlen
(ist wohl in einem Gehäuse die grünen Kühlrippen brauchen viel kalte Luft zum Kühlen)

Stell auch mal die Feeds in Z (mm/s) vorsichtig so ein:
#define MAX_FEEDRATE_X 100
#define MAX_FEEDRATE_Y 100
#define MAX_FEEDRATE_Z 4
#define HOMING_FEEDRATE_X 60
#define HOMING_FEEDRATE_Y 60
#define HOMING_FEEDRATE_Z 4
#define HOMING_ORDER HOME_ORDER_XYZ
#define ENABLE_BACKLASH_COMPENSATION 0

Auch glaube ich, das der Extruder wenig Bums hat (retract...) ..
Probiere mal auf 1/32 Steps und auf 1,5 Volt-Ref
#define EXT0_MAX_FEEDRATE 150
#define EXT0_MAX_START_FEEDRATE 30
#define EXT0_MAX_ACCELERATION 2000

Weeenn das dann Funktioniert, kannst du die Werte deiner Mechanik nach oben hin vorsichtig und schrittweise anpassen.

So würde ich persönlich das einfach einmal versuchen.

Wenn es nicht klappt, gib noch einmal bescheid.

Das kriegen wir hin :-)

Gruss Angelo

1-mal bearbeitet. Zuletzt am 19.01.15 03:36.


Mein Club: [hackerspace-ffm.de]
RADDS-Shield -> Commercial [max3dshop.de]
Re: 1/128 Microstepperdriver für RADDS
19. January 2015 19:29
Ich hab meinen Fehler bezüglich der verschobenen Layer gefunden.
Mechanik.
Druckplatte war auf X nicht richtig fest. Und bei Belastung gab sie auf x nach. Beim langsam fahren alles gut. Beim schnellen fahren rutschte mal die x das Zehntel vor oder zurück.
Wunderte mich warum bei einem Druck von 150mm/s die layerverschiebung identisch blieb...
Zumindest druckt mein Drucker noch recht sauber bei 150mm/s
Was noch bleibt sind die brummenden Motoren. Aber da hab ich ja auch mit Angelo das Problem gefunden und sollte bald aus der Welt sein.
Danke an alle für die Hilfestellung. Ich werd versuchen meine Fehler mal zusammenzustellen und hier rein zu pinnen.
Gruß
Fastsonic
Re: 1/128 Microstepperdriver für RADDS
20. January 2015 00:25
vor allem wie du das brummen der motoren wegbekommen hast wäre interessant.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen