Leadshine Steppertreiber am Rumba board
19. September 2015 05:22
Hallo Leute,
hat von Euch schon mal jemand versucht einen Leadshine Treiber M542 an einem Rumba board zu betreiben?
Ich benötige etwas mehr leistung als man aus den Pololus bekommt, daher möchte ich geren die 4,2A Treiber benutzen. Als Firmware möchte ich weiter die Repetier benutzen.

Ich frage mich weilch Ansteuerungsvariante ich benutzen muss NPN oder PNP.

[www.leadshine.com]

Vielen Dank für eure Unterstützung
Philipp
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 05:39
Du holst dir mit ner kleinen Adapterplatine einfach Step/Dir/Enable rüber...und testest. Enable low sollte passen, das kommt so aus Rep, soweit ich weiß, bei Step und Dir musst du testen. Aber auch das kann man in der Firmware alles invertieren.

Gruß


[www.facebook.com]

Power is nothing.....without control!
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 05:56
Hallo Stud54,
so wie ich das verstanden habe benötige ich Enable nicht dann läuft der Teriber immer. Aber die Frage die sich mir stellt ist klemme ich das Dir und Step signak an den Minus- oder an den Plus-Kontakt des Leadshine Treibers?

Denn die Motoren sind bestromt, aber drehen sich nicht. Wenn ich ein Fahrsignal aus Repetier starte. Kann es sein, dass die Signale zu schnell sind? oder muss ich da noch einen Widerstand zwischen schalten? Im Manual des Treibers ist ein Widersatnd vorgesehen, doch ich bin der Meinung der ist schon auf dem Rumbaboard integriert.
Ich teste im lastfreien Fall, die Motore sind nicht mechanisch angeschlossen.

Vielen Dank
Philipp
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 06:05
Ne völliger Quatsch der Widerstand muss 0 sein da wir ja mit 5V arbeiten. Das ist nicht der Fehler.
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 06:24
Eben....

Aber so wie ich das lese...will die Endstufe ein High auf Enable....oder???

Gruß


[www.facebook.com]

Power is nothing.....without control!
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 12:37
Da steht so etwas wie üblicher weise nicht verbunden.
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 12:50
Naja....komisch.
Ich hab eben keine hier...sonst würde ichs mal testen.

Hab noch ne TrippleBeast hier...die braucht ein Low als Enable, die Raps vom Angelo ein High und die Pololus eben fast alle ein Low.

Häng halt mal 5V dran. Da kann nix kaputt gehen...falls du Schiss hast. Die Eingänge sind hochohmig genug.


[www.facebook.com]

Power is nothing.....without control!
VDX
Re: Leadshine Steppertreiber am Rumba board
19. September 2015 17:04
... ich habe diverse Industrie-Treiber von Nanotec, IMS oder Precitec (Berger-Lahr) mit der alten Gen3 und den ersten Megas betrieben - die hatten noch 5V Ausgangsspannung, die Eingangspins der Treiber waren aber meist unterschiedlich anzusprechen.

Bei Precitec waren die Logik-Pegel gleich, brauchten bei 24V - die konnte ich aber duch Wechseln der internen Widerstände auf 5V reduzieren ... die IMS haben schnelle Optokoppler als Eingänge, da mußte ich auch nur die Vorwiderstände der Eingangsdioden für 5V statt 24V anpassen ... die alten Nanotec waren die einzigen, die standardmäßig mit 5V zurechtkamen - neuere von denen sind aber auch wieder auf 24V definiert ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 05:49
Hallo Leute,

Vielen Dank für Eure Unterstützung. Es liegt nicht an dem Enablesignal, egal ob angeklemmt oder nicht der Motor blockiert. Ich habe irgenw wo mal gelesen dass die Pololu-Treiber mit einer höheren Frequenzarbeiten (kürzere Delay-Zeit) können als diese leistungsstärkeren Treiber.

Ich habe mir die Treiber noch einmal angesehen, mir ist bei meiner anfänglichen Beschreibung ein Fehler unterlaufen, der Herstelletr heißt "Longs" und nicht Leadshine, die Typenbezeichnung lautet "DM542a". Die dokumentation von Longs ist wesentlich lückenhafter als die von Leadshine, Es siht aber so aus als wären das 1:1 Nachbauten der Leadshine Treiber.

Vielleicht hat von Euch jemand Erfahrungen mit diesen Treibern, die mir weiter helfen können.
Viele Grüße
Philipp
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 06:02
Wenn der Motor immer blockiert musst du mal das Enable invertieren.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 07:33
Hallo,
das Enablesignal zu invertieren bringt den erwartungsgemäßen Effekt, der Motor blockiert weiterhin. Alo noch einmal zu besseren Verständnis. Wenn ich bei ausgeschaltetem Strom den Motor mit der Hand verdrehe, dann den Strom einschalte rastet der Motor in die nächste Rastposition ein. Soweit ist das auch sinnvoll. Das Zeigt, dass der Motor am richtigen Treiber angeschlossen ist und das der Treiber enabled ist, sonst dürfte er den Motor nicht bestromen. Wenn ich nun im RepetierHost einen Fahrbefehl absondere passiert nichts, der Motor bewegt sich nicht und gibt auch keine Geräusche ab.

Jetzt liegt der Verdacht nahe, dass die Temperaturüberwachung in der Firmware mir einen Streich spielt. Also habe ich den Extruder und das Heizbett eingeschaltet und hochgeheizt, das funktioniert prima, doch der Motor bewegt sich nicht er blockiert weiter hin.

Jetzt wäre es natürlich schön wenn man sich ansehen könnte wie die STEP-Signale aussehen und ob die auch ankommen. Hat jemand eine Idee wie ich mir diese Ansehen kann

Vielen Dank für Eure Tips.
Philipp
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 07:37
So ich habe nun den Motor an stelle der Z-Achse angeschlossen und siehe da er bewegt sich.
Es gibt also ein Problem auf der Extruder-Achse.

Enable ist nicht angeschlossen

1-mal bearbeitet. Zuletzt am 21.09.15 07:38.
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 07:42
Bei normalen Treibern ist beim anmachen vom Board noch kein Strom auf den Motoren. Dieser ist erst aktiv wenn Enable aktiviert wird bzw. der Motor einen Verfahrbefehl bekommt. Und das ist je nach Stepper entweder High oder Low. Vorher lassen sich die Motoren drehen.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 07:43
Naja ...häng halt mal ein Oszi ran.
Sollte es Marlin sein...dann schalte mal die Sicherheitsfeature für gefährliche Bewegungen des Extruders ab...


[www.facebook.com]

Power is nothing.....without control!
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 09:26
Hallo,
also es liegt tatsächlich an den Sicherheitsabfragen. Es scheint die Min_Extruder_Temp gewesen zu sein. Die war mit 150°C offen bar zu hoch.

Vielen Dank für Eure Hilfe,
Re: Leadshine Steppertreiber am Rumba board
21. September 2015 09:46
Na dann.....hau rein und vergiss die Fotos hier nich...winking smiley


[www.facebook.com]

Power is nothing.....without control!
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen