Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Due + RADDS @ DIY core XY und nur Ärger

geschrieben von botchjob-rbt 
Due + RADDS @ DIY core XY und nur Ärger
01. May 2017 17:42
Drüben im "projekte" bereich habe ich einen Teil meines Leidenswegs bereits dokumentiert, aber ich glaube es macht sinn, hier das reine Elektroniktroubleshooting gesondert zu dokumentieren.

Ausgangslage:
Habe von Heapster sein Komplettset mit DUE, RADDS und Display übernommen. Treiber sind die RAPS 128

Konstruktion ist ein CoreXY, Motoren komplett NEMA17 von Wantai. Kabel im allgemeinen passend oder großügig dimensioniert.

Als Firmware war für Repetier geplant, da diese den RADDS unterstützt. Online configuration, compilieren und hochladen lief dann auch weitgehend problemlos.
1. auffälligkeit: schließe ich den due an einen 3.1 oder 3.0 USB Slot a, stottert die dort ebenfalls verortete USB Soundkarte. via USB 2.0 lässt sich mit der aktuellsten Arduino SW keine Verbindung zum DUE herstellen.

Erster Start:
LCD flackert gelegentlich, aber kein bild. motoren melden sich mit deutlichem "tacktack" und stehen dann unter strom, bewegen sich aber kein stück.
ansprache via Pronterface nicht möglich. findet keinen drucker am COM3 (den ich auch zum proggen nutze)

testweises drehen am Impulsgeber des Displays führte zu bewegung des vorderen linken motors. druckkopf bewegte sich ein paar milimeter auf beiden achsen.

weitere Schritte.
Firmware gegen Marlin4Due getauscht. drucker jetzt über Pronterface ansprechbar, aber nur das hotend.

[attachment 93596 igor_is_alive.jpg]

sobald ich das LCD wieder anklemme weigert sich der Drucker kontakt mit Pronterface aufzunehmen. unabhängig davon ob das LCD in der Firmware aktiviert wurde oder nicht.

Hotend: thermistor gibt daten aus die realistisch sind (mit pyrometer verglichen und für gut befunden), hotend heizt auf. sonst aber schweigen im Walde, alle Symptome wie oben beschrieben.

Endstops: habe hier im forum über ärger mit den Endstops gelsen und das ganze daher mal getestet:
über command M119 kommen recht wiedersprüchliche angaben ob man denn nun triggered oder nicht. zum start geben sie korrekt "open" aus, wenn man die taster einmal aktiviert hat, bleiben sie auf high/triggered. mit dem multi ausgemessen aber keine auffälligkeiten, verhalten sich wie gewöhnliche taster ...

die endstops komplett zu "//" provozierte auch keine neue reaktion des Druckers.

Treiber: Spannung der Treiber ist bei 3/4 1,5, bei einem 1,39V, also auch alles im Bereich des "soll"

so weit so ratlos. mir gehen langsam die ideen aus, wo ich noch suchen könnte.

3-mal bearbeitet. Zuletzt am 01.05.17 18:00.
Re: Due + RADDS @ DIY core XY und nur Ärger
01. May 2017 17:51
Probier mal die gesamte Spannungsversorgung NURNOCH über das Druckernetzteil zu erledigen, also im USB Stecker am RADDS den 5V-Pin abkleben (dazu reicht ein schmaler Streifen Isolierband). Damit schließt du aus das Dein USB-Port überlastet wird (stottern der Soundkarte deutet auf überlast) der kann am PC nur ca 500mA liefern.


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
02. May 2017 16:06
mhh der stototototerer tritt auch auf wenn nur der due am port hängt, aber ich schau mal ob die abklebeaktion was bringt. das RADDS board hat keinen eigenen port, aufm due ists so ein microusb anschluss. das wird was frickelig winking smiley
Re: Due + RADDS @ DIY core XY und nur Ärger
02. May 2017 16:24
Dann nimm den Stecker am Rechner winking smiley der iss was grösser. Ansonsten könnte noch der Schnittstellen Baustein auf dem DUE (müsste beim Original ein 8-Bit Atmega sein) eventuell defekt oder zerflasht sein. Bei nem Due-Clon ist meistens ein ziemlich merkwürdiger Verbaut da muss dann der Treiber stimmen.


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 04:37
Hast Du das DUE mal nackt angeschlossen? Also ohne Display und RADDS? Stottert die Soundkarte dann auch noch? Flackerndes Display spricht eigentlich dafür dass der Stecker auf dem RADDS falsch rum drauf ist.
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 13:33
ja völlig nackt, stottert trotzdem. dürfte auch ein original due sein - made in italy, arduino.cc
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 14:42
Nimmst Du auch den Richtigen USB am Due ? Der hat ja 2 davon (einmal Programming und einmal Nativ)

1-mal bearbeitet. Zuletzt am 03.05.17 14:44.


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 14:59
hopefully. nutze den programming port (näher am stromanschluss) für flashen und ansprache via pronterface. native port stottert nicht, connected aber auch nicht (weder noch)
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 15:32
Hat das Board denn beim Vorbesitzer funktioniert ? Will dem Kollegen jetzt nix aber könnte ja ein Transportschaden entstanden sein ?


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 15:50
Bei mir bewegte sich der Kopf auch leicht wenn ich am Rad drehte. War das Kabel das falsch rum draufsteckte und eher durch die permanenten Resets verursacht die das auslöste. Dreh mal die Stecker rum. Probier auch nochmal einen anderen PC/Laptop aus und alles auszuschliessen. Aber es klingt immer mehr nach nem defekten DUE.
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 17:13
chrchr ... teilproblem gelöst. LCD war tatsächlich verpolt, wenn ich im MARLIN4DUE das passende display definiere wirds auch lustig angesprochen und ich kann im Menu spielen. dokumentation war da maximal irreführend.

motoren blocken und lösen sich aber weiterhin nach zufallsmuster, bewegen sich keinen mm, auch wenn ich via "prepare" irgendwelche werte dort reihacke, endstops scheinen auch nicht klar zu triggern. preheat und coolddown lasssen sich via display auslösen.

soweit also same same aber statt auf 24" auf 4x16

2. rechner ist grad nicht greifbar, muss am WE mal nen image clonen und nen alten lappi reaktivieren. danke schonmal für die Hilfe. ich hoffe ja noch, dass das prob im Human layer liegt (siehe verpolung) und ich mir den austausch von Hardware sparen kann.

1-mal bearbeitet. Zuletzt am 03.05.17 17:14.
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 17:51
Moin moin aus HU.
Hast Du in der FW bei den Steppern zufälligerweise das EN-Signal invertiert. Dann hängen die Motoren in Ruhe immer am Strom und bein Ansteuern laufen sie nicht.


Liebe Grüße aus Henstedt-Ulzburg.
Frithjof
Meine Seite
[www.facebook.com]
Re: Due + RADDS @ DIY core XY und nur Ärger
03. May 2017 18:49
oha. war nicht invertiert, hätte aber sein sollen. jetzt bewegt sich was.

unter prepare move axis x .... bekomme ich sehr viel bewegung nach links aber nur minimale bewegung nach rechts. andere noch nicht getestet. jetzt erstmal bett. gn8.
Re: Due + RADDS @ DIY core XY und nur Ärger
05. May 2017 11:24
Original Arduino Due und das LCD flackern hört wie Magie auf :-).
Arduino/Genuino hatten Streit und Lieferterminprobleme, sodass ich ebenfalls auf die Clone ausgewichen bin (saintsmart due)
Jetzt wieder alles gut ...
Ich kaufe gern bei exp-tech :-)

Alternativ nach Bestromung erst mal reset ...

Wenn ich persönlich einen due einbaue, wo gleich das Display flackert, schmeiße ich das gleich in die Tonne.
Irgendwie funktioniert dann alles nicht so richtig :-(.

Bitte erst Mal aufmerksam doku.radds.org lesen, dann alles gut :-)

Gruss
Angelo


Mein Club: [hackerspace-ffm.de]
RADDS-Shield -> Commercial [max3dshop.org]
Re: Due + RADDS @ DIY core XY und nur Ärger
13. May 2017 08:27
hi angelo,

die ersten probleme sind gelöst, die verkabelung war verpolt und das motorstartsignal musste invertiert werden -> done.

wie das so ist, es kommen gleich neue winking smiley

gegenwärtig versuche ich x + y zum "homen" zu bewegen. sobald ich jedoch die endstops treffe (egal welchen) erhalte ich massives "rattern", videos @ twitter:

[twitter.com]

[twitter.com]

macht dabei keinen unterschied ob ich via pronterface oder displayinput die endpunkte anfahre oder ob ich erst y oder erst x home.

kinematik für repetier: z-axis + XY H-Gantry / core XY (x-motor = x+y, y-motor = x-y)

edit:

die druckerhardware: [forums.reprap.org]

edit2: die endstops sind ok, via multi durchgemessen und die dinger schließen korrekt. wenn ich jedoch den Status der stops via M119 abfrage wird fälschlicherweise "L" ausgegeben. endstops sind mit schlichter litze an die signal points des RADDS angebunden.

edit3: wenn ich via prntrface die x / y achse manuell verfahre stoppt er irgendwann und lässt sich erst nach manual reset am display wieder zur kooperation bewegen

BG

R

3-mal bearbeitet. Zuletzt am 13.05.17 08:41.
Re: Due + RADDS @ DIY core XY und nur Ärger
13. May 2017 08:52
Das "Rattern" kommt davon weil du zwar die Endschalter triffst diese aber nicht richtig in der Firmware eingetragen sind und demnach nicht auslösen. Wie sind deine Endschalter denn angeschlossen ? Als öffner oder schliesser ? Wie sind deine Pullups in der Firmware eingestellt ?


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
13. May 2017 11:15
Dreh mal am Rädchen vom Display. Da kommt dann irgendwo eine Seite mit den Endstopstati. Geht zwar auch per gcode, des ist aber jetzt zu kompliziert. Wenn du die Seite hast, lös mal doe Endstops mit den Fingern aus. Die sollten mit ein wenig Verzögerung auch auf dem Display schliessen.

Die Endstops sollten auch auf der Seite sein, wohin gehomed wird.

Trifft eines der beiden Sachen nicht zu, musst du die Einstellungen in der Firmware anpassen.
Re: Due + RADDS @ DIY core XY und nur Ärger
13. May 2017 15:50
@ kleiner Drache

sind angeschlossen als open type,

#define ENDSTOP_PULLUP_X_MIN true
#define ENDSTOP_X_MIN_INVERTING true

(gleiche einstellung für alle anderen stops)

im cfg tool: switch on GND, normally open (interpretiere ich mal als stromkreis NICHT geschlossen)

in hardware:





@ warmduscher:
x-max switch tut was er soll. wenn ich da drantippe zeigt im display das recht der beiden kästchen aktivität

y-min macht garnichts, z-min triggert y UND z und bleibt dann auf "high" (linkes kästchen) bis man die ganze kiste resettet




------

um x zu triggern muss ich deutlich länger den finger auf dem taster halten als bei z (kabellänge?) dürfte ca 0,25 -0,5 sekunden unterschied sein, in jedem falls deutlich zu spüren.

1-mal bearbeitet. Zuletzt am 13.05.17 16:16.
Re: Due + RADDS @ DIY core XY und nur Ärger
13. May 2017 18:26
sollten bei deiner Firmware Einstellung und NO Tastern zwischen GND und Signal angeschlossen sein.

#define ENDSTOP_PULLUP_X_MIN true (ok Pullup ist an Eingang hat High)
#define ENDSTOP_X_MIN_INVERTING true (das High wird invertiert was dein M119 L erklärt)

ändere mal auf

#define ENDSTOP_X_MIN_INVERTING false


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
13. May 2017 19:19
mhh ne das isses nicht. jetzt sind die endstops von anfang an auf "high" und es bewegt sich naturgemäß wenig, weil man ist ja schon da, auch wenn der kopf noch mittem auf dem druckbett steht winking smiley

z-max triggert weiter y-min und z-max gleichzeitig. ne elektrische verbindung zwischen beiden kann ich nicht erkennen.
Re: Due + RADDS @ DIY core XY und nur Ärger
14. May 2017 02:10
Poste mal die Configuration.h der Firmware. eventuell sind auch die Anschlüsse der Endstops falsch. wieder hole mal den Test mit immer nur einem angeschlossenen Endstop. dann kriegste raus, welche Anzeige im Display mit welchem Pin aufm dem Board korrespondiert.

1-mal bearbeitet. Zuletzt am 14.05.17 02:10.
Re: Due + RADDS @ DIY core XY und nur Ärger
14. May 2017 05:25
der aktuelle zustand. endstops teste ich heute abend im dtail.

Konfigurations-Infos.txt

*** EDIT ***

... hängt doch so riesen-Textfiles als Angang dran, damit man nich soviel herumscrollen muß eye rolling smiley

1-mal bearbeitet. Zuletzt am 14.05.17 08:34.
Re: Due + RADDS @ DIY core XY und nur Ärger
14. May 2017 11:42
Das stimmt nie und nimmer:

#define X_MAX_LENGTH -200


und:

#define X_HOME_DIR 1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

solltest du eigentlich nicht brauchen, wenn Du sowohl min, als auch max Endstops hast. Bestimmte lieber den Nullpunkt so, dass er dort liegt wo Du ihn möchtest (z.B. links vorne am Drucker). Dann stelle die Firmware so ein, dass die Achsen sich richtig bewegen. Die Endstops und Homingrichtung solltest Du dann im Defaultzustand belassen können.

die hier ist auch definitiv falsch (Z-Axis deaktiviert):

#define DISABLE_Z 1

für den Anfang ok um nichts kaputt zu machen. Das sollte aber deutlich höher sein:

#define HOMING_FEEDRATE_X 10
#define HOMING_FEEDRATE_Y 10
#define HOMING_FEEDRATE_Z 2


Das ist mir nur beim Durchscrollen aufgefallen. Vermutlich sind da noch einige dicke Klopper drinnen. Wenn ich dir einen Tipp geben darf: Lass das mit dem Onlinekonfigurator. Lade dir die Firmware nackt runter und konfiguriere die Configuration.h im Arduinoeditor. Da hast du dann am Ende viel mehr Doku als Kommentarzeilen dabei und siehst was Du tust.
Re: Due + RADDS @ DIY core XY und nur Ärger
16. May 2017 15:52
nabend. die -200 waren mal zum testen.

enstops habe ich x auf dem hotend schlitten rechts, y vorne rechts am rahmen und z ebenfalls vorne rechts (druckplatte fährt nach unten). das interpretiere ich mal als x-max, y-min, z-min. daher die 1, -1 ,-1 an den stops

habe daher versucht den nullpunkt nach vorne rechts zu legen. speed habe ich idT bewusst so niedrig angesetzt, damit ich auf den notaus zimmern kann winking smiley

was ich weiterhin nicht verstehe ist das verhalten der min-endstops. x-funktioniert, y nicht, z schaltet y und z dauerhaft auf high. auf dem board kann ich keinen kurzschluss messen oder erkennen, es spielt keine rolle welchen taster ich dort anschließe.

wo erhalte ich die nackte firmware? direktdownload habe ich nicht gefunden, überall wird aufs tool verwiesen.

edit: unter den manual settings recht weit oben in der config.h habe ich folgende zeile gefunden, wo ich einen zusammenhang mit meinen endstoptroubles vermute. kann mir jemand erklären was die zeilen bedeuten ?

Quote
#undef Y_MIN_PIN

Quote
#define Y_MIN_PIN ORIG_Z_MIN_PIN

edit2: die zeilen tun genau das wonach sie aussehen, y-min abschalten und y+z zusammenlegen. WTF warum tut der onlineconfi sowas? gleiches siehe z disable, das hab ich da mit sicherheit nicht reingeschrieben.

4-mal bearbeitet. Zuletzt am 16.05.17 16:38.
Re: Due + RADDS @ DIY core XY und nur Ärger
16. May 2017 16:50
// ################ Endstop configuration #####################

#define ENDSTOP_PULLUP_X_MIN true
#define ENDSTOP_X_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_X true
#define ENDSTOP_PULLUP_Y_MIN true
#define ENDSTOP_Y_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Y true
#define ENDSTOP_PULLUP_Z_MIN true
#define ENDSTOP_Z_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Z true
#define ENDSTOP_PULLUP_X_MAX true
#define ENDSTOP_X_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_X true
#define ENDSTOP_PULLUP_Y_MAX true
#define ENDSTOP_Y_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_Y true
#define ENDSTOP_PULLUP_Z_MAX true
#define ENDSTOP_Z_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_Z true
#define max_software_endstop_r true

#define min_software_endstop_x false
#define min_software_endstop_y false
#define min_software_endstop_z false
#define max_software_endstop_x false
#define max_software_endstop_y false
#define max_software_endstop_z false

Herzl. Grüße
Re: Due + RADDS @ DIY core XY und nur Ärger
16. May 2017 17:22
Repetier PUR


Wer freundlich zu mir ist zu dem bin auch ich freundlich. Wer Schreibfehler findet darf sie gerne behalten winking smiley / Geeetech Prusa I3 ProX extended / Repetierhost / Mattercontroll / Slic3r
Re: Due + RADDS @ DIY core XY und nur Ärger
16. May 2017 17:45
@ alter bastler. jetzt nähern wir uns. beim anfahren der endstops hört das rattern nun nach 1-2 sekunden auf und es wird die "annäherungssqeuenz" abgefahren also 5mm, 3mm, 1mm, stop

bewegung über manuelles verfahren ist aber nicht drin, einmal geparkt ist feierabend und der drucker reagiert nur noch auf weitere homebefehle.
Re: Due + RADDS @ DIY core XY und nur Ärger
16. May 2017 18:19
#define X_MAX_LENGTH -200

Herzl. Grüße
Re: Due + RADDS @ DIY core XY und nur Ärger
03. June 2017 08:11
moin.

bin den ratschlägen gefolgt und habe mal eine jungfräuliche firmware aufgezogen. XY laufen jetzt auch recht genau so wie man das erwartet ohne irgendwelche seltsamkeiten in die homingsequenzen einzubauen.

Z macht mir aber noch sorgen. habe die seit dem letzten post nochmal komplett auseinandergenommen und sauberer ausgerichtet. die gewindestangen drehen jetzt ohne klemmereien. Die achse fährt aber etwas seltsam herum und homed nicht am endschalter usw. (mit der alten firmware hat sich X praktisch genauso verhalten) Siehe video (ton anmachen ...):

[twitter.com]

in dne schnell gefahrenen passagen sieht man auch, dass das geratter nicht sein müsste (klingt auch gleich ob ich 1/4 odr 1/16 Microstepping einstell)
wenn ich am display manuell rauffahre, dann verzählt er sich auch erheblich. gerne mal ein paar zig mm.

mit der alten firmware:
[twitter.com]
allet tutti ...

lüfter laufen auch nicht an, auch nicht, wenn ich am display manuell an oder aus schalte.

korrektur. manuell laufen die lüfter an (kontaktfehler), aber nicht automatisch beim aufheizen.

2-mal bearbeitet. Zuletzt am 03.06.17 09:47.
Anhänge:
Öffnen | Download - config_h-01-06-2017.txt (73.8 KB)
Re: Due + RADDS @ DIY core XY und nur Ärger
04. June 2017 07:35
Endstops. Gleicher Fehler wie oben.

Herzl. Grüße
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen