Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Ramps-Arduino-Kombo und Probleme

geschrieben von Minihawk 
Ramps-Arduino-Kombo und Probleme
07. July 2017 15:37
Hallo,
cih habe Anfang der Woche meine Ramps-Arduino-Kombo bekommen, die Firmware war schnell drauf gespielt, die Achsen fuhren auch schon korrekt (außer die Z-Achse, da hätte ich in der Firmware noch die Rcihtung ändern müssen), die Thermistoren haben korrekt gemessen, Extruder wie auch Heatbed konnten heizen.
Dann hat plötzlich der Arduino geraucht und danach war halt essig, keine Funktion mehr.
Was kann für das Ausfallen eines Arduino mega 2560 sorgen? Was ist auf der Platine ausgefallen? Warum?
Was hat die Diode damit zu tun? Wie kann man das verhindern? Ich vermute,d ass die Soannungsregelung auf dem Arduino Hops gegangen ist.

Danke für die Tipps.

1-mal bearbeitet. Zuletzt am 07.07.17 15:37.


liebe Grüße

Minihawk

*** In Wirklichkeit ist die Realität ganz anders ***
VDX
Re: Ramps-Arduino-Kombo und Probleme
07. July 2017 15:46
... vermutlich hast du den schwachen 5V-Regler überlastet - miß mal nach und evtl. kannst du den mit einer externen 5V-Quelle (und/oder austausch des defekten 5V-Reglers) wieder aktivieren ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 03:49
Es ist der AMS irgendwas-Spannungsregler, der kaputt ist. ich wüsste keinen grund,w arum ich den oder wie ich den hätte überlasten können. Es war halt die Kombo aus ARDUINO und RAMPS, keine weitren Spielereien. Die Firmware war drauf, die Motoren liefen schon, wenn auch noch in falsche Richtungen.
Ich vermute, dass der China-ARDUINO-Clone einfach entweder einen schlechten Chip drauf hatte oder in der Beschaltung Fehler gemacht wurden.
Auch ist der hohe Spannungsunterschied von 7V zwischen Eingang und Ausgang ein Problem, wohl insbesodere bei den China-Clones.

Ich kann jetzt über USB den Kram versorgen und drucken, ich werde eine andere Möglichkeit finden, den ARDUINO mit 5V zu versorgen.

Der Ebay-Händler, der sowohl RAMPS als auch ARDUINO geliefert hat (importiert selber wohl aus China) nimmt sich von Allem nichts an. Er meint, eine Gewährleistung komme nicht in Frage, da das ARDUINO ja gelaufen sei... Na, sei es drum, garantiert kein Händler, dem eine langjährige Existenz sicher ist.


liebe Grüße

Minihawk

*** In Wirklichkeit ist die Realität ganz anders ***
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 06:16
Moin,

um den zu killen reicht schon nen Falsch gepolter Endstop.....

Wenn Du einen Spannungsregler brauchst, schreib imr ne Nachricht... habe davon noch welche in der Grabbelkiste liegen.


Gruß
Gregor
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 07:01
Wie habe ich mir denn einen falsch gepolten Endstop vorzustellen? Die Teile sind bei mir Microschalter, die keine Verbindung zu plus oder Minus haben. Also sind sie beliebig auf der Platine anzubringen (verpolungssicher).

Auf dem RAMPS habe ich ja drei Pins für jeden Endschalter, lt. Firmware werden die Endschlater mit einem Pullup betrieben, den Schalter könnte man nun auf das Ramps-Board auf die falschen beiden Pinks stecken.

Meist du das? Das soll schon den ARDUINO Spannungsregler killen?

ich will eigentlich diesen SMD-Regler nicht tauschen, nur ausbauen und gegen einen Regler extern mit Switching-Technologie austauschen. Muss da aber noch mal drüber nachdenken. Vielleicht auch einen 78 xy 05, der 2A oder so kann. ich weiß nur nicht, ob die Teile mit den 7V-Differenz zurecht kommen.


liebe Grüße

Minihawk

*** In Wirklichkeit ist die Realität ganz anders ***
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 07:53
Einmal den Endstop falsch angeschlossen schon ist der Regler hin, da hat Gregor schon Recht.


Lars - Blog, Thingiverse, Git

After successfully ignoring Google, FAQ's, the board search and leaving a undecipherable post in the wrong sub-forum don't expect an intelligent reply.
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 09:05
Nun, es wäre halt gut, zu wissen, was unter "einmal falsch angeschlossen" zu verstehen ist. Das Ramps-Board hat drei Pinne. Nirgendwo findet man so recht die Belegung dieser Pins. Ist das (wennd as Ramps-Board vor einem liegt, die Spannungsversorgung rechts)

a.) Unten GND, Mitte Signal, Oben VCC

oder etwa

b.) Unten Signal, Mitte GND, Oben VCC

bei der zweiten Version würde ich das verstehen, da würde ein falsch aufgesteckter Endschalter beim Auslösen die Versorgungsspannung kurz schließen.
Die Belegegung wäre aber in dem Fall auch recht unsinnig gewählt.


liebe Grüße

Minihawk

*** In Wirklichkeit ist die Realität ganz anders ***
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 10:33



Lars - Blog, Thingiverse, Git

After successfully ignoring Google, FAQ's, the board search and leaving a undecipherable post in the wrong sub-forum don't expect an intelligent reply.
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 13:34
Hi, bei mir heute etwas ähnliches. Hab das ramps nur mit motortreibern angesteckt um alles mal zu testen, dann ausgemacht und essen gegangen. Beim wieder einschalten hat der piezzo vom full graphics display durchgehend gepfiffen und das display hat wirres zeug angezeigt. Hab dann das ramps abgesteckt und in die hand genommen, wobei ich gemert habe, dass der mega chip sehr warm war. Vlt kann mir ja einer von euch sagen, was ich da falsch gemacht habe, oder was da kaputt ist.

Mfg Moritz
VDX
Re: Ramps-Arduino-Kombo und Probleme
12. July 2017 15:19
... mit den Grafik-Displays, die über den 5V-Regler vom Arduino versorgt werden, ist das meist das gleiche Problem - nach ein paar Minuten ist der Spannungsregler überhitzt (da keine vernünftige Kühlung) und brennt dann auch gerne mal durch ... muß also nicht immer ein Kurzschluß durch falsch aufgesteckte Endschalter sein eye rolling smiley


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen