Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

TemperaturSensor nicht lesbar

geschrieben von netsnake 
TemperaturSensor nicht lesbar
06. February 2018 08:11
Hallo,
Bitte um kurze Hilfe:
Aus heiterem Himmel die Meldung Bett-Temperatur Sensor defekt
Anzeige 393°, was eher auf Kurzschluß deutet
Egal ob angesteckt oder nicht.
Sensor ist völlig ok. Crosscheck bestätigt den Fehler im Board.

1. Vermute ich richtig, dass da das MEGA2560 was hat? Am Ramps1.4 ist ja nicht viel dran, was hin werden kann.
2. Wie könnte ich den brach liegenden T2 Eingang auf die BettHeizung umleiten.

Bei der Abfrage mit M105 wird allerdings für T2 nur [email protected]:0 ausgegeben.

Danke schon mal.
Re: TemperaturSensor nicht lesbar
06. February 2018 10:17
In der pins_RAMPS.h Zeile 168ff, Pin 13 und 15 tauschen
// Temperature Sensors
//
#define TEMP_0_PIN         13   // Analog Input
#define TEMP_1_PIN         15   // Analog Input
#define TEMP_BED_PIN 14 // Analog Input
Herzl. Grüße

Edit: Sorry, 14 und 15 natürlich

1-mal bearbeitet. Zuletzt am 06.02.18 11:01.
Re: TemperaturSensor nicht lesbar
06. February 2018 11:24
Ah ja...
d.h ich muß das ding neu flashen und das ganze Arduinozeug wieder rauskramen, was ich seit 4 Jahren vergessen hab.. angry smiley

Danke jedenfalls
Re: TemperaturSensor nicht lesbar
06. February 2018 11:32
Um Deine Laune noch zu steigern: smiling smiley
Vor vier Jahren war Marlin anders organisiert, dann mußt Du in der pins.h suchen.

Herzl. Grüße
Re: TemperaturSensor nicht lesbar
07. February 2018 08:58
Alles gut,
geht wieder thumbs upsmileys with beer
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen