Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

TMC2100

geschrieben von PIPO881 
TMC2100
04. January 2019 09:24
Hallo Zusammen,

ich benötige einmal euren Rat in Bezug zu diesen Treibern die ich mir vor ca. 6 Monaten gekauft hatte:

[www.amazon.de]

Die Brücke für den spreadCycle Mode habe ich von GND auf CFG1 gelötet und diese Treiber dann auf ein Ramps 1.4 gesteckt..
Um die richtige Spannung einzustellen habe ich nichts gerechnet. Ich habe alle drei Treiber auf 0,8V eingestellt und habe dann die Spannung erhöht bis ich keine Schrittverluste mehr hatte. Waren dann alle drei bei 1,2V.

Und so liefen die jetzt auch die letzen drei Monate.
Jetzt allerdings, vor allem bei größeren Teilen (220 X 120 mm) macht mir die Y-Achse kummer. Hier bekomme ich wieder Schrittverluste. Bin jetzt schon bei dem Treiber der Y-Achse bei 1,4V angelangt, ohne eine Besserung zu erkennen.
Wodran kann das liegen????
Wie weit sollte ich die Spannung weiter erhöhen?
Sind das einfach nur schlechte Treiber?
Bin hier mit meinem Wissen am ende!
Ich kann fast zu 100% ausschließen, dass es sch um ein mechanisches Problem handelt da ich das natürlich als erstes geprüft hatte.
Aber vielleicht weiß hier zu diesem Thema was mehr.


Wäre echt nett wenn jemand der sich damit auskennt mit helfen könnte.


Gruß

Pipo
Re: TMC2100
04. January 2019 09:36
Schon mal probiert die Treiber untereinander zu tauschen?


Gruß
Armin

Sparkcube | DuetWifi | PanelDue 4.3 | Meanwell RSP 320-15 | Extruder RepRap.Fab Microbarrel, Big Booster direkt |
DICE | AZSMZ-Mini | Raspberry Pi3 | RPI USV+ | MicroBarrel RepRap.Fab | Delta-Eigenbau | Radds | Raspberry Pi3 | e3D V6
Re: TMC2100
04. January 2019 09:49
Hi,
Evtl. Ist die Kühlung schuld. Wärmeleitpaste/Kleber ausgetrocknet Kühlkörper teilweise abgelöst oder sitzt neuerdings im Schatten der Luftströmung.
Vielleicht ist auch der Schrittmotor schuld.

Das der Treiber auf einmal Leistung verliert hatte ich bisher noch nicht gehört.

Gruß Micha
Re: TMC2100
04. January 2019 11:04
Hallo Zusammen,

erstmal vielen Dank für die schnelle Antwort.
Ihr könntet beide Recht haben.
Da ich das Ramps seit dem ich Umgebaut habe einfach unter dem Lüfter liegen habe und das ab und an natürlich auch Bewege könnte das auch was mit dem Luftstrom zu tune haben. Obwohl es doch komisch wäre, dass das dann nur einen Treiber betrifft.
Ich werde aber jetzt auch mal die Treiber tauschen um zu sehen ob es daran liegt.

Erstmal danke für die Tips!

Werde mich heute Abend dran machen.

Gruß

Pipo
Re: TMC2100
05. January 2019 03:24
Hallo Zusammen,

danke für euere Hilfe!
Hab es jetzt durch "Rumfummeln" hinbekommen. grinning smiley
Habe den Kleber der Passivkühlung erneuert, mal das Bord entstaubt und den Treiber neu gesteckt. Danach habe ich die Spannung auch wieder auch 1,15v runtergeschraubt.
Jetzt funktioniert alles wieder. Aber wodran es jetzt genau lag kann ich euch leider nicht sagen.


Gruß

Pipo
VDX
Re: TMC2100
05. January 2019 05:33
... eine zu hohe Ref-Spannung bzw. Spulenstrom an den kleinen Treibern und knapp zuwenig Kühlung macht auch genau solche "Schrittverluste", wenn die Treiber in den Übertemperaturmodus gehen und kurz abschalten, bis sie wieder abkühlen ... wenn das genau an der "Grenze" ist, sind das ggf. nur ganz kurze "Pausen" ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org]
Call for the project "garbage-free seas" - [reprap.org]
Re: TMC2100
05. January 2019 08:40
Hallo Pipo,

bevor du noch auf andere mögliche Probleme hingewiesen wirst, bitte diesen Thread beachten, deine MKS laufen durch Beschaltungsdiffernzen nicht im spreadcycle Mode.


Grüße Jörg


DIY Graber i3, based on Ramps 1.4 / LCD-SD-support / Marlin / MK8 upgraded direct drive

Home of Graber i3 reloaded, based on Ramps 1.4_TMC2100 / LCD-SD-support / Marlin / MK8 upgraded direct drive


Und sollte ich vergessen haben, jemanden zu beschimpfen, dann bitte ich um Verzeihung!
Johannes Brahms
Re: TMC2100
06. January 2019 14:15
Hallo Jörg,

danke für den Hinweis! Wirklich sehr cooler Thread!
Die dort beschriebenen Probleme mit den MKS Treibern passen zu 100% zu meinen Problem, wie ich finde.

Da ich mir nicht zutraue den MKS so zu modifizieren, dass er nachher das tut was er tun soll werde ich auf die Watterott wechseln.

Was ich jetzt vielleicht noch zu mir sagen muss ist, dass ich wirklich auf diesem Themengebiet kein Vollprofi bin. Habe mir aber heute nochmal ein paar Stunden gegönnt um mich weiter in das Thema einzulesen.

Da ich ein Ramps 1.4 nutze sollte ich auf die Watterrott 5V gehen, richtig?

Um diese dann im spreadCycle 16/256 Mode zu betrieben, gibt es so wie ich es verstanden habe 2 Wege:

1.) Brücke zwischen GND und CFG1 löten sowie die Pins CFG1-3 abschneiden bzw. nicht anlöten.
Vorteil: der spreadCycle 16/256 Mode ist fix und funktioniert auch auf anderen Bords.
Nachteil: der spreadCycle 16/256 Mode kann nicht mehr geändert werden.

2.) Man Lötet nix und lässt alle Pins dran und setzt dafür die Jumper auf dem Ramps 1.4 auf.
Vorteil: spreadCycle 16/256 Mode kann geändert werden, wenn gewollt
Nachteil: Die Jumper können je nach Ramps anders gesetzt werden müssen.

Ich denke ich werde mich jedoch für die Variante 1 entscheiden.
Was ich jedoch wirklich nicht verstehe ist, dass ich eine Brücke von GND auf CFG1 löte um dann nachfolgend den CFG1 Pin abzutrennen. Aber gut .....confused smiley

Nochmals vielen Dank!

Gruß

Pipo
Re: TMC2100
06. January 2019 14:22
Quote
PIPO881
Da ich mir nicht zutraue den MKS so zu modifizieren, dass er nachher das tut was er tun soll werde ich auf die Watterott wechseln.

Wenn du jetzt wechselst, nimm doch lieber die 2208.


Best regards / Viele Grüße
Till
Re: TMC2100
09. January 2019 00:58
Hallo Till,

vielen Dank für den Tip!
Die TMC2208 kannte ich nicht.

Habe dazu jetzt einwenig gelesen. Und so wie ich verstehe, korrigiert mich richtig wenn ich falsch liege, kann ich den Treiber ohne weitere Brücke auf das Ramps stecken. Mit den richtigen jumper settings auf dem ramps läuft der treiber dann im stealthchop2 (16/256).

Ich habe gelesen, dass ich durch die Logic supply voltage von 3.3 bis 5V Probleme bekommen könnte. Leider finde ich den Artikel nicht mehr sonst würde ich ihn hier verlinken. Aber wie genau ich diese Problematik umgehe habe ich noch nicht verstanden. Vielleicht kann mir da jemand helfen?
Ich habe jedoch eine zweite Version des Treibers gefunden TMC2208 v2 der sich genau dieser Problematik widmet. Da dieser nicht auf watterott zu finden ist bin ich nach den Erfahrungen und den hier aufgezeigten Problemen etwas skeptisch.


Gruß

Pipo
Re: TMC2100
26. January 2019 07:16
Es gibt bei Watterott auch noch SilentStepStick-Protector, die schützen die Treiber gegen Durchbrennen beim Bewegen der ausgeschalteten Motoren zum Einen und - was ich erst nach Umbau der Treiber entdeckt habe, besitzen ein Lötpad, um genau diese Brücke zu setzen. Diese Shields werden unter die Treiber gesteckt, erhöhnen also den Aufbau (bitte vorher bedenken bzgl Lüfter etc).
Habe also vor Einbau der Treiber alle Jumper entfernt (die Brücke auf den Treibern dann auch wieder) und die Lötbrücke auf den Protector-Shields verbunden. D.h., wenn jetzt ein Treibertausch vorgenommen werden muss, muss dieser nicht merh angepasst werden.


Grüße von der Nordsee
Knut
- - - -
P3Steel toolson MK2 [scheuten.me] - RAMPS 1.4 - TMC2100 - 2x ext. MOSFET - Marlin 1.1.9 - RasberryPi 3 (octoprint, pronterface) - Cura 3.6
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen