3D-Druck - Fehler in der Elektronik?
06. October 2023 16:13
Hallo im Forum,

ich hoffe, es geht euch allen gut. Ich wollte meine Erfahrungen mit meinem 3D-Druckerprojekt teilen. Vor einiger Zeit habe ich mir einen 3D-Drucker zugelegt und bereits viele tolle Dinge gedruckt. Jetzt habe ich mich entschieden, einen eigenen 3D-Drucker zusammenzubauen. Ich habe schon eine Menge Bauteile besorgt und ein bisschen herumgebastelt.

Heute wollte ich die Schrittmotoren testen und habe die Konfiguration in Marlin erstellt. Anschließend habe ich es auf mein Mega 2560 geflasht (hoffentlich habe ich das richtig gemacht, xD).

Wenn ich das Mega 2560, Ramps 1.6 und das 12864 LCD über den USB-Anschluss an meinen Computer anschließe, funktionieren die Geräte einwandfrei. Aber sobald ich sie über ein 12V Netzteil mit 360W anschließe, sehe ich nur eine kleine Beleuchtung auf dem Ramps 1.6. Alle anderen Teile wie das LCD-Display und der Mega 2560 bleiben aus.

Hat jemand von euch vielleicht Erfahrung mit diesem Problem und kann mir weiterhelfen? Ich wäre sehr dankbar für eure Ratschläge und Tipps.

Vielen Dank im Voraus!




VDX
Re: 3D-Druck - Fehler in der Elektronik?
06. October 2023 16:43
... miß mal die Spannungen und Spannungsregler nach ob das von der Verdrahtung her paßt und die Spanungsregler funktionieren.

Wenn die 5V über den USB-Port kommen, aber nicht über die externe Versorgung, dann ist entweder der Spannungsregler hin oder die Verbindung nicht richtig ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: 3D-Druck - Fehler in der Elektronik?
06. October 2023 17:40
Die Spannungen habe ich bereits gemessen, am Netzteil kommen 230 V an und die Verbindung mit dem RAMPS 1.6 kommen genau 12 V an. Das Netzteil hatte ich neu bestellt und ist gestern angekommen.

In der Elektronik bin ich nicht so gut xD

Ich habe auch versucht, den RAMPS über das Netzteil laufen zu lassen und den MEGA 2560 mit dem USB Kabel am Computer verbunden. Über die Software Pronterface wollte ich dann die Schritt-Motoren testen, jedoch bewegt sich da nix.

1-mal bearbeitet. Zuletzt am 06.10.23 17:59.
VDX
Re: 3D-Druck - Fehler in der Elektronik?
06. October 2023 17:56
... miß auch mal die 5V auf den jeweiligen Platinen nach.


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: 3D-Druck - Fehler in der Elektronik?
06. October 2023 18:39
Habe die 5V-Platinen gemessenen, hoffentlich auch die Richtigen grinning smiley




1-mal bearbeitet. Zuletzt am 06.10.23 18:40.
VDX
Re: 3D-Druck - Fehler in der Elektronik?
06. October 2023 19:47
... und jetzt schau mal, was der Unterschied ist, wenn du den USB-Stecker abziehst - da sind dann keine 5V mehr dran ... oder?

In dem Bild ohne USB, wo das Display aus ist, mißt du welche Pins mit den 12V? - wo sind dann die für den Betrieb benötigten 5V?


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: 3D-Druck - Fehler in der Elektronik?
07. October 2023 05:21
Man angenommen, ich lasse den USB-Kabel am MEGA2560 dran, wodurch dann eine Spannung von 5V durchgeht. Dennoch bewegen sich die Schritt-Motoren nicht.
VDX
Re: 3D-Druck - Fehler in der Elektronik?
07. October 2023 05:42
... wenn ohne USB keine 5V da sind, dann ist typisch der Spannungsregler defekt ... miß dann auch mal an den Chips der Stepper-Treiber, ob die 5V dafür noch da sind - diese werden evtl. über einen eigenen Kreis versorgt ... oder die Motorspannung kommt nicht an ... da kann noch mehr defekt sein ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: 3D-Druck - Fehler in der Elektronik?
07. October 2023 07:09
Bei den Stepper-Motoren habe ich 12 V gemessen. Ich habe mal das Datenblatt für ein Nema17HS4401S angeguckt.
Die benötigen anscheinend nur 2,6V oder liege ich falsch?

In zwei anderen Internetseite steht, dass das Nema17HS4401S, 4,3V und 12V benötigen, das bringt mich jetzt durcheinander.




2-mal bearbeitet. Zuletzt am 07.10.23 07:30.
Re: 3D-Druck - Fehler in der Elektronik?
07. October 2023 10:06
Falls der Spannungsregler defekt ist, welches Bauteile (Mega2560 oder Ramps 1.6) muss ich denn austauschen?
VDX
Re: 3D-Druck - Fehler in der Elektronik?
07. October 2023 12:51
... wegen der Spannungsregler mußt du mal in der Nähe der Spannungs-Eingänge schauen - das sind so kleine 3-4-Beiner, sehen wie dickere SMD-Transistoren aus.

Wegen der Stepper - die werden über Strom geregelt/angesteuert - die Spannung bestimmt nur, wie schnell die Spulen umgeladen werden ... die könnten auch noch etwas schneller mit 24V laufen ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen