Welcome! Log In Create A New Profile


Extruded Filament Cycles b/w Thick and Thin Flow

Posted by S1I2F3 
Extruded Filament Cycles b/w Thick and Thin Flow
October 04, 2013 03:25AM
I'm not sure how to best describe this issue, so I think pictures will do it best:

I am using a home built Prusa i2 w/ RAMPS 1.4, Slic3r for Gcode, running in Pronterface for Mac. My prints (ABS) are less than decent, the main problem being that the filament will extrude in a perfect stream, then at a constant interval will turn into a thin stringy line for a short period of time. I have calibrated the extrusion amount, and prior to that this issue was much worse. I performed that calibration 3 times, and that has not solved the problem. I do not think it is an issue with the Extruder motor steps, as if it was, I think the extruded material would go from a thick stream to a thin stream, then to no stream at all for the remainder of the print. Also, I don't think it is an issue with the layer transitions, as it happens multiple times on a single layer. I'm thinking it might have something to do with retraction? My setup in Slic3r (regarding retraction) is as follows:

Length: 1mm
Lift Z: 0.3mm
Speed: 30mm/s
Extra Length on Restart: 0
Min Travel After Retraction: 2mm
Retract On Layer Change: OFF
Wipe BEfore Retract: OFF

A note on the above, I have my layer height set to 0.3mm, and the problem persists with Lift Z set to 0mm.

My other guess would be with the Extruder temperature. Perhaps it is too low, so it gets backed up after a while until a small, harder piece gets pushed out? Or maybe too hot so after a while the filament gets burned and comes out thinner until fresh filament enters the nozzle? I have no idea. I'm running the extruder at 230C (not yet confirmed with an IR gun) but I used a crude thermometer (metal-metal conduction), so I know I'm pretty close. Ideally, I'm hoping someone else has seen something similar and the solution is obvious. Thanks for the help!
Re: Extruded Filament Cycles b/w Thick and Thin Flow
October 04, 2013 08:06AM
Hmm, sounds quite a bit like a problem that I have just posted about here, but with PLA.

Try disconnecting the drive and pushing through a bit of filament holding it between the thumb and fingure. If the back pressure changes then it may be some foreign object in the melt chamber - I once has something that looked like a big grain of sand. Although I havent seen that since, it is still the first thing I look for.

Re: Extruded Filament Cycles b/w Thick and Thin Flow
October 05, 2013 02:49AM
I tried your suggestion, and I was able to push the filament out smoothly and cleanly, no problem at all. On a similar note, when my printer is heating up, I can extrude filament in pronterface (in 5mm increments via the extrude button) and on first click very little filament will come out of the nozzle, but on every click thereafter the filament will flow as it should without a problem. Maybe I should try stepping up the nozzle temp in 5C increments?
Re: Extruded Filament Cycles b/w Thick and Thin Flow
October 05, 2013 04:51AM
If the nozzle is not blocked and the filament can be pushed through freely, then the problem may be in the hobbed bolt: Is the knurled bit central to the filament? Does the idler wheel carriage lift freely without sticking? Is the idler wheel bearing free to turn? try adjusting the idler wheel pressure.
Another thought, is the short path from the extruder to the melt chamber free of sharp edges which could snag the filament

Re: Extruded Filament Cycles b/w Thick and Thin Flow
October 11, 2013 12:49AM

Thanks for all the suggestions, they were very helpful!

I actually opened up the extruder idler, and checked the hobbed bolt knurling alignment, and it was centered as it should be. I rotated the large gear around though, and I found some small slivers of filament lodged into the teeth. Small as they may be, it seems they were enough to not allow the bolt's teeth to fully engage the filament, causing the extrusion skipping problem at a regular interval i.e. each full rotation of the bolt.

All is fixed now and running great! Thanks again


Sorry, only registered users may post in this forum.

Click here to login