Welcome! Log In Create A New Profile


Pronterface Not Connecting

Posted by Theorist 
Pronterface Not Connecting
November 03, 2013 01:33AM
Pronterface is no longer connecting to my printer. I'm using RAMPS 1.4 and Windows 7 64 bit.

Arduino board is running on COM 3, Pronterface is also set for COM 3.

Firmware is set for 250000, as is Pronterface.

The Arduino IDE can communicate with the Arduino board and update it's code just fine. When I upload test code, all the motors move, so RAMPS is working at least to that extent.

I've powercycled the printer electronics and rebooted the computer to make sure that nothing else is trying to use that COM port.

I've changed the baud rate in the firmware to 115200 and updated Pronterface.

I've tried different versions of Pronterface.

I've tried different USB cables.

Still, Pronterface doesn't connect, doesn't time out, doesn't create an error log.

If I unplug the USB cable completely, it creates an error log.

I'm stumped. Any suggestions for a fix, alternative to Pronterface, or other way to test my electronics?

My (rarely updated) Prusa i3 build log: [3dtheorist.wordpress.com]
Re: Pronterface Not Connecting
November 03, 2013 03:32AM
I've tried this with two different computers now.

Even unplugged everything except the USB and power to RAMPS.

Still the same result, no connection, error, or timeout. It just says "Connecting..." indefinitely.

The only time I can get a different response is when I unplug the USB cable, then it errors out finally.

I'm about to buy another RAMPS board unless someone can give another compelling suggestion.

My (rarely updated) Prusa i3 build log: [3dtheorist.wordpress.com]
Re: Pronterface Not Connecting
November 03, 2013 06:34AM
If Arduino can connect there is nothing wrong with the hardware as it uses the same serial port. The difference is it avrdude talking to the bootstrap instead of pronterface talking to the firmware. Also the RAMPS board is not involved in the comms.

To determine if the problem is the firmware or pronteface try connecting with the Arduino serial monitor. You should see the startup message when you press the reset button and you can send commands like M114 and see the results. It only seems to go up to 115.2Kb so you will have to configure the firmware for that.

Re: Pronterface Not Connecting
November 03, 2013 11:08PM
Hi Nophead, thanks for the suggestion.

I changed the firmware to 115200, then opened the serial monitor in the Arduino IDE and changed the baud rate there too. I hit the reset button on RAMPS, LED 1 flashed twice, but I still got no feedback in the serial monitor. Oddly, I can still upload to the Arduino. Does this mean that the hardware is bad?


My (rarely updated) Prusa i3 build log: [3dtheorist.wordpress.com]
Re: Pronterface Not Connecting
November 04, 2013 04:46AM
No because the USB port must be working. Seems more like the firmware you are loading does not run.

If you run the test code do you get anything from the serial port? IIRC it prints out ADC readings continuously.

Re: Pronterface Not Connecting
November 04, 2013 04:45PM
Fixed! Nophead was right, it was a firmware issue.

The test code apparently doesn't print to the serial monitor, but I loaded some of my own code that does, and that worked. So I switched to a different version of Marlin, and Pronterface is finally connecting.


My (rarely updated) Prusa i3 build log: [3dtheorist.wordpress.com]
Re: Pronterface Not Connecting
March 20, 2015 12:08PM
Theorist im having a similar problem. where did you get the version of marlin that worked?
Re: Pronterface Not Connecting
May 03, 2015 02:03AM
this worked for me - follow the instructions here;

Re: Pronterface Not Connecting
July 11, 2019 10:41AM
your link does not work
Re: Pronterface Not Connecting
July 11, 2019 03:21PM
your link does not work

It's a very old link smiling smiley

Re: Pronterface Not Connecting
January 27, 2020 10:34AM

I'm having the same problem with Pronterface not connecting with just a bunch of garbage returned.

Pronterface was working ok and then I fitted a supposedly NC, NPN (LJ18A3-8-Z/AY) inductive sensor (sensor LED was on when raised - i.e. - closed - and off when close to metal bed[) and set all endstops to false in Marlin as per config as my X and Y microswitch endstops ae both NC. I uploaded the re configured Marlin and sent an M119 via Pronterface and X and Y were shown as not triggered but to my surprise Z was Triggered despite being well above the bed level by around 40 mm.

So I then inverted the logic of the Z endstop (probe) in Marlin and had to invert the Z_endstop_pin as Marlin would not compile without the pin inversion. After uploading this new configuration Pronterface will not connect - just shows the garbage mentioned above.

Just for clarity this was the message that I got when compiling after inverting probe logic in cinfiguration.h in Arduino IDE:

exit status 1

And that is why I Inverted the logic on the Z min Endstop. But after reconfigering uploading Pronterface refused to connect.

Should I abandon the Z probe and perhaps replace it with a BL touch or is there a better firmware solution in Marlin.?

I'd be grateful for any advice


Edited 2 time(s). Last edit at 01/27/2020 11:11AM by TerryD15.
Sorry, only registered users may post in this forum.

Click here to login