Welcome! Log In Create A New Profile


Test Firmware Failed

Posted by GreekPride91 
Test Firmware Failed
March 19, 2014 01:03PM
Hey everyone

I uploaded the test firmware to a Megatronics v2.0 board and while the motor for the x-axis turned, when I opened pronterface and tried connecting, it return the message "RCVD: 'fa'" which I take to mean as that it failed. Has anyone else faced this issue?

Additionally, when I uploaded Marlin and connected the board to pronterface, when I tried to home an axis, the LED labeled "LEX2" lit up and the board made a loud, prolonged beep sound and refused to move. Even though it failed the test-firmware I tried to see what would happen anyway, and clearly to no avail.
Re: Test Firmware Failed
March 19, 2014 02:02PM
Try clear EPROM - find programm for this in standart Arduino library.
Then set 250000 speed in FW.
Re: Test Firmware Failed
March 19, 2014 03:25PM
@Potapich which file in the Marlin code would I implement that to?
Re: Test Firmware Failed
March 19, 2014 08:33PM
The test firmware only wiggles the steppers, strobes the LED lights, and outputs diagnostic messages to the USB serial port. It does NOT talk to Pronterface or any other printer control programs.

Also, the default of 250,000 baud is a non-standard speed that is not supported by some computers. Fall back to 115,200 baud and see if that fixes everything.....
Re: Test Firmware Failed
March 20, 2014 12:25PM
I thought the firmware was supposed to return temperature values in pronterface? And I lowered the baudrate and I was wrong before, it wasn't the board making the noise, it was the motors whistling, which it is still doing.
Re: Test Firmware Failed
March 20, 2014 03:27PM
Its in Arduino library - File - Examples - EEPROM - eeprom_clear.

Compile and load to board. After restart, load Marlin.
Re: Test Firmware Failed
March 20, 2014 06:25PM
Now my new problem is that when I plug in the power when the board is connected to my computer, it automatically turns off my computer. All of the wires are connected as they should be/used to be, but I'm not sure how to pinpoint this short. Any suggestions?
Re: Test Firmware Failed
March 21, 2014 09:02PM
Did you remove the "5V USB" jumper cap next to the USB connector? Just my guess, with a big disclaimer that I accidentally popped the on-board 5V power and have to feed my board from the USB 5V power so I would verify this against the schematics.....
Re: Test Firmware Failed
March 24, 2014 09:25PM
Problem resolved guys, it just needed a different feedrate and steps per unit/ Thanks for all the replies!
Sorry, only registered users may post in this forum.

Click here to login