Welcome! Log In Create A New Profile



Posted by MrBill2014 
August 16, 2014 10:56AM
Hello Printers, I built a Prusa i3 rework and when I try to print its chaos!!! But the manual movement works fine.

When I print, the printer slams very quickly to +X (and still tries to keep going) then slams to +Y (and still tries to keep going) , back to -X and -Y (and still tries to keep going). As if it was making a giant skirt.

I have tried and compared so many variations of Marlin firmware. I went to websites selling the same model and downloaded their firmware for comparison. Used the online Reprap Calculator and Repetier configuration tool which gives me almost identical set ups. And still the same slamming problems.

After a ton of experimenting. I was able to get it print a few time by cutting all my setting down to almost nothing and adjusting my print area to 100x100 - in firmware/slic3r and in Printrun. Then setting my objects scale to 50% in slicer, which printed them close to 100%. But they're awful.

My printer is set up like this:

Endstops are all on the Printer's Min and plugged into the Min on the RAMPs 1.4,

Y Motor is on -Y Min

XY = 80
Motor Step Angle: 1.8º (200 per Rev)
Pololu Stepper Drivers: 1/16
Belt Pitch: 2mm - GT2
Pulley Tooth Count: 20

Z = 4000
Motor Step Angle: 1.8º (200 per Rev)
Pololu Stepper Drivers: 1/16
Leadscrew Pitch: 0.8mm - M5
1:1 Gear Ratio

According to what I been reading these are the settings I should be using - except they cause total chaos.

#define HOMING_FEEDRATE {50*60, 50*60, 50, 0}

#define DEFAULT_AXIS_STEPS_PER_UNIT {80,80,4000,516}
#define DEFAULT_MAX_FEEDRATE {500, 500, 2, 25}
#define DEFAULT_MAX_ACCELERATION {9000,9000,10,10000}


Here are the settings for my last experiment - A sliced 2cm x 2cm block @ 100% printed as 8cm x 8cm..

#define HOMING_FEEDRATE {15*20, 15*20, 15, 0}

#define DEFAULT_AXIS_STEPS_PER_UNIT {30,30,375,375}
#define DEFAULT_MAX_FEEDRATE {63,63,0.25,3.1}
#define DEFAULT_MAX_ACCELERATION {30,30,1.25,30}


It seems to me that there is some sort of scaling happening in the firmware. Is there a place other than Configuation.h that this could be?

Any help greatly appreciated!!! Thanks!
Re: Chaos
August 16, 2014 01:29PM
Are you sure your electronics are set up for microstepping? For 1/16, you should have 3 jumpers installed beneath each pololu (assuming you have RAMPS)
Re: Chaos
August 16, 2014 04:02PM
THANK YOU!!! I completely missed that step… Thank you so much!
Sorry, only registered users may post in this forum.

Click here to login