Welcome! Log In Create A New Profile


Extruder printing for too long

Posted by THEBRICK36 
Extruder printing for too long
March 15, 2015 10:07AM
I built my first 3d printer and I am having troubles with calibrating the extruder. I have a Melzi v2.0 board from RepRapPro.com. I have Marlin 1.0.2 RRP firmware. A M503 command reports the following:

echo: Steps per unit:
echo: M92 X100.000 Y100.000 Z4000.000 E10.000
echo:Maximum feedrates (mm/s):
echo: M203 X500.000 Y500.000 Z3.000 E45.000

Using Pronterface, telling the printer to extrude a length of 1.0mm @ 60mm/min results in the extruder moving for 39 sec. If I change the steps per unit to E1.000, then the extruder will move for 3.9sec (I've also tried using G1 commands with the same outcome). When I print 1mm with a feed rate of 60mm/min, it should only print for one second right? Not only that, but changing the steps per unit should have no effect on how long the motor is on for? I've tried redownloading the firmware with no success. I'm at a loss of where to go from here.

Edited 2 time(s). Last edit at 03/15/2015 10:09AM by THEBRICK36.
Sorry, only registered users may post in this forum.

Click here to login