Welcome! Log In Create A New Profile

Advanced

Problem setting E-steps confused smiley [SOLVED]

Posted by Ragdollcat 
Problem setting E-steps confused smiley [SOLVED]
August 27, 2015 08:47AM
Hi, I have a sunhokey prusa I3 2015 and I'm having problems setting the e-steps. I divided the amount I want it to feed with what It's actually feeding and multiplied that number with my current setting like this: (100mm/57mm)*80.5 = 141,2 so I changed the E-steps/mm to 141.1 and extruded 100mm again but this time it extruded 140mm confused smiley

Edited 1 time(s). Last edit at 08/27/2015 02:10PM by Ragdollcat.
Re: Problem setting E-steps confused smiley
August 27, 2015 09:01AM
My guess is that when you did your original test, the extruder skipped some steps, which is why you only got 57mm instead of close to 100mm.



Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Problem setting E-steps confused smiley
August 27, 2015 09:08AM
I don't have my bowden tube attached so I don't think it skipped
Re: Problem setting E-steps confused smiley
August 27, 2015 09:30AM
Can an motor skip even if it's spinning freely?
Re: Problem setting E-steps confused smiley
August 27, 2015 09:55AM
Quote
Ragdollcat
Can an motor skip even if it's spinning freely?

Perhaps the filament wasn't unwinding freely from the spool?



Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Problem setting E-steps confused smiley
August 27, 2015 11:16AM
I don't think it's a mechanical issue.
Attachments:
open | download - 600kb.jpg (582.3 KB)
Re: Problem setting E-steps confused smiley
August 27, 2015 12:57PM
Just continue a few more times.
100/140 * 141.1 = 101

You'll home in on the correct number.

If at some point you don't get consistent results, check motor current, slipping gears etc.
Re: Problem setting E-steps confused smiley
August 27, 2015 02:08PM
Thanks alot!! I had to do it about 5 times and now I get exactly 100mm every time smiling smiley
Re: Problem setting E-steps confused smiley [SOLVED]
August 27, 2015 03:59PM
Excellent! Congrats! smiling smiley
Sorry, only registered users may post in this forum.

Click here to login