Welcome! Log In Create A New Profile


Shifted Layers with No Answers

Posted by chevellebro1 
Shifted Layers with No Answers
April 17, 2016 03:17PM
I built a new printer running Marlin firmware. I just started printing this last week and I have had little success at getting a good print. I started off with the calibration 20mm cube and that was problematic. I saw on another forum that someone printed a thin wall shell to start testing. So I started with this print and I had great results. I had the speeds very slow (20 mm/s) from the other cube and I had very good results on this test. I then used the same settings on the cube again with the same result. I've attached a picture of the messed up cube along with the printed shell next to it. I used the exact same settings for both. The problem is only in the X axis and it repeats every layer.

I have tried calibrating my steppers and those are working great. I have changed the acceleration values in the firmware, adjusted the amperage to the X axis stepper motor, checked resistance sliding it by hand, lubed the axis...I'm out of answers here. The machine does not use belts and gears as I've read in other forums about slipping belts. This uses a rack and pinion with a the set screw tightened against the flat spot on the motor shaft. I think the gear has little chance of spinning on the shaft. But again I am able to print a shell with no problem. But whenever I print any kind of infill, solid or otherwise, I get shifted layers.

Can anyone shed some light on this?

Edited 1 time(s). Last edit at 04/17/2016 03:18PM by chevellebro1.
open | download - IMG_0028.jpg (153.2 KB)
open | download - IMG_0029.jpg (155.7 KB)
Re: Shifted Layers with No Answers
April 17, 2016 06:52PM
What acceleration values are you using, and did you adjust them down low enough to see a visible difference, i.e. so you know the changes were taking effect. Also, what value of XY jerk are you using?
Re: Shifted Layers with No Answers
April 17, 2016 06:58PM
#define DEFAULT_AXIS_STEPS_PER_UNIT   {48.14169,48.14169,1512.42,97.1402}
#define DEFAULT_MAX_FEEDRATE          {100, 100, 4, 10}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {500,500,100,3000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION          100    // X, Y, Z and E max acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION  100   // X, Y, Z and E max acceleration in mm/s^2 for retracts

// Offset of the extruders (uncomment if using more than one and relying on firmware to position when changing).
// The offset has to be X=0, Y=0 for the extruder 0 hotend (default extruder).
// For the other hotends it is their distance from the extruder 0 hotend.
#define EXTRUDER_OFFSET_X {0.0, 31.75} // (in mm) for each extruder, offset of the hotend on the X axis
#define EXTRUDER_OFFSET_Y {0.0, 0.0}  // (in mm) for each extruder, offset of the hotend on the Y axis

// The speed change that does not require acceleration (i.e. the software might assume it can be done instantaneously)
#define DEFAULT_XYJERK                5.0    // (mm/sec)
#define DEFAULT_ZJERK                 0.4     // (mm/sec)
#define DEFAULT_EJERK                 5.0    // (mm/sec)

I have slowed it way down. The print makes no difference running at these slower accelerations.

My setup electronics
RAMPS1.4 w/ Arduino Mega
TB6560 Boards for each axis

Since writing this post I came across someone else with similar issues and them mentioned making the pulse width longer which I have done here. Still no difference! I am really at odds here of what is happening?

if (counter_x > 0) {
        counter_x -= current_block->step_event_count;

      if (counter_y > 0) {
        counter_y -= current_block->step_event_count;

      if (counter_z > 0) {
        counter_z -= current_block->step_event_count;
Re: Shifted Layers with No Answers
April 17, 2016 08:37PM
Are you sre that the current to the stepper motors is high enough?
It looks like you are loosing a few steps every time the x-axis is active.

Edited 1 time(s). Last edit at 04/17/2016 08:37PM by Downunder35m.
Re: Shifted Layers with No Answers
April 17, 2016 08:40PM
I have adjusted it in both directions. The motors are NEMA 17 requiring 1.8A. I have adjusted the board to be lower at 1.6A and I've turned it all the way up to 3.0A to test. None of these made a different. It really stumps me because the motors and boards are the same for the other axis but it doesn't change no matter what settings or hardware things I change
Re: Shifted Layers with No Answers
April 18, 2016 09:32AM
I had issues like this myself and it turned out it was the drivers overheating... They did not seem super hot to the touch but a threw a fan and a makeshift air duct blowing on all the stepper driver heatsinks and that stopped the shifting.
Re: Shifted Layers with No Answers
April 18, 2016 10:36AM
I have the drivers in a computer tower with 120mm fans cooling them. And like I said all the other axis are fine. The Y axis and Z axis are both running 2 stepper motors a piece at 3.0A and are fine. For some reason the X axis driving a single motor is the one loosing steps. It doesn't make sense....
Re: Shifted Layers with No Answers
April 18, 2016 10:51AM
Try swapping the X and Y drivers and see if the issue changes direction. If it does then you know the driver is bad.
Re: Shifted Layers with No Answers
April 18, 2016 10:55AM
I've swapped the driver, issue stays with the X axis
Re: Shifted Layers with No Answers
April 19, 2016 01:50AM
you might have too much tension in your x belt. It also could be a bad X axis bearing. Does the carriage slide smoothly with the belt off the motor pullyor does it feel like there are subtle micro steps.

Edited 1 time(s). Last edit at 04/19/2016 01:50AM by CTCHunter1.
Re: Shifted Layers with No Answers
April 19, 2016 08:37AM
There are no belts, my machine uses rack and pinion. I have slid it by hand and it seems smooth to me. I've tried adjusting the gear and lubing everything with no difference. I tried swapping stepper motors yesterday with an interesting result. The missed steps caused the piece to slope to the right. However after swapping motors I realized that the motor was turning opposite of the other one. So being lazy, I just inverted the axis in the firmware. Now the missed steps are in the opposite direction and it is sloped to the left. I'm not sure what could cause this. It doesn't seem to be mechanical. It happens no matter where the part is on the bed. Also it is consistent so I don't think it can be mechanical. I'm left with it either being a bad arduino/ramps or a problem with Marlin. I'm not sure how else to troubleshoot this
Re: Shifted Layers with No Answers
April 19, 2016 09:47PM
I agree with Downunder, Once I raised my stepper voltage from 5.1 to 6.8 (Nema 17's), the slanted prints stopped.
Re: Shifted Layers with No Answers
April 20, 2016 01:46AM
The weird part is that the X axis prints fine as long as there is no infill to the print. Just printing the perimeter there is no missed steps. Only doing the infill is there a problem. I think it would do it all the time if it was an amperage issue. I've also tried adjusting the current up and down with no change in print quality
Re: Shifted Layers with No Answers
April 20, 2016 07:23AM
Whats your infill and travel speeds? These may only occur when printing with infill. If they are high it could miss a step/jump a tooth. Without knowing the machine its hard to comment on the mechanics. Is it possible for the gear to jump a tooth under load - deflection of the rack/carriage.
Re: Shifted Layers with No Answers
April 20, 2016 10:58AM
My travel speeds and infill speeds are both low (10-20mm/s). It isn't possible for the gear to jump teeth the way it is built. And because it is only happening in one axis makes no sense. Both axis are built the same! I've adjusted acceleration settings, jerk settings with no change
Re: Shifted Layers with No Answers
April 20, 2016 12:16PM
Although not really possible but with nothing to loose:
Get your copy of your firmware ready, note all settings you might have change through the EEPROM values.
Use the EEPROM Clear sketch from the examples to clean out the memory.
Flash the firmware again and give it try.
Sometimes a simple typo with no visual effects or error codes will mess up the entire EEPROM section.
Had this happening a few times and it causes all sorts of troubles, so you might be lucky and it is this easy to fix.

If that does not help it could also be a stepping issue.
A 16MHz CPU can provide around 10000 steps per second before it needs to cheat one way or the other to get more speed.
So if you add all steps for all active axis including the extruder for one second and you are much higher than 10000 you might have a problem.
With the speeds of our hobby machines this should not be an issue but certain configurations make it easy to go overboard.
For example geared extruders and very small pulley with only a few teeth.
Take a geared extruder feeding a 0.7mm nozzle creating a 0.3mm solid infill at 50mm/s - you will be surprised how many steps this thing chews per second...

One last thing I learned from my laser cutter:
Acceleration and Jerk are closely related to the print speed!
I noticed for example that increasing the acceleration to over 1000 fixed a lot of issues with stuttering and lost steps during fast engravings.
Similar story for the Jerk, if it is too low the machine will be forced to slow down hard, it should be hard but not so hard that steps are lost or stuttering happens.
Some people are happy with 10, other with under 5, I prefer different values based on the job.
Very fine details with a lot of directional changes are done with a quite low jerk, pure raster engravings with a high jerk of around 40.
There are testobjects that claim to be good for testing this but IMHO it pays off to have something complicated.
Things that look like sections of a planetary gear box with a lot of different angles.
Select a print speed that you prefer and is quite high and adjust the jerk and acceleration during the print until you find working settings.
Don't be afraid to go overboard with the values but the Jerk should be tried low first.
Re: Shifted Layers with No Answers
April 20, 2016 02:13PM
Most of the common causes have been mentioned, however there are a lot of other things that cause shifted layers.
The following Wiki page may help: Shifted Layers

Since this appears to be a more difficult issue - please consider posting some of the general, and specific info we could use to help diagnose your issue. You may also want to post a video.

Also, as part of the diagnosis - try rotating the part 45 degrees and re-print.

Hope that helps.

My printer: Raptosaur - Large Format Delta - [www.paulwanamaker.wordpress.com]
Can you answer questions about Calibration, Printing issues, Mechanics? Write it up and improve the Wiki!
Re: Shifted Layers with No Answers
April 21, 2016 12:15AM
After trying all of the above troubleshooting I had already done, I went ahead and replaced the entire ramps/arduino board with no change in results. The printer still is off the same amount and in the same direction.

As of now I have:
Adjusted Amperage
Changed Stepper Drivers
Changed Ramps/Arduino
Adjusted Acceleration/Jerk Settings
Slowed printer to a crawl (there is no difference printing at 10mm/s vs 50mm/s)
Added a pulse delay for TB6560 stepper drivers
Checked smoothness of gear in rack
Changed Stepper Motors
Added shielded wiring

I have really tried everything I can think of mechanically. I have referred to the wiki page when I first started having these problems. There is no backlash in the machine, very smooth and tight running. I don't think I'm exceeding the step rate for the arduino with the speeds I'm running. Putting in the new board took care of the EEPROM problem if there was one. I had the acceleration settings set to 500 and jerk set to 5. There was no way that it was moving to quickly at this setting and it still gave me the same result. I am really stumped at what the problem is at this point. I have tried printing other models besides the cube and it gives me the same end result, a shift in that same direction. The only other thing I can think of trying is switching from Marlin to Sprinter which I don't want to do as my firmware is heavily modified. I will take a video of the machine running but it seems very smooth and there is no audible skipping or other issues. I have really tried about every solution I have found online and I haven't even seen a slight improvement since finding the problem...it's a nice machine just need to get it to print accurately.
Re: Shifted Layers with No Answers
April 21, 2016 02:18AM
We've got no idea what hardware you have... Can you post a photo of the stepper board, and info on the model?

My wild speculation is it may be electrical interference in the stepper board caused by lack of/incorrect decoupling capacitors.

This link talks about this extensively.

My printer: Raptosaur - Large Format Delta - [www.paulwanamaker.wordpress.com]
Can you answer questions about Calibration, Printing issues, Mechanics? Write it up and improve the Wiki!
Re: Shifted Layers with No Answers
April 21, 2016 02:32AM
You said you changed the stepper drivers - same type or different type?
Asking as I use the A4988 drivers with no issues on the printer and laser cutter.
You changed and checked basically everything there is, only the actual firmware is left.
But as said I would again try the jerk and acceleration.
Try around the 2000 for accelleration and start with 40 for the jerk, set the print speed to just 20mm/s max.
If the print looks bad turn down the jerk first and check if something improves or goes bad, go down 5 every few layers that still shift the same.
In case you get a worthy difference before you get under 10 start to lower the accelleration by about 200 each time.

As a last resort if nothing helps I would try a different firmware.
Give MarlinKimbra a chance if you want to change firmware as I am very happy with it and it should offer more options than any other Marlin firmware I came across.
There are several forks and branches available as well as my version for the laser cutter.
An online configurator is available as well for ease for use, I did all manually but too me some time to get used to the different structure.
Re: Shifted Layers with No Answers
April 21, 2016 06:50AM

Try around the 2000 for accelleration and start with 40 for the jerk,

Interesting suggestion, but I'm not sure I understand the idea? Why not start with jerk 0 and acceleration low enough that you can really see the mechanics accelerating and slowing down - maybe as low as 10mm/s2. That way you know that the settings have taken affect. If it still skips at that speed you know it's not acceleration related. Otherwise you can slowly increase the settings until you find the limits.
Re: Shifted Layers with No Answers
April 21, 2016 11:05AM
To be honest I fail to fully undesrstand it myself.
It is just that during tuning my laser I noticed that low jerk and acceleration settings can have a very negative effect on longer moves at high speeds.
Some people seem to think the jerk and acceleration work totally different from reality winking smiley
The acceleration defines how fast an axis can go from 0 to full speed without loosing steps due to the mass being moved.
The jerk however defines how fast a directional change can be made without loosing steps or skipping teeth.
That means the jerk has little to no effect at all for example when going straight in one direction, stop and continue.
But if you go along x and need to turn in an angle the jerk will define how fast you get around the corner.

Having said that is becomes a bit clearer that finding the settings that work good for all possible print moves requires a testobject that has all bad features messing with jerk and acceleration.
Short straights, changing angles, more than 90° turns...
It also becomes clear than the heavier bed and extruder setup are the more power is required for the motors to cope with the load.
Now imagine you start testing with low jerk and acceleration.
Some moces will look perfect while others cause the machine to bang and jump as testing at very low speeds would not really help.
When starting with high values all bad moves can make you loose a step or two right away, so you low lower the values until all runs smooth enough.
Starting the other way can produce very smooth moves indeed but it is also very easily overlooked if the head slows down too much.
So you think that all is perfect and during your prints you find overextruded spots and pimples all over the printed object.
As a result you start messing with retraction, wipe and so on only to mess up other things.
I know it makes no real sense in the head to start from high and tune down until all is fine but really is faster and prevents some other problems on the way. At least for me it is...
Re: Shifted Layers with No Answers
April 21, 2016 10:23PM
I tried to upload the new firmware to the board and I did not get any improvement from changing software. So I am not sure what I'm missing. I'm sure there is a simple setting that I have forgot about but I have yet to find it in the past two weeks. I have attached some pictures of the hardware that I am using. You can see the gear and rack as well as the TB6560 board that I am using. I again tried to adjust the currents as well as the stepping on the board (from x16 to x8) and it made no difference. I have yet to make a change to the settings that have effected the print in a positive or negative way. I would just like to see some change to know that I am doing something in the right direction. I've rotated the model, switched slicers, switched computers all with no change. I am really stumped at this point. It has to be something software related because all of these changes to the amperage and step motion should make a difference if it is mechanical. I've also uploaded a video of the printer working. You can see it is a smooth motion, not jerking at all. I just am lost at what to do. I have placed an order for different stepper drivers but if the Y axis is not an issue, the board should be fine too on the X axis. I've also calculated my step rate and it does not exceed 10,000 at the speed I'm running now. If anyone has any advice for which settings to change it would be appreciated. I am really stumped with this issue!

open | download - IMG_2986.jpg (184.4 KB)
open | download - IMG_2987.jpg (155 KB)
open | download - IMG_2988.jpg (191.9 KB)
open | download - IMG_2991.jpg (221.9 KB)
Re: Shifted Layers with No Answers
April 21, 2016 10:28PM
Did you change the stepper drivers for a different model?
Re: Shifted Layers with No Answers
April 21, 2016 10:30PM
No the stepper motors have always been the TB6560. I have replaced the X axis twice with a new board and there has been no difference. I am looking at upgrading to a 2M542


The current board is:

Re: Shifted Layers with No Answers
April 22, 2016 04:48AM
Well I don't know if you have special needs with your amount of motors but I do know that the TB6560 is well known for positiong problems.
Original boards not so much, china clones badly.
Best option would be to use a board with different drivers or if your not electronically challenged to read up on the shifting problem and the fix over at CNCZONE.
It is bit involved to get them work properly but several people have done the mods and reported properly working machines after it.
Re: Shifted Layers with No Answers
April 22, 2016 07:41AM
Can you try printing the hollow cube when rotated 45degrees to the bed.
At the moment infill is the only time you are using both X & Y together so just wanted to see if its the infill or X+ Y motion that is the issue.
Re: Shifted Layers with No Answers
April 22, 2016 08:28AM
What's the current requirement for the motors you are using? If you could manage with something in the 1.5A region you could use a drv8825 for testing.

The build looks very nice, but has a fairly high moving mass and low steps/mm which is consistent with the sort of problems you are having. However, if that was the entire story you'd hit the problem on Y before X. Do you have witness marks across the motor shafts and drive gears? A slipping gear is not my favourite theory, but since it's easy to rule out you might as well check that.

I'm concerned that you've said on several occasions that you've changed settings and it's not made any difference. I hope you just mean that it hasn't changed the skipping steps, but if you actually mean you can't see any difference in movement then we need to find out why. I still think you should start with jerk set to 0 and acceleration low enough that you can see the head changing speed during the segments. The changes in direction in your video still looking easily fast enough to lose steps on a high mass design - I'd like to see that going much slower. The one time my printer started skipping steps it looked just like yours. I was amazed that there wasn't more visible drama, but it seems to be something that just creeps in without any grand announcement of having reached the limits.
Re: Shifted Layers with No Answers
April 23, 2016 10:37PM
I wanted to thank everyone for their help with this problem. I figured it out last night! So after replacing nearly electronic, changing motors, wiring, firmware...it turned out to the the TB6560 that was the issue. I should have listened to all the other forums that complain about them. Even though I tried 3 different boards, they were all from the same manufacturer and so the problem was in the cheaply manufactured driver. I upgraded the driver to the 2M542 and it was solved! Sometimes going the cheap route is not the answer. I have ordered two more to replace the Y and Z axis, so glad to have a functioning printer again! My few weeks of frustration was the result of cheap chinese drivers. I hope someone else will read this and learn from my mistakes!
Re: Shifted Layers with No Answers
April 24, 2016 09:07AM
Hey, that's great news - glad you got it sorted out. Thanks for letting us know, it's been driving me nuts wondering what's going on smiling smiley
Sorry, only registered users may post in this forum.

Click here to login