Welcome! Log In Create A New Profile


Heated head Thermal Runaway *Fixed

Posted by Horatius 
Heated head Thermal Runaway *Fixed
October 02, 2016 08:32PM
I am fairly new at 3d printing and this is my first post ever. I looked around all over google and forum and didn't find anything that look like my problem. So here it is, I just finish building my first 3d printer, a delta model based on this DIY instruction (http://www.instructables.com/id/3d-Home-Printer-With-Arduino/).
Everything is working fine but one thing. When i print something the heated head get to the right temperature and stabilize. But after about a minute (time vary slightly from one test to the next) the temperature of the heated head runaway ! All the way to the MAXTEMP and the printer stop printing. And i have to turn the power off to stop it from heating. Then when i start it back everything goes back to normal. One more thing on that is that if i manually set the temperature, the printer reach that temperature with no problem and keep it steady at +-1C from the set temp. And the thermistor show accurate reading all the time so i don't think there is an issue with it

Here is some more information on this. When i connect a multimeter in parallel with the heated head it show the normal amount of voltage that the board is providing but when the temp reach the MAXTEMP limit the multimeter keep showing a constant voltage of 12V after the limit is reach meaning that the temp keep going up until i power it off.

My board is a ramp1.4 running Marlin 1.1.0 RC7 but i previously had Marlin 1.0.3 with the same issue.
I tried running the print directly from an SDcard with the same result so its not the software.
My PID setting are all properly calibrated from the PID_Tuning web page
Tried changing the PID_MAX with no change
Tried turning the PID off and go with BangMax with the same result
Played with THERMAL_PROTECTION settings, WATCH_TEMP settings as well with no change (all those change have been made one by one on muuultiple occasions)
unplugged and re-plugged every cable, Tested the cable i made for shorts
I also change the heating element in the head with no change.

I'm all out of ideas and i hope this community as the answer.
I include some screenshot so you can see the temperature and power graph.

Edited 1 time(s). Last edit at 10/04/2016 03:22PM by Horatius.
open | download - overheating.JPG (111 KB)
open | download - overheatingcloseup.JPG (99.6 KB)
Re: Heated head Thermal Runaway
October 02, 2016 09:18PM
Probably one of the mosfets in your RAMPS board has failed.
You need to replace it.

Edited 1 time(s). Last edit at 10/02/2016 09:18PM by Veesta.
Re: Heated head Thermal Runaway
October 03, 2016 01:27AM
I doubt thats a faulty MOSFET.

Looks like its gate is not getting pulled down when its being switched off.

Assuming its not a firmware issue. Which it could be. (I'll be no help if it is)

Possibly a problem with the pull down resistor on the ramps board. Or the arduino gas a problem.

Put your multimeter on the gate pin of the MOSFET while its doing this and see if its getting pulled down low enough to switch off. It should be dropping to 0 pretty fast.
If its not start investigating why.

If you can't fix it with tape and tie wire. Its broken. You need a new one.


Moderators and RepRap Wiki editors have my full and unconditional permission to use any original photo's I upload for the wiki or any other way they may be of benefit to others.
Re: Heated head Thermal Runaway
October 03, 2016 07:38AM
Alright, thank you for these quick answer. I'll investigate as soon as i can and post my result.
Re: Heated head Thermal Runaway
October 04, 2016 03:19PM
Alright it is fixed !! I must say that you guys definitely pointed me in the right direction.
What you said Mongrel_Shark about the gate not being pull down got me thinking about the arduino firmware that might not be doing his job. I had an other hint when i looked closely at the temperature curve, the arduino was becoming unresponsive when the temperature was running away.
So i bootload a new firmware using this link :[www.gammon.com.au] . And it fixed my problem. now i have steady temperature.
Sorry, only registered users may post in this forum.

Click here to login