Welcome! Log In Create A New Profile


First print Issues, please help!

Posted by Thunder34 
First print Issues, please help!
October 07, 2016 02:06PM
Hey guys, I am excited to join the world of 3D printing! I have recently purchased a tronxy 3D printer kit with marlin v1.0 software. You can find a link to the product here: [www.amazon.ca]

I have the kit set up and as far as I know everything seems to be working properly, auto home, auto leveling and preheating is all functioning properly. My issues arrive when I try to print my first calibration cube. On the LCD screen, it shows that the print has started and the heated bed/extruder has reached temperature but nothing is happening.

Being new to the 3D printer world, I have a feeling it is an easy fix, but I have tried all that I can think of and thus I need some help so I turned to this forum. Any help will be very much appreciated! If you need more information about the printer or if you have an idea that could work, I will be happy to try any thoughts you may have. Thank you.
Re: First print Issues, please help!
October 07, 2016 02:36PM
Did you put it together or came assembled? How did you tested the ABL function? Are you trying to print from SD card or have you tried to print from the computer?

Several things might be at fault here and you need to narrow it down, could be a bad SD card, a wrongly setup endstop, a faulty g code, etc.

Connect your printer to a computer and check your printer endstop, movements and temperatures and then try to print from the computer.
Re: First print Issues, please help!
October 07, 2016 03:07PM
Hey, thanks for the quick response. I assembled it from a kit. I am trying to print from an SD card. I don't think it's the SD card though, as it's able to read everything that's on it properly i.e. folder names, g-code file names and all that, unless you were referring to some other issue with the SD. I will connect it to the computer now and see if that makes a difference, then post my results shortly. I'm not exactly sure how to set up the z endstop, the instructions that came with the kit were not exactly thorough, almost no software help was given.
Re: First print Issues, please help!
October 07, 2016 04:00PM
Ok, I thought that the software came pre installed on the board but I guess that's not the case. When I connected the printer via usb to my pc no software was installed onto my computer. I found a short notepad tutorial on the given SD:
The repetier software download website :

FTDI usb driver download website :

I downloaded the FTDI usb driver and the repetier software. I'm on repetier now but the software is not picking up my printer.

Edited 1 time(s). Last edit at 10/07/2016 04:56PM by Thunder34.
Re: First print Issues, please help!
October 07, 2016 07:36PM
Ok, I believe I have made some progress, I have established a connection with my printer using the repetier software on a windows 7 computer. I still don't seem to be able to communicate with the printer though, I have checked the baud rate of the port (9600) and I changed the repetier software to reflect that but still nothing. I'm not sure if I need to download firmware onto the printer as well or if there's something else, any advice will be greatly appreciated. I'm sure some of you can relate to the fact that setting up a 3D printers software on your own can be a huge pain. Thanks guys.
Re: First print Issues, please help!
October 08, 2016 07:58AM
9600 would be an unusually low baud rate. The product specs don't say what controller is being used, so it's hard to give you much advice. If it is a mega2560/ramps setup or compatible clone the most likely default baud rate is 250000.
Re: First print Issues, please help!
October 08, 2016 10:10AM
My thinking is that the g code generated is either corrupted or the wrong type, some boards like the old mighty board uses a different file format.

Can you post a photo of the board, that will allow us to assist you further.
Re: First print Issues, please help!
October 10, 2016 10:38AM
I just built the same printer but without the autoleveling.

Build videos:
Tronxy X3 Build Part 1 - YouTube
Tronxy X3 Build Part 2 - YouTube
First Print - YouTube

The firmware was preinstalled. If you see text on your LCD, then it's already working.

Most likely, the printer is never getting to temp--it get close but never reaches it. The PID may need tuning. I found I could cheat a little but manually turning up the heat, say 250ºC then drop it back to the desired temp after a short minute or two. It seems that It gets close to temp, but never gets there. Upping the temp then dropping it back seems to help get over the hurdle. Not a solution, just a temporary fix to get things moving.

My issues with the kit so far:
  • Missing parts -- Shorted M4x12s, M4 t-nuts, missing bearing and shim from v-roller wheel, few other screws
  • Cold solder joint on x stop. (easy fix)
  • Fan cools the hot end too much that my max temp was 210ºC. Not hot enough for ABS or ASA. Designing a shroud of my own.
  • detached control box. I prefer an all-in-one
  • right 'brass nut holder' warped (3d-printed and corner lifted from bed)
  • no eccentric spacers to dial in wheel tightness
  • acrylic feet (I added rubber stick-on feet)
  • weak manual (missing a couple steps)
  • no part fan for better PLA
  • no wire routing diagram. You're on your own.
  • control box can only be on the right (or the way I wired it, was the only way it would reach)
  • heated bed is passable, but maxes out around 100ºC stock. A few minutes to reach 55ºC, but over 20 to get to 100ºC. Also, it seems it may be warping. but I already added glass and thermal pads tha help compensate.
  • z-axis motors could be rotated 90 or 180 degrees around the towers to allow for a larger bed--250mm easily.
Things i Like:
  • cheap (I got it on sale for $195USD shipped)
  • v-slot 2020 extrusion
  • v-rollers--not round edged ones
  • better power supply case than most kits
  • power cord socket
  • power switch with fuse
  • Melzi V5 board that can be updated
  • manual bed leveling assist in preinstalled firmware (BUT want to update the firmware but do not have access to this nice feature)
  • five-button controls (prefer it to twist knob)
Sorry, only registered users may post in this forum.

Click here to login