Welcome! Log In Create A New Profile


Steppers will not move while heating

Posted by NukaCola 
Steppers will not move while heating
October 16, 2016 03:10PM
I am having trouble getting my cheapo kossel mini printing. I've been through just about everything I can think of aside from switching out the power supply for one with a higher amperage. My problem is when I home all the axis and move the hotend while cold, it works ok. But while heating the hot end, the axis will not move at all. thumbs down I did manage to kind of get the extruder stepper working (no full revolutions, only jerky movements). I am running everything through a MKS Base V1.0 with 12v 16A (supposedlyeye rolling smiley) power supply. I have tried to adjust the pots on the onboard steppers from 0.4V to 0.9V with no luck. Any input would be appreciated. I have also attached the config.h file in case someone wants to look through it.
open | download - Configuration.h (28.7 KB)
Re: Steppers will not move while heating
October 16, 2016 08:23PM
Isn't this normal behavior?
Steppers are held in place with current and you cannot force them to move.

when your printer is in idle, steppers are released after few moments and you can push them around again.
Re: Steppers will not move while heating
October 17, 2016 05:42AM
when you start 'printing' the firmware will 1st heat the hot end to the required temperature,it will not move
the axis untill the hotend has stabalised for about 10 seconds.
Is the hot end reaching the print temperature ?
Re: Steppers will not move while heating
October 17, 2016 11:19AM
Sorry I should have specified. I am using Repetier Host to control the printer as I have not fully calibrated it yet to print. I have ran a PID Autotune for the heater and bed. When the hotend reaches the desired temperature the axis will still not move when sent the command. I'm thinking the amperage might not be enough because I can also hear the fan speed drop considerably, and sometime when heating the bed and hotend at the same time the whole thing just resets itself.
Sorry, only registered users may post in this forum.

Click here to login