Welcome! Log In Create A New Profile


Having problems getting anything to heat properly

Posted by hugetoughguy 
Having problems getting anything to heat properly
January 14, 2017 04:19PM

I'm having problems getting ANYTHING to heat properly on my 3D printer. I am using a kessel mini style delta 3D printer driven by a 360W power source running through a melzi pro board. The board is not supposed to be complete junk according to users, but I am on my 2nd board now and still the same problem. With the power level of my power supply I should have zero problems but am still not able to even heat or warm my heat bed or hot end to more than 36-37 celsius. They warm VERY slowly and never get beyond this point. I have checked all hardware issues. The board appears to be powered correctly. I have replaced the board. I have replaced the thermistor to hotend, replaced the heat cartridge, checked wiring, connections, contacts, wire integrity, changed the heat cartridge twice actually, firmware appears to be good, etc. I am testing it through pronterface, so could there be some issue with pronterface or are there safety settings or other issues that need to be dealt with that I'm not aware of before a full heating is possible? No it is not in test mode and there appear to be no other issues all checks out so what is going on? It NEVER heats above 36-37 degrees. This is getting nuts, I would appreciate any info or help on this issue. Thank you!
Re: Having problems getting anything to heat properly
January 14, 2017 06:07PM
Connect your heatbed to the 12V & GND rail of your power supply directly for a few minutes. What temperature do you reach? Can you measure voltage & current?
Sorry, only registered users may post in this forum.

Click here to login