Welcome! Log In Create A New Profile


DIY Prusa i3 stopped rising on Z axis

Posted by terryd 
DIY Prusa i3 stopped rising on Z axis
March 01, 2017 11:09PM
I posted this in an older Thread but was advised to start a new thread and include G codes and photographs of failed prints so here goes:

I have a diy Prusa i3 made with the box frame, which I built about 3 years ago. I used it successfully but stopped using it after about a year and have just come back to it again.

I updated Marlin, Pronterface and Slic3r and serviced the machine. I had a few basic problems, such as levelling and prints warping and not sticking etc but these are sorted. it was just like starting over again and refreshing the processes. However I have run into a problem I have not seen before and wonder if anyone has any suggestions as I describe the problem below.

Last night I started a smallish print - a small idler for a direct filament drive - and it was printing well except for an overhang but that's beside the point. I left the printer running about a third of the way through as I was called away. when I returned the print was ok up to about halfway but then the rest was squashed and distorted. This morning I tried the print again and it started well, laying down the skirt and first layer but then as it printed subsequent layers the Z axis was not lifting and the printer was printing on the same level for each layer. I used a simple flag on the Z axis to see what it was doing. It was retracting and lifting between layers as normal but was returning to the same position, as shown by the flag, to print each layer thus giving no height to the print. I cancelled the print, loaded a re-sliced gcode, retried and had the same result.

I can raise, lower and home the Z axis as usual I have re-sliced the stl file several times but get the same result, I have even added a G90 code to the start code to no avail. I am at a loss, I am not technical enough to read the g codes, could it be that the firmware in Arduino is messed up? or is it something else. I made quite a lot of successful prints when I used the machine originally and have made a couple of nice prints recently but this has got me completely foxed.

Marlin, Slic3r and Pronterface, Motherboard Arduino Mega 2650 with Ramps 1.4 driver. All latest stable versions of the firmware and I've not changed any voltages to the motors.

Please help if you can I'm getting to the end of my tether.

G code and pictures attached but unfortunately I binned the later prints which were only one layer thick
open | download - Kraftwerk_-_basic_1_0_b gCODE LISTING.txt (437 KB)
open | download - Failed print.JPG (184.2 KB)
open | download - Failed Print_1.JPG (256.7 KB)
Re: DIY Prusa i3 stopped rising on Z axis
March 02, 2017 02:37AM
I just found out how to add an image to my posts so here is are a couple of pictures of the failed print. There is a step in the print a little way up but that was caused by me nudging the printer. As you can see the Z axis seemed to fail about halfway up the print. As I said the Z axis behaves impeccably when moved and homed when using Pronterface.

Thanks for looking

Re: DIY Prusa i3 stopped rising on Z axis
March 02, 2017 06:16AM
I had a similar Problem once.

Error was solidified Oil & Dirt on the Leadscrew. When going up, friction & load was to high to reach the required height. Going down was less Problem, because load is helping. As the Stepper got hot it started loosing steps.
So maybe do a good cleaning of your leadscrews and relubricate it with e.g. sewing-machine-oil (or any other not solidifying oil)

Edited 1 time(s). Last edit at 03/02/2017 06:17AM by Dancer.
Re: DIY Prusa i3 stopped rising on Z axis
March 02, 2017 07:31AM
Z steps are in there. Note:- doesn't look like you set a z offset for the first layer.
Pictures of the machine would be useful.
Re: DIY Prusa i3 stopped rising on Z axis
March 02, 2017 10:44AM
The problem with Prusa i3 X-carrier is: the horizontal rods are clamped in between X-motor carrier and X-idler carrier. The clamping force must be higher than the X-belt tension. Otherwise the X-carriers get pulled together and cause binding on the z-rod linear bearings.

I guess, over the years your X-carriers have lost their ability to clamp the rods firmly ( oil might have crept in there too ).
Re: DIY Prusa i3 stopped rising on Z axis
March 05, 2017 12:58AM
Hi all,

thanks for your advice which I tried,

Dancer - when I checked, the threads were clean and dry, I use PTFE dry lubrication on my rods and threads.

McCarman - when I checked the gcode the Z offset for the first layer was 0.35 with 200% extrusion, and the rest set at 0.3 mm. In subsequent tests the first layer was good but then the print just carried on at the same level, the Z screws were retracting at the end of the layer but then resetting back to the first level on each layer.

o_lampe - the X axis rods and Z axis were fine. When I raised and lowered the x axis there was no problem and the lift was accurate when checked over 100 mm with digital calipers.

I think that I have solved the problem now, I reconfigured a new installation of Marlin (1.1.0(RC8)) and re flashed Arduino. The layering is now accurate but another problem has arisen, that may be the subject of another thread,

Once again many thanks for your efforts in replying which is much appreciated, it certainly got me thinking and analysing the problems,

Sorry, only registered users may post in this forum.

Click here to login