Welcome! Log In Create A New Profile


Firmware Issue? Cannot establish my home position.

Posted by JackOfDesign 
Firmware Issue? Cannot establish my home position.
March 22, 2017 03:45PM
Hello all,

I have been lurking in the forums for a while now and have not found anything similar to what I am experiencing.

Backstory - 1.5 years ago I bought a Q3D OneUp (big mistake). About 4 months ago I had a motor burn out and decided to upgrade to something sturdier and cannibalize the One Up. I kept the Ramps 1.4 and the Arduino Mega 2560 board. I converted to a Prusa i3 clone frame, added end stops and dual z axis motors. I am thinking the end stops may be my downfall but please keep reading. I have the printer set up and can manipulate each axis using Repetier Host and Printrun pronterface until I hit the home button. I have y min and y max and z min and z max endstops installed. I plan to do x as well but need to print some brackets! Alas, I need a printer to do so!

When I used the one up, I would manually move the extruder to my start position, connect to the printer and then hit the house icon in Repetier host to establish the home position. Now I have attempted to do the same thing. When I hit the house icon in Repetier host, the z axis moves downward probably 5 mm which engages the z min and then freezes the system.

I tried loading the Sprinter firmware and use pronterface. I manually move the extruder to my home and then when I push the home icon, the printer moves in the x about 2 mm, the y about 2 mm and then moves upward in the z direction about 5 mm. When I start a print, the z axis stays at this level and just oozes PLA in a big glob. Additionally, the x and y axis movements do not follow the gcode. It tends to stay in the same orientation and just extrude material with an occasional jog in the x or y direction.

I have tried sending G92 X0 Y0 Z0 in both instances with no effect. I have also added @isathome with no effect.

When any endstop is reached the system freezes and I have to move the bed/axis off the end stop and cycle power to regain control.

After a failed print the extruder moves in a positive x and y direction and then seems to reestablish itself as at home. I am unable to move the axes in a negative direction using the GUIs.

I used the stock repetier arduino code and the stock sprinter code. All I've changed in the slic3r settings are bed size. Using Repetier I think my EEPROM settings are fine.

I'm not sure what to show you in terms of settings or the like so if you have any ideas I'd love to hear them!

Thanks in advance!

Edited 1 time(s). Last edit at 03/23/2017 12:01PM by JackOfDesign.
Re: Firmware Issue? Cannot establish my home position.
March 23, 2017 02:32PM
Take one of your Y endstops and use it for the X axis and modify your firmware to match the directions of your axis so when you home your printer each axis moves in the proper direction.
Sorry, only registered users may post in this forum.

Click here to login