Welcome! Log In Create A New Profile


My extruder loses steps

Posted by Gorebar 
My extruder loses steps
June 01, 2017 04:52PM
Hi, I have a problem with my extruder, Everything worked perfectly I printed large things for many hours without any problems, but it took a couple of days for the extruder to lose steps in some areas of the hot bed, it's strange but it's usually the same area (usually).

The printer is a remix of the prusa i3, it is called prusa i3 power code, I myself assembled it by pieces and it has been running without any problems until now.

I have tried to calibrate the pololus again, they are correct but still failing, I have looked if the hotend is stuck and nothing, clean, what is most strange is that it usually occurs in the same place as the print, I have tried different designs and Always happens the same In some areas they give as jumps and do not print.

I put a link of a video that I made of the problem.


Any suggestions? Thanks
Re: My extruder loses steps
June 01, 2017 05:18PM
What do you mean your extruder misses steps?

Is there not enough filament coming out of the hotend (direct driver, bowden, wade?), or does your X and/or Y axis lose steps and thus it looks like your print is 'losing steps'? If you say your drivers are tuned correctly (which drivers are you using?), have you looked at your extruder motor overheating or your driver overheating? If the extruder stripped the filament it would normally not continue printing. Can you hear the extruder motor skipping?

You say it only happens in certain areas of your hotbed... perhaps your bearing is acting up. I have had a bearing acting up but it was more random than only a specific area. Still it may be worth it swapping it out if you have a spare one available.
Check your belts for any damage, change the tension a bit if you can.

Also, your video did not work (for me at least), it says the video is not available.

Hope you get it sorted out.
Re: My extruder loses steps
June 01, 2017 05:23PM
Check the wiring to your extruder stepper. If you have a loose connection, or broken wires inside the insulation, they will touch in some positions as the hot-end moves the wires, and not touch in others.

Also check the wiring to the hot-end (the temperature graph on Repetier Host or whatever you're using to drive the printer would also show spikes)... if the heater wires are broken/loose, the heater will disconnect/connect at some positions, and the hot-end temperature may fall to the point where the filament jams. Some firmware (e.g. Repetier) detects this. Also look for shorting near the heater cartridge... the insulation can pull back and expose the wires, and any broken strands can then short the heater out.

To prevent these issues, use a cable-chain or similar, and rigidly attach the wiring bundle at each end, so that bending of the wires happens across the whole length of the whole bundle, not just at the ends.
Re: My extruder loses steps
June 02, 2017 02:17AM
@v1talogy answer:

wel... is a Greg's wades extruder, while is printing, sometimes the gears make a strange sound like "clac, clac, clac..." without print anything. The X and/or Y axis works good, I thought.

I'm using A4988 driver with a NEMA 17 4.8kg.

I have not checked for an excessive temperature rise. Everything seems to be good at temperature.

And the video... it's strange, check here



@frankvdh answer:

I'll check all my wires to see... Thanks

Edited 2 time(s). Last edit at 06/02/2017 02:19AM by Gorebar.
Re: My extruder loses steps
June 02, 2017 03:40AM
Mm ok, most of my response will be around the clack clack clack sound you mention.

I have no experience with Wade extruders, but I have read about them a lot smiling smiley. If your temperatures are not too high (you must always be able to touch a motor indefinitely in my opinion) then it may be that your extruder driver is not driven hard enough.
You have mentioned that you have tuned them correctly, and I apologise for saying this again, but it is the only solution I can think of. There are many A4988 editions available and the voltage on the potentiometers vary according to the size of the sensor resistors on them. This page explains it nicely (the current limiting section), and what I mean is some pololu drivers produce 1A with a voltage of 0.3V and others with 1V+. Have you checked your sensor resistors and calculated the correct current to drive your motors? The correct current is also calculated based on the current rating on the driver motor, 4.8kg sounds like a motor with a roughly 1.2A rating? I only drive the extruder motor hard, none of the other motors.

Check the tension springs on your extruder, there should be a great deal of force on the filament to be able to push it into the hotend. Also make sure that the teeth are clean and free of debris.

This still does not explain the problem you mention about the problem only occurring on certain areas of the board. The advice @frankvdh gave seemed pretty legitimate and I would also think it is a mechanical issue and not electrical.

Edited 1 time(s). Last edit at 06/02/2017 03:43AM by v1talogy.
Re: My extruder loses steps
June 05, 2017 08:11PM
The clack clack sound means you have enough tension on the springs. If there wasn't, the motor would turn and grind away the filament rather than skip.

There are *many* possible causes of the extruder skipping
  • the nozzle being too close to the bed
  • too high OR low nozzle temperature
  • too high OR low extruder stepper current
  • overheating stepper driver
  • bad filament path
  • jammed filament spool
  • poor quality hot-end
  • too much spring tension
  • overheating stepper motor

You say it only happens in some parts of the bed, and that you have previously had many successful prints. So I still think that it's wiring that's become fatigued and the wires are cracked/broken inside the insulation.
Sorry, only registered users may post in this forum.

Click here to login