Apparent problem with A4988 microstepping
June 13, 2017 09:41AM
Hello

So, I have been trying to build a 3d printer of my own based on the design of the Prusa I3, and I have encountered a problem with my stepper motors/drivers. It started with the motors only buzzing really loud and not moving at all. After much fiddling, I found out the problem was the steps/mm parameter, which was too high. I have decreased it, and even though now it moves as much as it should, it does so while vibrating a lot!

After much reading, I found out I should measure the voltage on the MS1, MS2 and MS3 pins of my A4988 drivers. I did so with the one controlling the X axis, and found out that there is no voltage running in any of those pins. So basically, it's working in full step, which explains both the default steps/mm being too high and the vibration. It's probably not the drivers fault, as I have tried several different A4988 drivers on the same spot, and the vibration is always there.
I must also say that I think all the other drivers may suffer from the same problem, as I have also had to decrease the steps/mm for them and now they also vibrate a lot.

What could be wrong, and could be done to fix it? Could it be the RAMPS 1.4 board itself which is at fault?
Re: Apparent problem with A4988 microstepping
June 13, 2017 10:18AM
Are the microstepping jumpers installed on the pins under the driver on the main RAMPS board?


Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Apparent problem with A4988 microstepping
June 13, 2017 10:37AM
Until you mentioned that name, I didn't know what those black pieces were for. I have now searched and it's probably that. I will try it once I get home from work.

Thank you very much. smileys with beer
Re: Apparent problem with A4988 microstepping
June 14, 2017 06:12AM
Greetings,

Your solution solved the problem I mentioned. But now another one surfaced.
Now, when trying to home the axis, the z-axis will move ever so slightly, stop and start vibrating and making lots of noise. This can only be stopped by resetting the RAMPS board.

Do you have any idea what may be the problem now?

EDIT: nevermind, I was using the wrong threaded rod diameter for my calculations...

Edited 1 time(s). Last edit at 06/14/2017 06:56AM by Koizito.
Sorry, only registered users may post in this forum.

Click here to login