Hi guys,

For some this might be an easy answer but I've been trying to get that perfect first layer, I was able to fix this by changing the z offset on the arduino software and uploading to the ramps board.

My z_offset is set to -1.36 which was the closest I got it to printing well but to close (not a perfect line) I'm making changes and uploaded but none of the changes are taking affect.

Could it be that I need to push a g-code to recognize the new z_offset?

Could it be that the new filament cura profile (vers.15.04.6) needs a specific g-code to print on that z_offset instead of 0.00? I believe this fixed it last time, reason I think this is it because I'm running stock g-code settings after reimaging my pc "forgot to save that I messed up, but even before this I was still troubleshooting the printer so maybe it wasn't a bad thing to start from scratch again.

A bit puzzled at the moment but I'm sure someone here will be like dude I ran through the same issue put this g-code in after it auto homes g29 and then this g-code to print at that offset and your set

Printer - Makerfarm Prusa i3 8
Running on Marlin
Hotend - E3D-V6
Heated Bed - Glass Surface with Hair spray

Other info
Auto Bed Level Settings on configuration.h
Z_offset - -1.36
Auto Bed Leveling Enabled - 9 point

G-Code
Stock Settings so nothing crazy here it's pretty much what comes in cura
eeprom settings have preference over values set in the config file

push
M502
M500

to update eeprom with the config settings

or you could use the M206 to edit Z offset directly
[marlinfw.org]

Edited 1 time(s). Last edit at 07/03/2017 05:27PM by obewan.
Thanks man Imma try that now
Quote
obewan
eeprom settings have preference over values set in the config file

push
M502
M500

to update eeprom with the config settings

or you could use the M206 to edit Z offset directly
[marlinfw.org]

Obewan you were right, after making changes and uploading the firmware I went on Octoprint and pushed those two commands and wallah the changes I was making on the z_offset were taken into affect. I had to spend several hours and the morning to get a solid first layer but your commands definitely helped thanks man
Sorry, only registered users may post in this forum.

Click here to login