Nozzle 2mm above bed when printing
November 16, 2017 08:01AM
Hi everybody,

I've been using my mendel90 for 2 years without any problems, I just love this machine. I did not buy a kit from Chris but self-sourced all the parts. I'm using this board: []. I've been using Marlin 1.1.0-RC2 since the beginning.
However I've been scratching my head as my mendel90 is behaving strangely, it started about a week ago: when I start a print, the nozzle is 2mm above the bed instead of being at 0.3mm. The first time I saw this I stopped the print and from pronterface issued a G0 X0 Y0 Z0, no problem, the nozzle was at the expected height. I then restart the print, same problem, the nozzle was 2mm above the bed confused smiley
I checked the gcode file, nothing special appeared to me, I've been using Slic3r from the beginning with no problems. I decided to try cura to generate the gcode and the same problem occured, the nozzle was 2mm above the bed when the print started.
I then tried again to send a G0 X0 Y0 Z0 from pronterface and the nozzle was correctly positioned!
Then I edited the gcode file to put a G28 and a G0 X0 Y0 Z0 as the two first instructions and started the print, the nozzle went down and stopped at 2mm while heating the bed...
Before I'm starting to think that the universe doesn't want me to use my printer anymore, I decided to as you guys if you ever encountered such behavior?
Re: Nozzle 2mm above bed when printing
November 16, 2017 08:22AM
Did you maybe by error enter a z-offset in Slic3r?
Re: Nozzle 2mm above bed when printing
November 16, 2017 08:36AM
I thought about this and checked and no, there is no offset specified. Moreover I have the same result using the Cura slicer sad smiley
Re: Nozzle 2mm above bed when printing
November 16, 2017 09:58AM
Could you post the first lets say 100 lines of your g-code file, so we can see if the error is in the g-codes?
Re: Nozzle 2mm above bed when printing
November 17, 2017 05:16AM
Here is the beginning of the file generated by Slic3r:

; generated by Slic3r 1.2.9 on 2017-11-15 at 1:13:56

; external perimeters extrusion width = 0.40mm
; perimeters extrusion width = 0.67mm
; infill extrusion width = 0.67mm
; solid infill extrusion width = 0.67mm
; top infill extrusion width = 0.67mm
; support material extrusion width = 0.40mm

M104 S200 ; set temperature
G28 ; home all axes
G1 Z5 F5000 ; lift nozzle

M109 S200 ; wait for temperature to be reached
G21 ; set units to millimeters
G90 ; use absolute coordinates
M82 ; use absolute distances for extrusion
G92 E0
G1 Z0.300 F7800.000
G1 E-2.00000 F2400.00000
G92 E0
G1 X61.038 Y104.769 F7800.000
G1 E2.00000 F2400.00000
G1 X63.724 Y104.587 E2.17991 F1800.000
G1 X65.999 Y110.689 E2.61497
G1 X66.218 Y111.354 E2.66170
G1 X66.343 Y111.993 E2.70524
G1 X66.369 Y112.348 E2.72900
G1 X66.360 Y112.622 E2.74732
G1 X66.325 Y112.853 E2.76294
G1 X66.274 Y113.052 E2.77663
G1 X66.173 Y113.273 E2.79287
G1 X66.063 Y113.422 E2.80525
G1 X65.864 Y113.610 E2.82355
G1 X65.694 Y113.713 E2.83682
G1 X65.460 Y113.795 E2.85335
G1 X65.214 Y113.791 E2.86984
G1 X65.015 Y113.739 E2.88358
G1 X64.794 Y113.639 E2.89979
G1 X64.524 Y113.465 E2.92121
G1 X64.187 Y113.145 E2.95224
G1 X63.999 Y112.872 E2.97442
G1 X63.562 Y111.802 E3.05161
G1 X62.930 Y110.082 E3.17404
G1 X61.058 Y104.826 E3.54680
G1 X60.974 Y104.374 F7800.000
G1 E1.54680 F2400.00000
G92 E0
G1 X57.956 Y103.471 F7800.000
G1 E2.00000 F2400.00000
G1 X57.002 Y103.330 E2.06446 F1800.000
G1 X57.529 Y102.732 E2.11768
G1 X57.897 Y102.233 E2.15915
G1 X58.097 Y101.911 E2.18445
G1 X58.383 Y102.125 E2.20827
G1 X58.145 Y102.649 E2.24675
G1 X58.012 Y103.113 E2.27901
G1 X57.966 Y103.412 E2.29917
G1 X58.771 Y101.746 F7800.000
G1 X58.326 Y101.413 E2.33629 F1800.000
G1 X59.343 Y99.138 E2.50278
G1 X59.626 Y98.402 E2.55548
G1 X60.291 Y99.174 E2.62356
G1 X60.659 Y99.536 E2.65805
G1 X61.786 Y100.475 E2.75605
G1 X60.416 Y100.793 E2.84999
G1 X60.074 Y100.909 E2.87410
G1 X59.707 Y101.072 E2.90091
G1 X59.411 Y101.241 E2.92370
G1 X58.817 Y101.708 E2.97418
G1 X58.504 Y102.044 F7800.000
G1 X57.905 Y101.207 F7800.000
G1 X57.454 Y101.932 E3.03120 F1800.000
G1 X57.112 Y102.396 E3.06970
G1 X56.609 Y102.966 E3.12050
G1 X56.184 Y103.341 E3.15834
G1 X55.804 Y103.596 E3.18892
G1 X55.603 Y103.700 E3.20407
G1 X55.256 Y103.826 E3.22869
G1 X55.022 Y103.861 E3.24451
G1 X54.670 Y103.846 E3.26809
G1 X54.360 Y103.747 E3.28984
G1 X54.075 Y103.531 E3.31370
G1 X53.891 Y103.313 E3.33274
G1 X53.805 Y103.164 E3.34425
G1 X53.692 Y102.828 E3.36795
G1 X53.660 Y102.439 E3.39397
G1 X53.700 Y102.031 E3.42139
G1 X53.818 Y101.559 E3.45392
G1 X54.041 Y100.993 E3.49451
G1 X54.356 Y100.411 E3.53869
G1 X54.718 Y99.874 E3.58199
G1 X55.306 Y99.147 E3.64446
G1 X55.822 Y98.555 E3.69693
G1 X56.569 Y97.799 E3.76792
G1 X56.949 Y97.462 E3.80183
G1 X57.320 Y97.184 E3.83280
G1 X57.726 Y96.955 E3.86396
G1 X58.020 Y96.884 E3.88417 F1800.000
G1 X58.276 Y96.886 E3.90126
Re: Nozzle 2mm above bed when printing
November 17, 2017 05:46AM

As you are using Marlin 1.1.0 RC2, which is quite old - might it be this Problem???

Do you maybe have EEPROM enabled - Maybe for some kind of reason there has gone a wrong value into EEPROM?
Do a M503 from your Host-Program and write down al the values
Do a M502 and M500 - This should reset EEPROM to factory settings
Re: Nozzle 2mm above bed when printing
November 17, 2017 09:05AM
Thanks a lot for taking the time to read the gocde.
The EEPROM is not enabled in my firmware.
I configured and compiled the latest marlin version but I couldn't upload it to the melzi board sad smiley (avrdude: stk500_recv(): programmer is not responding). The strange thing is that with the 1.0.6 version of the arduino ide I have no problem uploading my old firmware, but when I use the latest version of the arduino ide to compile the latest marlin I cannot upload... I tried compiling the latest marlin in the 1.0.6 version of the arduino ide but it stops the compilation saying that my arduino version is too old, which is damn right!
Re: Nozzle 2mm above bed when printing
November 20, 2017 05:43PM
I finally could upload the latest marlin using the version 1.8.5 of the arduino ide by reducing the upload speed to 57600.
Unfortunately the behaviour is the same, the nozzle gets correctly positioned when I issue a G0 X0 Y0 Z0 or G1 X0 Y0 Z0 from pronterface but when I start a print the nozzle is still higher for the first layer... I really don't know what to try next sad smiley
Re: Nozzle 2mm above bed when printing
November 21, 2017 04:32AM
Try M119 to make sure the endstop isn't being triggered even though it allows you to go to zero afterwards. Probably isn't, but it is something to try.
Re: Nozzle 2mm above bed when printing
November 21, 2017 09:28AM
Are you saying the nozzle is above the bed while doing the 1st layer of the print, or just that it is above the bed while heating up ?
Re: Nozzle 2mm above bed when printing
November 22, 2017 04:01AM
The nozzle is hovering above the bed while printing at approximately 2mm but the first layer should be 0.3mm thick. If I stop the print, home and then issue a G0 X0 Y0 Z0, the nozzle is perfectly positioned, I can slip a piece of paper between the nozzle and the bed and feel a slight friction. If I then home the printer and start a print, the nozzle hovers 2mm over the bed for the first layer. What amazes me is that my mendel90 has been working flawlessly for 2 years and started showing this behavior very recently, without changing making any changes to the firmware.
Re: Nozzle 2mm above bed when printing
November 22, 2017 10:56AM
Try putting a G90 between the G28 and G1 Z5 F5000 lines, clutching at straws but i cant see anything else in the G code that could have any effect.
Re: Nozzle 2mm above bed when printing
November 24, 2017 04:19AM
Thanks a lot guys for taking the time to read my posts! I could "solve" the problem yesterday evening: not knowing what to do I uploaded once again the firmware BUT this time I enabled the eeprom, homed the printer and issued once again a G0 X0 Y0 Z0. This time the nozzle was 2 mm above the bed, at the same position it was when I was trying to print. I then corrected the max Z value in the firmware (I could have changed it through gcode commands but I used the method I've been using for two years without the eeprom), uploaded the firmware and my mendel90 is know printing again smiling bouncing smiley
In the end I don't know what was happening before but I least now I can print grinning smiley
Re: Nozzle 2mm above bed when printing
December 04, 2017 04:57AM
Good to hear you solved it.
Sorry, only registered users may post in this forum.

Click here to login