Welcome! Log In Create A New Profile


Can someone explain me whats wrong here?

Posted by FriedrichNietzsche 
Can someone explain me whats wrong here?
May 13, 2018 05:25AM
Since a few weeks I have a Anet A8 and I am still in the 'getting used to it' phase. After printing some stuff to improve the printer itself I wanted to print my first 'real' part. But here the printer fails all the time already when printing the brim. It starts out well, but the lines becomes more uneven, the farther inwards are. Finally the will get so uneven, that the nozzle will tear the part from the glass bed. The funny part is, that before changing the retraction setting (because I had stringing), it worked much better (but with stringing).
Any idea how to fix this? Thanks!

Re: Can someone explain me whats wrong here?
May 13, 2018 08:42AM
which "improvements" have you done?
if you change the retraction settings now or disable retraction completely, does it work better?
same issues with a different model?

Edited 1 time(s). Last edit at 05/13/2018 08:44AM by Kutulu.
Re: Can someone explain me whats wrong here?
May 13, 2018 09:33AM
Hi, thanks for the reply

the standard stuff, that everyone recommends:

Circular fan duct
Igus linear bearings
X and Y belt tensioners
Glass bed

No, I increased the retraction value in Cura to 8 mm (from 6.5) to prevent stringing. I can't tell if it works better, because the printer messes the print up already before finishing the brim. The stringing I experienced later, when he prints the holes inside of the model. So far I did not try another model. I was hoping for an easy answer grinning smiley
Re: Can someone explain me whats wrong here?
May 14, 2018 12:56AM
When the brim gets wavy, it's a sign for too much 1st. layer extrusion.
There are several reasons for this:
1. nozzle too close to bed ( most likely your problem, since you added the glass bed )
2. extrusion width for 1st. layer set too high in slicer
3. extruder not calibrated or wrong extrusion factor in slicer
Re: Can someone explain me whats wrong here?
May 18, 2018 11:53AM
Hey guys,

sorry, had a busy week.

Did some further digging and I'm getting more and more to the conclusion that there is a problem with the Z-steps.
I now had it two times, that I've done the calibration and the Z-axis was way off.

The history so far:
1: Default in the firmware was 400 steps/mm, but the printer moved only about 75 mm for 100 mm in the firmware
2. Adjusted it to ~500 (don't remember the result)
3. On a later measurement there were again ~390 steps needed to move a mm


4. Did measurements again now. Turns out, that the axis again is moving only ~79 mm per 100 mm in the firmware
5. Adjusted it to calculated 489 steps. Another test showed, that it was almost perfect.
6. Forgot to save the values. I powered the printer down and up again. The 489 steps from before were lost, but the preset 390 steps from before again hit the mm more or less perfect

My theory: The z-axis sometimes moves 20 % less than it is supposed to which makes the nozzle dive into the earlier printed layers and messes them totally up. But the guided rods are supposed to have a 2 mm pitch. The steppers should have 1.8° per step so 400 half steps should represent a mm, which makes those ~ 500 clearly wrong. But what could cause something like this? Are there any known bugs in the Marlin/Skynet firmware (which I am using)

Edit: Just discovered, that skynet3d is dead. So doing a firmware update now.

Edited 1 time(s). Last edit at 05/18/2018 12:11PM by FriedrichNietzsche.
Re: Can someone explain me whats wrong here?
May 19, 2018 02:03AM
To me it seems your Z-axis misses a few steps sometimes. Better look for mechanical reasons or raise stepper current.
Re: Can someone explain me whats wrong here?
May 19, 2018 07:33AM
Ok today another try.

I solved the issue of the brim getting ripples and wobbly: Turns out, that the Cura default of a 0.3 mm initial layer messes everything up. Changed it now to 0.1 mm and the first layer gets almost perfect. Unfortunately the print seems to grow faster than the printer expects. With 100 percent flow the nozzle starts to carve through the print sad smiley( A flow rate of ~40 % seems to solve it partly, but that seems to me way to low to be reasonable. Also the brim gets very thin with the lines partly not touching each other anymore. I don't get it: I printed with 0.1 mm layer height from the beginning. The prints never turned out perfect, but they at least got printed.

3D printers certainly are a frustrating hobby.
Re: Can someone explain me whats wrong here?
May 21, 2018 06:55AM
Ok, got the printer back to print in an acceptable quality. The singe most important thing was reducing the initial layer thickness to 0.1 mm

But I also reset the printer settings to factory and started with a new Cura profile from scratch.
Re: Can someone explain me whats wrong here?
May 22, 2018 03:25AM
Hmmm, it could have been an Eeprom issue. Just for the record: you have to send M502 & M500 after you flashed a new FW-version when you've enabled Eeprom.
To be save, I run "eeprom erase"-sketch everytime before I flash new FW.
Sorry, only registered users may post in this forum.

Click here to login