Welcome! Log In Create A New Profile


RAMPS 1.6+; motors don't move

Posted by Loader009 
RAMPS 1.6+; motors don't move
October 26, 2018 01:59PM
Hey there,

I ordered my first RAMPS 1.6+ from aliexpress -> [www.aliexpress.com]
This one -> [ae01.alicdn.com]

But I am having problems...
First off, I did two mistakes.

1. I connected USB to Arduino (clone) Mega 2560 while it was powered by RAMPS. But this seems to be no issue, it still works with the VIN at 12V, nothing seems to be broken. (Only the cable got pretty warm [that's how I noticed it] and one of my micro usb cables is broken now.)

2. The always-do-mistake, I have put the 12V cable in reversed. One fuse was broken (11A SMD fuse... never SMD for that again), I "replaced" it by soldering glass fuse via cable (5A fuse, I don't need 11A because the bed is heated with a separate mosfet). After replacing it, everything except the motors work.

The Problem; the stepper drivers seems to be powered, none of the motors move a single inch (like they are not even powered at all, I can move the axis' by hand).
Though I gave my best to find the problem, I am clueless.

What I did:
- checked the diodes (D1 & D2) with an DMM; they still work one-way.
- checked one of the stepper drivers + stepper motor with a stepper driver tester; I could move the X-Axis in both ways without any issues.
- checked the connection of X-EN, X-DIR and X-STEP to the Arduino with an DMM; no problems at all.
- checked if the three of them do a signal with an analog oscilloscope (still a beginner with this) and they look to be fine.
- checked voltages across the stepper driver, VCC-MOT has 12V, all of the X-MOT have 12V (which kinda surprises me). VCC for the stepper driver has 5V.
- used RAMPS 1.4 test code from the wiki and set X-ENABLED to HIGH, still no movement.

Please give me any suggestions, I would even check it twice, in case I did something of the above wrong.

Edited 1 time(s). Last edit at 10/26/2018 02:03PM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 26, 2018 07:02PM
for most stepper drivers modules enable is active low... so setting enabled high will disable it.
Re: RAMPS 1.6+; motors don't move
October 27, 2018 06:19AM
Thanks, I didn't know that.
I corrected it, the first test (only with X stepper driver & motor) worked, X-axis moved.

Then I put in Z stepper & X-axis motor to Z stepper, X stepper still on board. It didn't move.
I removed Z stepper and have put X motor back to X stepper (like in the first test). It doesn't move again.

I guess it's something with electronics on the RAMPS... any idea what?

edit: I think one of the cables to the motors have a short... need some time to check that.
I also need to wait a bit after I turned off the RAMPS. I guess it makes issues if I turn it off and on too quickly.

Edited 2 time(s). Last edit at 10/27/2018 06:24AM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 27, 2018 06:26AM
unplugging or plugging in stepper motors while the stepper driver is enabled will kill the stepper drivers. The controller should be off. (no 12v and no usb power)

If you have different stepper motors they can have different wiring (even with same colors)

My guess is you now have no working stepper drivers.
Re: RAMPS 1.6+; motors don't move
October 27, 2018 07:49AM
The stepper drivers (X and Z) are ok. (I tested them with the stepper driver tester, didn't check the others yet.)
I know that I have to unpower the board if I want to plug/unplug the motors or anything.

I still cannot find the random working/not working issue.
Maybe the diode D2 is damaged and stops working if there is too much amps?
Or one of the mosfets stops working if too much amps is being drawn?

PS: I owned a Sanguinololu before, which stopped working for an unknown reason.
So this is not my first printer board, but my first RAMPS. I took the stepper drivers from there to this board,
Ice Blue Stepsticks -> [reprap.org]
They also have electrical short protection for the motors.

Edited 1 time(s). Last edit at 10/27/2018 07:53AM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 27, 2018 02:30PM
Did you try a differen psu? Sounds like the psu may have a grounding issue sending power through the usb lead to the pc. Also check what the ripple is on the psu supply real is visible with oscilloscope (ac on top of the dc voltage). This may interfere with the mcu and/or stepsticks. Also check the stepstick and ramps schematics and check if the board is actually conforming to the schematicsbon this websites wiki pages. Chinese clones may have some slight differences. Ie my ramps board have all microstepping jumpers connected to 5V, even when no jumpers are placed.

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
October 27, 2018 03:05PM
Thank you for your suggestions, I will check the following tomorrow:
- different psu (actually I hear some kind of clicking noise inside the psu [not from the fan inside], but it didn't bother my old sanguinololu until recently.)
- about the grounding issue, in generell one have to cut a trace or remove D1 to be able to use usb. I didn't do that initially and I guess the transistor on the arduino clone tried to power my usb hub and my usb hub did the same to the arduino clone. Not good, but nothing damaged, I think.
- I check the ripple with my oscilloscope on the 12V line, luckily I did that once on another device, so I know how to do that. You might be right that it might interfere with the mcu/stepsticks, especially if the mosfets for bed/E0/E1 is enabled. I noticed a slight movement of the signal to the "left" when one of the mosfets is enabled. But I don't know if this does mean anything, maybe I am misinterpreting the signal because of no experience.
- still have to check any connection issues to the motors - the X motor connector hasn't been touched recently, so this one is the most reliable one for testing.

To the other points:
- you might be right about the schematics, but weird thing stays werid. The X stepper driver moved (in the Z driver "plug") the motor, though, the Z stepper driver didn't move any motor yet on RAMPS (but it works on my stepper driver tester!?!). I will recheck the schematics and note what is right/wrong.
- even if the microsteppings are all set to high, the stepper driver would fall back to its max/min setting and would move the motor (or at least block it, so I can't move it by hand). Though, I haven't checked if they are all high by default, I will check that. But I guess that it is working correctly, the RAMPS board have been sold a dozen times (and the seller/manufacturer is known to some review sites) and no one complained about such problems.
Re: RAMPS 1.6+; motors don't move
October 28, 2018 07:42AM
So, here are the results:
- Different psu doesn't change the issue.
- Ripple of the (first) psu is about +-0.2V, nothing to be worried about.
- All stepper driver are OK after testing them with my stepper driver tester. This one, if you are wondering -> [reprap.org]
(but mine is not from reprap.me and the components like the connector and the big cap have different colors)

stepper settings: MS1/MS2 are floating (around 0V), MS3 is High, that's what I set
All-STEP pins (according to original RAMPS 1.4 schematics) are influenced whenever E0 heating is turned on. Here you see how -> [youtu.be] I don't know if this is bad or not.
All-DIR pins get a periodic HIGH according to the RAMPS 1.4 test code.
All-EN pins are LOW all the time.

I haven't took the time to investigate the schematics yet, but the X stepper wouldn't have worked, if it wouldn't match at least partially.

After testing the steppers one by one, I put all of them on RAMPS, connected the motors (but loosened the bolds, so they don't actually move the axes).
All of them moved at first, though, they kinda cycled (don't know the order yet, I only hear different sounds). I also hear the influence, whenever E0 heating is on (but no heater connected).
Then all of them suddenly stop, like something stopped because of overheating, but I can touch the stepper driver. I can repeat that after some off time.

Maybe the stepper drivers are really broken? Or can it be the transistor or diode?
I tested the X stepper on the stepper driver tester for a little longer than the others, it moved for a longer time than the RAMPS and it did not stop working.

Or the Arduino clone is kinda broken?
Re: RAMPS 1.6+; motors don't move
October 28, 2018 11:05AM
I think this is the problem:
MS1/MS2 are floating (around 0V)

The MS1..MS3 pins (any logic input pins actually) shouldn't be left floating, they should either be connected to logic low or logic high. What happens when left floating is that due to the high impedance (between 50 and 100k Ohm) any parasitic charge may be built up causing it to sort of randomly flip from low to high and vice versa or when between the logic levels (ie between 0.3xVdd and 0.7xVdd) the state is undefined and could cause unexpected behavior. Just place all jumpers and it should be ok.
Make sure you change the steps per mm to reflect this setting. I see in the RAMPS schematic only MS1 is pulled down to GND, the others, when not jumpered, are left floating. I'm not sure what the reasoning was behind that, most likely a flaw in the design.

The A4988 datasheet states that all pins have a pulldown resistance (100k for MS1 and MS3, and 50k for MS2). It's probably due to space constraints that no 3 way jumper could be placed under the stepstick. In a noise free environment this could work without pulling the pins down with a lower resistance but a DIY 3D printer is far from noise free and shielded.

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
October 28, 2018 12:28PM
Thank you for the explanation, but sadly the issue isn't gone with MS1/2 set to high.

- ramps is turned off; (arduino still has the ramps test code flashed)
- removed the stepper drivers
- set jumpers for MS1/2/3 (though, the stepper driver has only MS1/2 after researching a bit - it is a A4982, not A4988. A4982 datasheet -> [www.allegromicro.com] )
- put back stepper drivers
- turned on
- motors moved for about 30 seconds and stopped (LEDs are still rotating)
- turned off, waited about 10 seconds, turned on
- motors moved about 10 seconds and stopped

I will check the schematics tomorrow, but I guess this won't be the issue, since it affects all stepper drivers/motors. (X stepper driver schematic part on ramps have been checked by me already at the beginning.)
Re: RAMPS 1.6+; motors don't move
October 28, 2018 12:52PM
Ok, that doesn't sound good. Could you check if the step signal is reaching the step sticks, or do they stop too? That would indicate that the atmega also has stopped. Do you have another arduino board? Does the gcode interpreter still respond? ie can you send commands to display information like M503?

Can you check if the current draw on the 12V looks ok? If it seems high like 5A with only the stepper motors on it could be the mosfet output transistor could be shorted out (not uncommon when 12V is reversed).

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
October 28, 2018 02:26PM
In the youtube video you see the STEP signal, without working motors.
So yes, the STEP signal reaches the step sticks.
I have no other mega board but an arduino uno (dunno if the ramps test code works on that, but I know that I need to modify pins, just tell me if it is worth testing on it).

I attached my variable DC PSU with a display and it showed about 1A of current drawn while the motors were working and a little less than 0.1A when the motors stopped working.

M503 works (connected through a USB-serial adapter, because I don't want to cut a trace or remove D1 yet)

19:23:14.868 : N17 M503*19
19:23:14.914 : echo:  G21    ; (mm)
19:23:14.915 : echo: Filament settings: Disabled
19:23:14.915 : echo:  M200 D1.75
19:23:14.915 : echo:  M200 D0
19:23:14.915 : echo: Steps per unit:
19:23:14.915 : echo:  M92 X80.20 Y80.20 Z4000.00 E146.00
19:23:14.915 : echo: Maximum feedrates (units/s):
19:23:14.915 : echo:  M203 X300.00 Y300.00 Z1.65 E25.00
19:23:14.916 : echo: Maximum Acceleration (units/s2):
19:23:14.916 : echo:  M201 X2000 Y2000 Z100 E10000
19:23:14.916 : echo: Acceleration (units/s2): P R T
19:23:14.916 : echo:  M204 P3000.00 R3000.00 T3000.00
19:23:14.950 : echo: Advanced: Q S T X Y Z E
19:23:14.950 : echo:  M205 Q20000 S0.00 T0.00 X8.00 Y8.00 Z0.30 E5.00
19:23:14.950 : echo: Home offset:
19:23:14.950 : echo:  M206 X0.00 Y0.00 Z0.00
19:23:14.951 : echo: PID settings:
19:23:14.951 : echo:  M301 P24.10 I1.17 D124.38
19:23:14.951 : echo:  M304 P344.88 I50.12 D593.33

edit: damn smilies, can't disable them...

Edited 2 time(s). Last edit at 10/28/2018 02:29PM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 01:50AM
if steps are still happening, perhaps something is killing vmot? Its that pesky 12v again. perhaps one of the electrolytics between vmot and gnd is half dead

Edited 1 time(s). Last edit at 10/29/2018 03:06AM by Dust.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 04:31AM
According to this -> [reprap.org] (look at the Power part)
C6 have been reverse charged and probably damaged... am I guessing right?

Though, I don't have SMD caps, but I have through hole elecrolytic caps for replacement, 100µF with 16V/25V (no 35V). I could replace that (after removing and testing it).

edit: Vmot still has 12V after motors stop working (I measured that a dozen times). Maybe something that grounds Vmot to the motors fail? (Because all motor connectors have 12V, I think the steppers lower the voltage to rotate the motor.)

Edited 3 time(s). Last edit at 10/29/2018 04:39AM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 04:35AM
I was thinking about C3,C4,C7,C9,C10 the caps under each stepper driver.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 04:46AM
If that would be the case, then C4 wouldn't be damaged, because I never had plugged any stepper there (only E0, X, Y and Z steppers are in use)?

The issue is also present for C4 (E1 stepper).

Edited 1 time(s). Last edit at 10/29/2018 04:47AM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 07:51AM
I connected a fan to Vmot/GND, it was still rotating after the motor stopped. (I even stopped it by hand.)
There must be something in between Vmot/GND and the motors.

I guess that there is only the steppers between Vmot and the motors?
Either I try to get one cap off (which is pretty hard because of the SMD components) or I buy one new stepper and look if it works with that.

I prefer the latter, because I don't know if I can get the cap off without damaging other components or the board.

edit: Forgot to mention, I finished checking the schematics, everything is correct, it is a RAMPS 1.4 based layout.

Edited 2 time(s). Last edit at 10/29/2018 08:21AM by Loader009.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 05:21PM
What about the enable pins on the stepesticks? Maybe the signal is bad or the tirmware is shutting off the motors?

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
October 29, 2018 05:26PM
Oh and the reset and sleep pin, whats the signal lije on those?

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
October 29, 2018 05:28PM
The enable pins are always low (all of them) and all stepsticks are shutting down at the same time. (enable pin was still low while motors have stopped)

One thing wonders me right now.
After trying to read the test code, I think that all motors should work at the same time and rotate in the same direction and speed, always.
This was not the case, some motors worked, some stood still. I will check this more thoroughly tomorrow.
Re: RAMPS 1.6+; motors don't move
October 29, 2018 11:16PM
yes the standard ramps test firmware moves all steppers at the same time... (well within ms of each other)
but microstepping jumpers can make them move different amounts
Re: RAMPS 1.6+; motors don't move
October 30, 2018 07:50AM
Oh and the reset and sleep pin, whats the signal lije on those?
I checked, reset is floating, sleep is high.
Thank you, that was the problem, this solved it smiling smiley

According to the RAMPS schematic, RESET and SLEEP are connected to each other. This would be good, because for the A4982 SLEEP have a pullup resistor.
Both signal must be high according to the datasheet.

I falsely assumed that RESET and SLEEP are also connected in my case (I only tested the arduino shield pins). This assumption is wrong, it is a bit more complicated.
This RAMPS 1.6+ is compatible to SPI stepper driver, which means that it has jumpers for four "settings" (MS1, MS2, MS3 and [for stepsticks not explained] RESET).

This was my problem/issue, I had to add a jumper for reset to set it to high.

If you look at the attached picture, you see the four jumper options. The right row is 5V, the middle is MS1/2/3 and reset, the left are MOSI, SCK, CSN and MISO.
Initially I let the last jumper in the state when the board was shipped, connected reset to MISO. This didn't work, so I removed all jumpers, then the problem I described in this thread appeared.
After your explanation I only connected the MS pins, reset was still floating, but I thought that this is not needed to be connected, because this is not SPI (and nothing in the picture is stated).

This time I checked the reset pin while motor was moving and the motor immediately stopped when I put the probe on reset.
Obviously the pin was floating high and got low, when I touched it with the probe.

After connecting the fourth jumper, the steppers don't stop moving and the motors rotates happily with a smiling face.

Thanks to both of you, I feared that something is broken. Maybe it is, but this is not the case for the steppers or the power for the motors.
open | download - RAMPS 1.6+ stepper config.jpg (156.4 KB)
Re: RAMPS 1.6+; motors don't move
October 30, 2018 08:15AM
got to love the lack of documentation when they change something... sad smiley
Re: RAMPS 1.6+; motors don't move
October 30, 2018 04:58PM
Great to hear the problem is found, good group effort

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
October 31, 2018 04:27AM
Maybe this custom RAMPS design was kinda using a part of RAMPS 1.7 design? -> [reprap.org]
But anyway, lack of documentation is always a problem for cheap chinese clones, I guess.

It was indeed a good group effort, I completely forgot to check any datasheet at first, I have to get used to this.
Re: RAMPS 1.6+; motors don't move
November 01, 2018 04:26PM
You gave us good feedback, that helped a lot! With these kind of things one almost needs to be an electronics engineer to troubleshoot hardware that's losely standardized and reinterpreted by clone manufacturers.

Kind regards

NFAN CoreXY printer:
Re: RAMPS 1.6+; motors don't move
November 02, 2018 10:20AM
Well, I always wanted to answer as fast as I could, but instead I stopped while typing my answer and decided to check my own theories.
I guess this was a lot better than to (stupidly) follow your words and do nothing beside that.

And because all of that, I learnt a bit more about electronics.
Sorry, only registered users may post in this forum.

Click here to login