Extruder stepper skipping
February 19, 2019 07:38PM
I bought a Creality CR-X some weeks back. At first it ran really well. Recently though some issues have cropped up that have me stumped, specifically the skipping extruder steppers.

For those that don't know the CR-X has two extruder steppers feeding into one nozzle. Out the box it actually working really well but I decided to tinker with things to try and get it even better. Unfortuantely about two weeks ago I noticed the the extruder skip during printing. Not all the time, it seems quite random. Not sure if it started two weeks ago or sooner as I am not always there to listen to it but two weeks ago was when I first noticed it. So I want to go about properly calibrating everything.

When I do the 'extrude 100mm of filament' test the results are 97mm for T0 and 101mm for T1. I believe the firmware in this printer is locked by Creality (speak under correction) but I know I can compensate for this using M92 in the start gcode. What I don't know is what the default esteps are for this printer. Google searches suggest using the M503 command but I don't know how to apply this in practice. I would really appreciate some help here.

As to other cause for the skipping, I have:
- changed the nozzle (1x steel, 2x brass)
- tried various filament brands
- tried various temperatures (180-210)
- tried various feedrates (35 - 60)
- tried various layer heights

Not sure what else it could be if not the extrusion amount but T0 is under extruding so it can't that. Sometimes they skip on the first layer, sometimes they don't. Sometimes it prints fine for several layers after skipping for a layer or two. Bed levelling is good. Tearing my hair out here. All help appreciated.


Sebastian

Flash Creator X
Creality CR-X
Anycubic Photon
Re: Extruder stepper skipping
February 20, 2019 09:28AM
Found the default e-steps: 92.65. And I found that Creality have indeed locked the firmware so I am unable to update it. Not a train smash as I can just add the compensation to the start g-code. Only thing I am not quite sure of is how to set different e-steps for each extruder using M92. My understanding is that M92 is modal, meaning that consequent M92's will overwrite previous ones. Suggestions?


Sebastian

Flash Creator X
Creality CR-X
Anycubic Photon
Re: Extruder stepper skipping
February 22, 2019 03:18PM
Well,

You might get lucky and actually get some customer support. Yeah, I know "what ARE you thinking?!". You might get lucky and they can help you.
Check all your screws. A buddy just got a Creality Pro printer. The build quality was not all that great and he had to adjust a lot of screws until it was all solid and square.

DLC


Kits: He3D K200 Kossel, Folgertech Kossel 2020 upgraded E3Dv6, Anet A8 upgraded E3Dv6, Tevo Tarantula enhanced parts and dual-head
Scratch: Large bed Cartesian, Linear slide Delta, Maker-Beam XL Micro Delta
Re: Extruder stepper skipping
February 25, 2019 07:21AM
Any chance there are seperate flow rate modifiers for each extruder? If not in the firmware maybe in your slicer.
Re: Extruder stepper skipping
February 28, 2019 05:59PM
Agreed, I'd just use the multiplier in the slicer for that.
I'm not familiar with creality hardware, but see if you can adjust the motor current. Make sure the z axis doesn't bind and runs very smoothly.


--
Kind regards
Imqqmi

NFAN CoreXY printer:
[reprap.org]
Re: Extruder stepper skipping
March 06, 2019 03:22PM
Thanks for the input. I have tried so many things now. Gettting really frustrating.

I don't know the first thing about adjusting motor current. How do I do this?


Sebastian

Flash Creator X
Creality CR-X
Anycubic Photon
Re: Extruder stepper skipping
March 06, 2019 03:32PM
See the attached photo. Near the top is a missing layer. These occur at any height, although mostly nearer the top. The next layer was fine again. Really can't figure this out.


Sebastian

Flash Creator X
Creality CR-X
Anycubic Photon
Attachments:
open | download - 20190306_202332_Burst01.jpg (170.6 KB)
Re: Extruder stepper skipping
March 07, 2019 02:56AM
UPDATE:

I have isolated this to the Extruder 1 stepper motor.

As mentioned before this mostly happen when well into a print. All help appreciated.


Sebastian

Flash Creator X
Creality CR-X
Anycubic Photon
Re: Extruder stepper skipping
March 10, 2019 04:51AM
When something starts to go wrong after a period of time, it's likely to be something heating up. Maybe the stepper driver is overheating? Or the stepper itself? Check temperatures of the motor and stepper driver heatsink... you should be able to hold your finger on them.

Or maybe heat creep within the hot-end... as heat creeps up the the heat break, filament softens and swells, increasing friction until the extruder can no longer push it out. But you say you have two extruders, and it only happens on one. What's different between the two?
Sorry, only registered users may post in this forum.

Click here to login