Welcome! Log In Create A New Profile

Advanced

Autolevel not compensating correctly

Posted by foul_owl 
Autolevel not compensating correctly
March 05, 2019 02:42PM
The bane of my existence...trying to get the bed leveled.

I'll spend hours trying to level the bed, only to have to replace something, requiring another leveling session.

Or worse, one day randomly the leveling work I have done is suddenly undone.

I finally added autoleveling to try and solve this once and for all, but even this does not work.

I try heating the bed to temp, then:

G28 X0 Y0
G28 Z0
G29
M500

And at the start of the print:
M420 S1

to enable.

Marlin 1.1.x firmware, bilinear method.

Here's the result from some calibration cubes:





Why would autoleveling have these errors like this, and what could I do to try and resolve this issue?

Edited 4 time(s). Last edit at 03/05/2019 03:01PM by foul_owl.
Re: Autolevel not compensating correctly
March 05, 2019 04:04PM
what is your heated be on, acrylic that is slowly warping? MDF that expands when heated?
how many probe points?

since you are using bi-linear have you tried getting a topographical map and importing it into a spreadsheet so you can see what is going on?

perhaps you bed has golfball sized holes...

up the number of points to a silly large number and graph that to see all the faults in your bed.

This all presumes your probe is reliable.
Re: Autolevel not compensating correctly
March 05, 2019 05:24PM
9 probe points, and the bed is aluminum.

There are no holes in the bed.

Bed material shouldn't matter also, because I'm using autoleveling.

I can level the bed by hand and get the prints perfect...until I either have to adjust something or enough time passes that the bed is no longer level. That's not the issue here.

The whole *point* of autoleveling is to compensate for the bed not being level.

Well, autoleveling is clearly not working, with no indications why.

The probe is reliable, I have run M48 many times and it gives a good stdev.

Let me run it again now and paste the results.
Re: Autolevel not compensating correctly
March 05, 2019 07:57PM
Send: M48 X150 Y150 P20

Recv: Mean: -0.693944 Min: -0.696 Max: -0.692 Range: 0.003Recv: Standard Deviation: 0.000719

0.7 micron stdev seems pretty good to me...
Re: Autolevel not compensating correctly
March 06, 2019 12:06PM
Quote
foul_owl
Send: M48 X150 Y150 P20

Recv: Mean: -0.693944 Min: -0.696 Max: -0.692 Range: 0.003Recv: Standard Deviation: 0.000719

0.7 micron stdev seems pretty good to me...

I feel your pain.

Have you tried locating the print in other sections of the bed? This would tell you if the problem is only at some locations on your bed.

I had an inductive autolevel probe that I discarded because its response was spotty depending upon the probed point. My hypothesis was that some spots on the bed were directly over steel screws that were quite close and the probe responded more strongly to those points making the bed look further away than it actually was. I then went to a removable micro-switch based probe that did a lot better job. Because the design sat it directly under the nozzle, I didn't need to do an offset in the bed leveling software for X and Y, only the Z.

Hmm,
Did you set the X,Y,Z offsets for the bed leveling probe? What kind of probe are you using? Or, are you manually running the G29?

DLC


Kits: He3D K200 Kossel, Folgertech Kossel 2020 upgraded E3Dv6, Anet A8 upgraded E3Dv6, Tevo Tarantula enhanced parts and dual-head
Scratch: Large bed Cartesian, Linear slide Delta, Maker-Beam XL Micro Delta
Re: Autolevel not compensating correctly
March 06, 2019 04:11PM
Using a microswitch.

I have set the X,Y, and Z offsets correctly.

I did find this in the firmware:

/**
* Normally G28 leaves leveling disabled on completion. Enable
* this option to have G28 restore the prior leveling state.
*/

//#define RESTORE_LEVELING_AFTER_G28 false

So does "M420 S1;" "restore" this leveling state, or must I always do G29 if G28 is ever run?
Re: Autolevel not compensating correctly
March 08, 2019 08:21PM
I believe I have resolved the main issue here.

Two things:

1. After flashing firmware that updates probe offsets, *always* run M502 to load these new settings from the firmware. I was trying to adjust these settings but getting no effect due to this issue.
2. My start up code is now:
G28
G29
M420 S1

Which seems to activate the autoleveling correctly.

There are still minor issues, but will address those later.
Re: Autolevel not compensating correctly
March 08, 2019 09:00PM
Quote
foul_owl

1. After flashing firmware that updates probe offsets, *always* run M502 to load these new settings from the firmware. I was trying to adjust these settings but getting no effect due to this issue.
2. My start up code is now:
G28
G29
M420 S1

You are still missing one line, at what height do you want the bed leveling data to fade Z height to a level print.
Otherwise the bed leveling data will continue until the top layer.

G28
G29
M420 S1
M420 Z4 ; Bed Level Z Height would be a smooth level no corrections at 4mm // Leveling fade Z height (Requires ENABLE_LEVELING_FADE_HEIGHT)

Edited 3 time(s). Last edit at 03/08/2019 09:05PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Autolevel not compensating correctly
March 19, 2019 04:08PM
If you have enough flash available on your board you can try enabling G26_MESH_VALIDATION - this will allow you to print a test pattern that you can use to tweak the mesh points before saving the mesh.
Re: Autolevel not compensating correctly
March 24, 2019 08:16PM
Thank you!!
Sorry, only registered users may post in this forum.

Click here to login