Welcome! Log In Create A New Profile


DUE+RADDS+TMC2130 2 Issues left

Posted by passion43d 
DUE+RADDS+TMC2130 2 Issues left
March 14, 2019 03:49PM
Hello Community,

Recently i "finished" building my second 3D Printer and i managed to print a 15 hour print with no problem.
Sadly the success lasted only about 2 days. Please help, SOS, MAYDAY...


COREXY format, Original Arduino Due, RADDS 1.5, TMC 2130 for X and Y, NTC 3950 (Termistor table 11 in Marlin 2.0), 400W silicon heated bed with SSR,

Software: Marlin 2.0 (32 bit)


1. The TMC 2130 are working fine in 16 microsteps configuration with sensorless homing but the noise is really irritating so i tried to configure it for 128 microsteps... Homing moves the Carriage in the right direction but only about 2 centimeters and then stops.
Obviously i would love some help with seting it to at least 128 microsteps.

2. For no apparent reason the T0 thermistor is showing -27 degrees.
The Thermistor for T0 used to work but now i get only -27 degree, if i try inverting TEMP_0_PIN to 1 the thermistor is reading 38 degrees at around 22 degrees room temperature. The temperature reading is not moving at all even if i heat the thermistor.
I tested different thermistors once in T0 and once in the T4 (bed thermistor) to check if the sensor is fine and it seems to be, there seems to be a problem only with T0.
I checked the Wires and electronics... everything seems fine.

3. Bonus Challenge is to install an extra hardwired stable USB port for the Raspberry PI connection or PC.

If you got to this point then Thank You for the attention and your time. If you need additional files please let me know and i will provide that ASAP.

Edited 1 time(s). Last edit at 03/14/2019 03:55PM by passion43d.
open | download - Marlin.ino (1.9 KB)
open | download - Configuration.h (75.8 KB)
open | download - Configuration_adv.h (87.7 KB)
open | download - pins_RADDS.h (6 KB)
open | download - pins.h (34.7 KB)
open | download - boards.h (13.7 KB)
Re: DUE+RADDS+TMC2130 2 Issues left
March 14, 2019 10:59PM

-27C normally means a missing or open circuit thermistor, or the analogue pin is high (+5V on 8-bit Atmel, +3.3V/+3V on 32-bit).

Put your multimeter/scope on the thermistor pin on the RADDS board/connector and see what the DC voltage is - it should be around 3.17V at 22 deg C (B3950 100k therm) with a DUE board.

Thermistor resistance/voltage calculator

If it looks OK, then follow it back to the MCU pin on the DUE board and see what the DC voltage is on the MCU pin itself (pin 78 I think) - it should match the voltage on the thermistor pin/wire - if it doesn't then there is a board/connector/track hardware fault (normally fixable).

Edited 1 time(s). Last edit at 03/14/2019 11:11PM by Pippy.
Re: DUE+RADDS+TMC2130 2 Issues left
March 21, 2019 02:16AM
Hello Pippy,

Thanks for taking your time. I recently unwired the board and checked it again for any visual clues of faulty solder or burned components and there are none.

I measured the DC voltage of the thermistor pins on the RADDS and oddly, T0 reads 2.2 Volt while all others are around 3.10 - 3.17 Volts.

Any ideas what causes this odd reading?
Re: DUE+RADDS+TMC2130 2 Issues left
March 21, 2019 05:33AM
What's the voltage on the RADDS board thermistor pins (between 0V and the signal pin) with the thermistor disconnected ?

If it's still not 3.3V then it sounds like something on the board(s) is pulling the pin down slightly or the 4k7 pull-up resistor on the RADDS board is not soldered/missing/damaged.
Re: DUE+RADDS+TMC2130 2 Issues left
March 25, 2019 07:22PM
Yes indeed the 4k7 pull-up resistor on the RADDS board is damaged/missing after i practiced my soldering skills on it... a new RADDS is already ordered and on the way.
Sorry, only registered users may post in this forum.

Click here to login