Welcome! Log In Create A New Profile

Advanced

Z-probe not deploying for Auto Home when...

Posted by Rewas 
Z-probe not deploying for Auto Home when...
April 04, 2019 09:52PM
I have installed a servo deployed Z-probe on my MKS GEN L upgraded Ender 3 (for Auto Bed Leveling) and it's working great EXCEPT when DEACTIVATE_SERVOS_AFTER_MOVE is enabled. With that enabled the probe does not deploy for Auto Home and the nozzle crashes into the bed. If I use my finger to trigger the probe switch and let it complete Auto Home, the probe will deploy when Auto Bed level is run. It all works fine so long as I don't enable DEACTIVATE_SERVOS_AFTER_MOVE but the servo jitters if power is left on. Your advise and help is very much appreciated.

Edited 1 time(s). Last edit at 04/04/2019 09:54PM by Rewas.
Re: Z-probe not deploying for Auto Home when...
April 08, 2019 06:27AM
I figured out the problem. On recommendation from a YouTube video, I had my Servo_Delay set at 100mS...too short. It looks like 200mS is the minimum needed for this type of servo. Oh, the hours I've spent trying to figure this one out and it was so simple.
Re: Z-probe not deploying for Auto Home when...
April 08, 2019 09:18AM
Thanks for the Update. Its good that you came back to post this valuable information so the rest of us can learn.


Electronics Technician / Computer Programmer
Sorry, only registered users may post in this forum.

Click here to login