Welcome! Log In Create A New Profile

Advanced

Marlin 1.1.9 auto level

Posted by MikeCL 
Marlin 1.1.9 auto level
April 23, 2019 03:14PM
I'm using a Capacitive sensor bed lever my first time getting the ramps 1.4 board up and running the issue is when I do a G28 it homes X and Y but for Z it will lower until it grinds the motor because the bed never moves to the center so the sensor can be detected it just stay's on the X end stop.. What setting in Marlin changes this? I turned off the Z safe homing but that made no change at all.
Re: Marlin 1.1.9 auto level
April 23, 2019 04:29PM
If you upload your configuration.h file to a file share like google Drive. Then post a sharable link here.
I will look it over to see if everything looks OK or if some changes should be made.


Electronics Technician / Computer Programmer
Re: Marlin 1.1.9 auto level
April 24, 2019 01:21PM
You definitely want Z_SAFE_HOMING to be enabled if you are using your Z-probe as your endstop.
Re: Marlin 1.1.9 auto level
April 29, 2019 07:30AM
Can it be that the homing speed is too high and the motor skips steps? I had to tune my z-homing speed and stepper amperage to prevent it from skipping steps while homing.

Edited 1 time(s). Last edit at 04/29/2019 07:30AM by Ohmarinus.


http://www.marinusdebeer.nl/
Re: Marlin 1.1.9 auto level
May 06, 2019 02:45AM
I seem to have it working ok now but the G29 command the offset I was given for the type of sensor I have seems not to be right as when it homes the sensor is off the build plate and never senses the bed so the nozzle crashes into the bed.. I entered it in 100% as it was given.
Re: Marlin 1.1.9 auto level
May 06, 2019 06:30AM
Quote
MikeCL
I seem to have it working ok now but the G29 command the offset I was given for the type of sensor I have seems not to be right as when it homes the sensor is off the build plate and never senses the bed so the nozzle crashes into the bed.. I entered it in 100% as it was given.

This is because you need to enable a specific setting in configuration_adv.h so that the sensor homes by respecting the sensor offset compared to your hotend. I don't remember the exact line but I have found it in a youtube video one day and it saved me from a lot of frustration.

Maybe someone remembers what it was?


Edit:
I looked it up.
Some things to do:
in Configuration.h enable:
#define Z_SAFE_HOMING

This makes it so that on G28 your probe levels in the center of the bed.

I think your problem is not the G29 but the G28. Did you set the offsets in the firmware?

Edited 3 time(s). Last edit at 05/06/2019 09:31AM by Ohmarinus.


http://www.marinusdebeer.nl/
Re: Marlin 1.1.9 auto level
May 06, 2019 02:39PM
ABL should only probe places on the bed as long as you have your printer well defined in the configuration. There are several settings you need to make sure are correct:
  • X and Y endstop positions - make sure that X_MIN_POS and Y_MIN_POS (assuming you have X-min/Y-min endstops) are set such that the front-left corner of the bed is X=0, Y=0. This may mean that X_MIN_POS and/or Y_MIN_POS may be negative! For example, on my AM8 X_MIN_POS is -33 and Y_MIN_POS is -6.
  • Bed size - X_BED_SIZE and Y_BED_SIZE should be set to the actual size of the bed.
  • Probe offset - X_PROBE_OFFSET_FROM_EXTRUDER/Y_PROBE_OFFSET_FROM_EXTRUDER need to be set correctly.
  • Z_SAFE_HOMING - it is very important that this is set. If everything else is set as described above, this will mean that the Z homing move should be done with the probe in the very center of the bed. Note that in this case the nozzle will probably not be in the center of the bed when homing.
  • Optional: If you're using a capacitive or inductive probe, ensure that you set MIN_PROBE_EDGE to ensure that the very edges of the bed aren't probed, since that kind of probe can be inaccurate near the edges. If you're using a contact probe like a BLTouch you can reduce MIN_PROBE_EDGE, if you're using an inductive/capacitive sensor leave it at the default of 10 or even increase it if you get inaccurate probing near the edges.
Usually, you don't need to change any other settings to have homing work correctly with a probe. Most of the problems I've seen with this is when people override other default settings in the configuration file.
Sorry, only registered users may post in this forum.

Click here to login