Welcome! Log In Create A New Profile

Advanced

Z Axis does not move during prints, so layers overlap

Posted by Zarret 
Z Axis does not move during prints, so layers overlap
May 13, 2019 02:04PM
Hi,

I'm new to 3D printing and I have gotten almost everything up and running, I just have this one last snag.

During prints, the Z axis does not move and this causes the layers to print on top of one another. The nozzle ends up digging into previous layers.
I have full control over the printer and can move all axes in printrun, and when I start a print, all axes home perfectly and the nozzle goes to the correct height above the bed and the first layer prints well. The Z axis seems to work perfectly and I'm just not sure what the issue is.

I have attached the Gcode of the 20mm cube that I am trying to print, sliced from CraftWare 1.21.1.
The same thing happened when I attempted to slice from printrun.
All the steppers seem to work and everything seems in order, it's just this.


I use an arduino attached to a RAMPS 1.4.

I will also attach a copy of my Marlin.

Any help would be appreciated!
Attachments:
open | download - 20mm_cube.gcode (83 KB)
open | download - COPY OF MARLIN SECOND CONFIG.H.txt (144.5 KB)
Re: Z Axis does not move during prints, so layers overlap
May 13, 2019 09:04PM
I look at your Firmware, and see that you have

#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 2560, 94.69 }

On my 3D Printer it would mean that I have a X and Y belt, And I have a all-thread Lead-screw that is 8mm x 1.25 thread

What 3D Printer do you have, an could you post a picture of your Lead screws.
I have a photo of three Lead screws below from Left to Right " all nuts are turned one revolution only"
1st is a TR8-8 would use a 400
2nd is a TR8-2 would use a 1600 /this is what I use/
3rd is a 8mm X 1.25 thread all thread would use a 2560 / this is what your numbers are saying you have.



Hope this will help you.

Edited 2 time(s). Last edit at 05/13/2019 09:06PM by Roberts_Clif.


Electronics Technician / Computer Programmer
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 04:26AM
Quote
Roberts_Clif
I look at your Firmware, and see that you have

#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 2560, 94.69 }

On my 3D Printer it would mean that I have a X and Y belt, And I have a all-thread Lead-screw that is 8mm x 1.25 thread

What 3D Printer do you have, an could you post a picture of your Lead screws.
I have a photo of three Lead screws below from Left to Right " all nuts are turned one revolution only"
1st is a TR8-8 would use a 400
2nd is a TR8-2 would use a 1600 /this is what I use/
3rd is a 8mm X 1.25 thread all thread would use a 2560 / this is what your numbers are saying you have.

[attachment 111317 Leadscrews3.jpg]

Hope this will help you.

I'm using an M5 screw even, for that one you need around 4000steps/mm. Indeed, this would be the first thing to check. After that, see if your Z-axis actually moved the correct distance before you start printing. You can do this with calipers and by giving each axis a move command.


http://www.marinusdebeer.nl/
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 07:07AM
Quote
Roberts_Clif
I look at your Firmware, and see that you have

#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 2560, 94.69 }

On my 3D Printer it would mean that I have a X and Y belt, And I have a all-thread Lead-screw that is 8mm x 1.25 thread

What 3D Printer do you have, an could you post a picture of your Lead screws.
I have a photo of three Lead screws below from Left to Right " all nuts are turned one revolution only"
1st is a TR8-8 would use a 400
2nd is a TR8-2 would use a 1600 /this is what I use/
3rd is a 8mm X 1.25 thread all thread would use a 2560 / this is what your numbers are saying you have.

[attachment 111317 Leadscrews3.jpg]

Hope this will help you.



Thanks for replying to me smiling smiley

I tried what you suggested. I'm pretty sure I have a TR8-8 leadscrew so I tried the 400 steps per mm. My printer is a self made custom build but everything seems to work fine.

I think I have narrowed the probelm down slightly. I tried printing the cube with the same gcode, and this time, I'm not exactly sure what happened.
It looked like for the first 2 or 3 layers or so, the z axis wasnt moving and the print layers were overlapping. Because of this, the nozzle was pressed up against the print so it jammed up and wasnt extruding anymore (the extruder motor was turning but the filament couldnt move through the teflon tube in my bowden setup).
The printer was still moving though. The frustrating thing is that after the nozzle jammed, the z axis just suddenly began working and started moving upwards after every layer just as it should.

So my problem now is that the first few layers print on top of one another, so the nozzle jams, and then the z axis kicks in. So is there any way that I could get the z axis to work from the start? Perhaps I am slicing incorrectly or have bad settings.

One last thing, is there any way I could prevent blockages in my hotend, because after every failed print, I need to remove the tube from my hotend, cut off the end of the filament, and put it back in. Maybe this is normal? Not sure.

Thanks again
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 08:24AM
Sounds like the Z-axis might be skipping steps because of either too high a feedrate in the firmware, or too low current settings on the driver chip. Could it be that it's skipping steps?


http://www.marinusdebeer.nl/
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 10:25AM
I don't think the z axis motors are skipping steps, because when I told the printer to increase z by 10 mm, and I measured it, it was 10mm (after I adjusted the steps per mm to 400). Also, as I said above, the Z axis starts to move after the first few layers are complete, but only after the nozzle jams.
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 10:47AM
home all axis, send the machine a M114 see where it thinks it is, I wonder if it thinks it is already higher than layer you are printing, so it doesn't move,
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 10:55AM
Quote
Zarret
I don't think the z axis motors are skipping steps, because when I told the printer to increase z by 10 mm, and I measured it, it was 10mm (after I adjusted the steps per mm to 400). Also, as I said above, the Z axis starts to move after the first few layers are complete, but only after the nozzle jams.

This doesn't mean it is ok. You can have a too high feedrate in your firmware or slicer. I had the same problem, it would move perfectly in pronterface when it said it to move 100mm but that was because the move speed in the software was lower than in reality when it would do a z-axis move during printing. Took me a while to figure this out. Anyway, just something to keep in mind. For me all moves worked perfectly but auto bed leveling didn't work because the feedrate was higher when it was doing auto bed leveling and it was really hard to hear the steppers losing steps because the feedrate was so high that it had a very high frequency and was hard to hear/see.


http://www.marinusdebeer.nl/
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 11:01AM
Alright, guys, I'm not sure what I did, but it's working!

I tried a new slicing software using all the defaults and it just worked.

Thanks for all the help, especially for the help on the correct steps per mm on the leadscrews. smileys with beer
Re: Z Axis does not move during prints, so layers overlap
May 14, 2019 02:15PM
Quote
Zarret
Alright, guys, I'm not sure what I did, but it's working!

I tried a new slicing software using all the defaults and it just worked.

Thanks for all the help, especially for the help on the correct steps per mm on the leadscrews. smileys with beer

Can it be it has different speeds in the slicer? I still think the Z-axis was missing steps, besides the obvious steps/mm. It may still be worth checking out what the issue was.

Edited 1 time(s). Last edit at 05/14/2019 02:16PM by Ohmarinus.


http://www.marinusdebeer.nl/
Re: Z Axis does not move during prints, so layers overlap
May 15, 2019 09:49AM
I agree with Ohmarinus, the 3d print3r shoukld be setup with the max acceleration and velocity it can handle so that whatever a slicer throws at it, it doesn't skip steps.
Just write some gcode that repeatedly goes back and forth 150mm at the highest velocity so that it doesn't skip steps for every axis, then subtract some safety amount like 5 to 10% and save that as default in firmware or eeprom.


--
Kind regards
Imqqmi

NFAN CoreXY printer:
[reprap.org]
Sorry, only registered users may post in this forum.

Click here to login