Welcome! Log In Create A New Profile

Advanced

Homebuilt CoreXY skipping steps only on +x+y motor

Posted by Paul S 
Homebuilt CoreXY skipping steps only on +x+y motor
July 17, 2019 09:42PM
I have a printer skipping steps only on one motor. It is one of the XY plane motors (it's corexy). Normally, it makes it a ways into a print, then skips, then later on in the print, it skips back to around the same position, but not quite exactly, and then it skips back, and then it repeats. That made me think that it was a loose setscrew on one of the pulleys, but I checked that, and it's not. I have tried a bunch of stuff and am pretty much at a loss. Some things I've tried are:
- Tightening the setscrews on the pulley
- Checking motor current (it's the same as all the others, including the other XY plane motor, so I don't think that has anything to do with it)
- Swapping motor drivers
- Replacing the motor
- Checking that "disable stepper when not in use" or whatever isn't on for that motor
- Slowing print speed
- Using z hop to make sure it doesn't catch on anything in the print
- Decreasing acceleration
- Decreasing jerk
- Checking that the motion platform is moving smoothly and doesn't have any catch points
- Checking that wires/bowden tube are not catching
- Using different gcode

The endstops are not interfering at all, because there aren't any, and the motors are NEMA 23s running on 24v. It's a RUMBA, and there's a 360-watt power supply and no heated bed so I don't think it should be a power issue. It seems that slowing down the print helped a little (it got further in a print that I tried a few times when it was slower), but it didn't fix it. The motion platform is pretty solid and I haven't had this issue in the past, and I've run it at 600mm/s, 15000 mm/s^2 acceleration ghost printing on a very boxy part, so I don't think it has anything to do with the motion platform. I would expect an electronics problem, or maybe a programming issue, but I'm not really sure. Any suggestions or ideas or really anything would be much appreciated. Thanks!
Re: Homebuilt CoreXY skipping steps only on +x+y motor
July 18, 2019 06:55AM
Check the cables to the motors, especially the connectors on them.

Acceleration of 15000 and speed of 600? Moving mass of 10g?

pictures?


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Homebuilt CoreXY skipping steps only on +x+y motor
July 18, 2019 07:11PM
I haven't checked the connector to the board, but I have replaced the stepper and the driver. I am going to try uploading firmware with that stepper moved to another slot on the board (I'm not using extruder 2) but other than a connection on the actual board, that's not it. The screw terminals on the board look fine, but I haven't checked with a multimeter, so I'm going to try that firmware. Also, yeah, the moving mass is tiny (carriage riding on carbon fiber rods and pretty much only an e3dv6 on it and nothing else) and the motors have quite a bit of torque behind them, along with the increased lever arm of a 36 tooth gt2 pulley. I really wish I could get the extrusion system to keep up smiling smiley

The print in the picture (that hopefully went through) is one that I left to run after it skipped, and you can see it skipped and then skipped back but not quite and then back and forth. The under-extrusion in that one is cuz it was the first print on a new extruder that wasn't even close to calibrated yet. It's that kind of almost-back-and-forth movement that made me think it was a loose setscrew, but I looked and the setscrews were tight and there were no scratches on the motor shaft.

I guess I'm gonna try that firmware and change the motor to a different slot on the mainboard and see if that does anything -- if it doesn't, it's pretty certainly not a connection issue. Thanks for the response
Attachments:
open | download - WIN_20190718_15_43_42_Pro (2).jpg (454.8 KB)
Re: Homebuilt CoreXY skipping steps only on +x+y motor
July 18, 2019 08:34PM
When troubleshooting things, you want to make two lists of all the possible causes of the problem, then order each from most to least likely, and attack the most likely things first. The two lists are things that are free to fix and things that cost money to fix. That way you don't waste time and money pursuing things that are extremely unlikely to cause the problems.

Configuration is often the culprit when prints are shifting and belongs at the top of the first list- usually acceleration and/or jerk/junction deviation are set too high for the torque the motors can deliver. You might get more torque by bumping up motor current, but if you set the motors to about 80% of rated current, they'll usually work smoothly and relatively quietly.

Motors almost never fail and belong at the bottom of the second list. All they are is coils of wire, magnets, and bearings- not much to go wrong, and when they do fail it tends to be very obvious. Cables and connectors are very unreliable and belong near the top of that list.

What are the acceleration and jerk/junction deviation settings you used for that print?

Post some pictures of the printer.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Sorry, only registered users may post in this forum.

Click here to login