Welcome! Log In Create A New Profile


conecting problems

Posted by bolean 
conecting problems
February 08, 2020 10:09AM
Have experienced problems connect to my Mendel 90 printer from pronterface, and to upload from arduino.
problem started om my Kubuntu machine. I found and fixed some software corruption and after manually unmarked and rename some lines in melzi/cores/arduino/main.cpp ; /marlin/SdBaseFile.h and /marlin/SdBaseFile.h that gave error massages in Arduino. After that I was able to upload the sketch. After that the connection from pronterface whas gone. changing back all modification made no difference.

Now I tried my Debian machine that has worked for years. Immediately Arduino complained about the same SdBaseFile.h, after unmarking all upload worked ( no problem with the marlin files.)
since I have'nt used this computer until now, I wonder where the problem is. Could it have something to do with the latest uploaded sketch?

I checked usb connection with dmesg and found this line for the printer connection

[ 452.802707] Thread-39[2236]: segfault at 7f2c2803b100 ip 00007f2be66e3261 sp 00007f2c0cb57248 error 4

everything else looked normal.

Without pronterface my printer become useless so this is a serious problem. Tips and help would be more than welcome.
Sorry, only registered users may post in this forum.

Click here to login