Welcome! Log In Create A New Profile


Extruder not turning

Posted by Dgils 
Extruder not turning
March 09, 2021 06:51AM

I have my extruder not turning at all.
For information I test it with warming and without warming head.
motor does not turn.
Before it was making strange noise but not anymore and do not turn
I tried :
change cable
change motor
move extruder from pronterface
move extruder from printer itself without success
I have a delta kossel K800xl mega2560+at with unknown driver the less expensive I suppose I can make picture of them + marlin
Re: Extruder not turning
March 10, 2021 12:45PM
I have similar problem but with other 3d printer, you can try to change E driver for Z driver for example and try if extruder start to work.

My board is creality 1.1.5 (little use) and extruder stop while printing, I changed tmc2208 driver, changed to marlin 2, driver got good voltage but doesn't start (no current). One strange thing is when I move X (or Y) driver, E and Y motors receive current and are blocked, X works ok.
Re: Extruder not turning
March 11, 2021 02:50PM
A stepper will make a growling noise and not turn if its wires are connected to the driver in the wrong way, so maybe your wires are crossed.

Edited 1 time(s). Last edit at 03/11/2021 02:50PM by MJLew.
Re: Extruder not turning
March 12, 2021 07:48PM
there is no noise at all on the motor and I tried to cross/uncross cable on board connector : No change

Maybe, if on the AT2560 I can manage a second extruder on another connector. maybe I can use this ?
problem is I do not know how to change marlin to have extruder 2 as default
and if I need to change driver position on the board ?
Re: Extruder not turning
March 13, 2021 02:22AM
if it has a unused extruder. you simply change the pins over.

so marlin still thinks it is moving E0, but it is really moving E1.

If its a ramps edit Marlin/pins_RAMPS.h has this code

#define E0_STEP_PIN        26
#define E0_DIR_PIN         28
#define E0_ENABLE_PIN      24
#ifndef E0_CS_PIN
  #define E0_CS_PIN        42

#define E1_STEP_PIN        36
#define E1_DIR_PIN         34
#define E1_ENABLE_PIN      30
#ifndef E1_CS_PIN
  #define E1_CS_PIN        44

just change all E0_ to E1_ in the first block, and all E1_ to E0_ in the second block.

Now marlin uses the physical E1 port as E0
Re: Extruder not turning
October 12, 2021 07:27PM

sorry for the delay in answering... after a long time I did not touch printer because too demoralised with this printer I came back and found issue... I connected on the wrong port. E1 instead of E0.... so it's working now thank for your help.
In the meantime I still can not print extruder is not enough strong to push pla. I need to turn screw on A4899 to put higher voltage but as i do not know what is ref of my motor...
I changed to an SKR1.03 + tmc5160 but I encounter some other issue. I will open new topic

thx for your help
Sorry, only registered users may post in this forum.

Click here to login