Welcome! Log In Create A New Profile


Concern with steps/mm being far too low

Posted by McLeod25 
Concern with steps/mm being far too low
June 29, 2021 01:00PM

I have recently done a board replacement for my custom built 3D printer (similar to Prusa i3 Mk3). My previous board melted at the heating bed wire connections (thankfully only that section was damaged). After swapping to a new "identical" board and chip set I added a MOSFET to avoid another small fire. Please note that my stepper motors, wires, screws, etc have been untouched (a straight swap on of the electronic board). Below are the system specs (please let me know if I am missing any vital information).

Ramps 1.4
Mega 2560 R3
stepper motor drivers a4988 (1/16th microstepping)
1.8o stepper motor (200 per revolution)
2mm belt pitch (GT2)
pully tooth count = 20

On to the concern. With my previous board, I had steps/mm for X and Y near 80 steps/mm, which is near default settings and theoretical settings. I had near similar values for my Z-axis and Extruder. However, after switching to the new board, these default values are far off. Meaning, I told the printer to move X-axis 1mm, and it moved over 10mm. Similar for Y and Z. I did some calibration for the axes and found X and Y to be near 6.3 steps/mm (similarly low for Z and Extruder when compared to default settings). I can print a 20mm calibration cube (using 1.5mm layer height at 30mm/s speed) and get +- 0.5mm accuracy depending on the axis (thus needs refinement on the steps/mm). My concern is that the calibration cube looks a little rough when compared to my old runs on the previous board. Thus, questions arise to how accurate and amount of tuning I could do with steps/mm so low (again, this is affecting all my stepper motors, including the Extruder).

Some additional information:
- Potentiometers have been tuned and are below 1V.
- With steppers disabled, can move X and Y easily (no sense of the stepper motors gumming up, grinding, or failing in general).
- Belts are not slack nor too tight.
- Power supply still at ~12V before and after board swap.

I have scoured the internet and have not found someone else with this type of issue. Closest I've found was someone's extruder steps/mm being far higher than their previous setup; but they actually changed their motor/design for their extruder. I would appreciate anyone's help or insight into this problem. Any solution to adjustments in Marlin would be preferred (for I am not seeing how else my setup could be inducing such drastic of a change, so it must be electronic/firmware). I can reply with any other potentially useful information if you need me to measure something (just be detailed in how you want something measured when it comes to electronics. I am a horrible electrical engineer and prefer to stay as a materials scientist and engineer.).
Re: Concern with steps/mm being far too low
June 30, 2021 07:18AM
use M503, verify eeprom setting match what you expect for steps/mm

you don't actually say what you replaced, the mega or just the ramps?

Micro stepping us set by jumpers under the stepper drivers, are you sure you installed all 3 under each stepper driver?

you say "I told the printer to move X-axis 1mm, and it moved over 10mm. "
this means the stepping is far to high, not low.
Re: Concern with steps/mm being far too low
June 30, 2021 10:29AM
After using M503, the steps/mm are indeed:

echo:; Steps per unit:
echo: M92 X6.30 Y6.30 Z25.20 E10.00

When I said circuit board, I meant the whole thing. So yes, Mega and ramps were both replaced.

I believe you just solved my problem. I did not install those jumpers underneath the A4988 drives. I did not fully disassemble my burnt board and thus did not see them. It's been over 4 years since I put the thing together.

I will post an update on fix.

Re: Concern with steps/mm being far too low
June 30, 2021 01:18PM
I placed three jumpers (small black box with a single sheet metal to connect two pinouts) underneath each A4988 drive and that solved my steps/mm concern.

To anyone that has a similar issue, check to make sure you have installed your jumpers into your circuit board, or at least check them for one may have gone bad.

Thanks for your help.
Sorry, only registered users may post in this forum.

Click here to login