Extruder rotates weirdly
July 22, 2021 09:31AM
I'm building my first printer and facing an issue with my extruder that I wasn't expecting. It isn't finished yet, but I've doing some tests without filament or bed, only watching this "air print". Probably the issue is some wrong adjustment in Marlin, but I couldn't find it until now. As I'm no more than a rookie using Marlin, I think looking for help would be better.

About the issue:
When I start printing the extruder rotates continuously loading the filament, but after that, while actually printing it starts an abnormal movement. It rotates about 72° (40 steps) and stop. A couple seconds after rotates another 72° and stop again. I thought it would be rotating continuously, extruding while it's printing, but it only extrudes in some intervals like it was "buffering" filament.

I already tried to replace stepper, driver and extruder output (from E0 to E1), but I wasn't able to fix it. I've also verified if the stepper was stuck or missing steps, but both are ok.

My setup is:
- MKS Robin Nano V3.0
- TMC 2209
- Pancake NEMA 17 @800mA
- Direct MK8 (?) extruder
- V6 hotend

Edited 1 time(s). Last edit at 07/22/2021 09:31AM by ddpsft.
Re: Extruder rotates weirdly
July 22, 2021 03:02PM
Updating it, now I'm moving my Z axis making some additional tests and calibration and the extruder is rotating, like it has been controlled by the same signal from Z steppers/drivers
Sorry, only registered users may post in this forum.

Click here to login