Welcome! Log In Create A New Profile


Not extruding during a print.

Posted by ianch 
Not extruding during a print.
August 06, 2021 09:42AM
No PLA is extruding when I try and print, what am I doing wrong?

I have a Gadget3D Printer which based on the Prusa printer. However its had a few mods. It now has a heated bed, and I swapped the direct drive head for a bowden drive going to a JHead hotend (E3D v6).
The printer is running with MarlinFW 2.0.9.

I have calibrated the X,Y and Z as per all the well known published KB articles on the web.
Likewise I have calibrated the E.
All of which set on the printer with E92 followed by E500.

Did a PIDTune and set with M301 & M500.

I have also reflected the values in the MarlinFW configuration.h file and uploaded the firmware to the Arduino Mega board with RAMPS1.4

I have also calibrated the pots on the RAMPS board as per KB articles and also the assembly instructions for the Gadget3D

Some lines from the configuration.h file that are noteworthy

#define LINEAR_AXES 3
#define EXTRUDERS 1
#define TEMP_SENSOR_0 5
#define X_DRIVER_TYPE  A4988   
#define Y_DRIVER_TYPE  A4988
#define Z_DRIVER_TYPE  A4988
#define E0_DRIVER_TYPE A4988
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 2000, 96}    // M92
#define DEFAULT_MAX_FEEDRATE          { 400, 400, 3, 8.5}    // M203
#define DEFAULT_MAX_ACCELERATION      { 1500, 1500, 25, 1000 }    // M201
#define DEFAULT_ACCELERATION          1500    // M204
#define DEFAULT_XJERK 10.0    // M205
#define DEFAULT_YJERK 10.0
#define DEFAULT_ZJERK 0.3
#define DEFAULT_EJERK    1.0
#define G3D_PANEL

I also enabled in the Marlin the bed leveling feature. Which I manually levelled the bed in the corners and the center with a single sheet of paper.

With PLA loaded, measured 1.74mm and the HotEnd heated by to 200C, from the printer panel I can extrude PLA no problems at all; in varying lengths and no jam ups or the stepper struggling. The hot PLA comes out the nozzle in a nice flow.

So far so good. Correct me if I've missed something.


When I try and print a model from the SD card, it doesn't extrude.

The print starts by heating the bed and nozzle to 60C and 210C. The printer does a home, all looks good.

The head moves to the center to start printing and nothing comes out of the nozzle. I can see the bowden stepper trying to push PLA down the tube to the hot end.
After a while the stepper starts to jump backward, guessing as its putting to much pressure on PLA that clearly isn't going anywhere.

If I stop the print and retract the PLA I can see a very tiny swollen section where its filled the diameter of the nozzle inside.

I've checked the temp of the block and it matches the read out of the thermistor value.

Reset the printer and load the PLA again. Heat up the hotend and extrude from the panel (move e - 10mm at a time) no problems. Extruding fine again.

Try printing same thing, nothing extruding.

I tried the bed leveling again, this time with 2 sheets of paper, thinking that maybe the nozzle was too close to the bed and therefore nothing could come out. Made no difference.
I've tried a different nozzle. I've also tried different throat tubes (one with PTFE and one without that was 1.78mm in diameter inside)

So my next thought was the GCodes in the file. I was using slicer but I have now installed Cura.
That doesn't have a printer for Gadget3D so I selected Prusa i3 as that's what the Gadget3D is based on.

Tried a model with that and still the same thing.


In my Slicer I have the following settings

Nozzle Diamete = 0.40
Extrusion Mulitipler = 1 (I have tried 0.9 as well)
Extrusion Width = 0.40mm
Layer Height = 0.2mm (Cure calls is draft)

What am I doing wrong?

Do we think it could be hardware?
Or maybe a firmware setting in Marlin. If so what?
Or maybe a slicer/cura setting?

Any suggestions?
Sorry, only registered users may post in this forum.

Click here to login