Welcome! Log In Create A New Profile


Pronterface s not connecting

Posted by TerryD15 
Pronterface s not connecting
May 21, 2023 12:42PM

I've ugraded my PC to win 10 and am running the latest versions of Marlin and Pronterface. My Marlin firmware configuration compiles and uploads to Arduino. However when I try to connect Pronterface it just hangs on the 'connecting' message. I'm using the correct (only) port - 3 for both my uploading of firmware and pronterface connection, both configured to run at 25000 baud. I've used this printer (which I built from scratch, based on a Mendel) previously The problem also occured before updating everything. The control board is a Ramps 1.4.

Any advice appreciated.


Edited 1 time(s). Last edit at 05/21/2023 11:08PM by TerryD15.
Re: Pronterface s not connecting
May 21, 2023 12:51PM
... try with smaller baudrate ...

Aufruf zum Projekt "Müll-freie Meere" - [reprap.org] -- Deutsche Facebook-Gruppe - [www.facebook.com]

Call for the project "garbage-free seas" - [reprap.org]
Re: Pronterface s not connecting
May 21, 2023 08:49PM
Serial ports are single connection points only. Ie you cannot have multiple things using the serial port at once.

Make sure cura/vscode/arduiino ide etc are all closed before starting Pronterface.

If its windows give the machine then reboot as windows likes to hold on to serial ports even after the program has ended.
Re: Pronterface s not connecting
May 21, 2023 11:45PM
Hello VDX and DUST,

Thanks for your comments I will investigate in the morning. I have not used the machine for some years and last week the HDD of the PC developed problems , wanting to carry out a chkdsk every time I started up,so I put in a new 1tb HDD (this PC is dedicated for printing) The old drive was removed and a new installation of WIN10 made. So to parody the Beatles Penny Lane it is a 'Clean Machine'

I then downloaded the latest versions of Marlin ( and Prontrface. My Marlin config threw up a couple of errors which were soon fixed and I first uploaded it up to the bare Arduino 2560 and it appeared to upload fine - of course I successfully tried 'Blink' first for nostagic reasons - I wiped the Arduino, added the already wired Ramps 1,4 shield and again uploaded the Marlin firmware The leds flashed happily as they do, so I assume everthing there is ok. When I then connect Pronterface the led on Rams flashes about three quick winks and then sullenly refuses to flash.

As I said I will test everything in the morning and make sure that the port is free (but why no error message?) What I don/t understand is that before the problems with original HDD I could connect and control the motors properly etc but wsa having heater problems and the machine would simply reset having claimed a thermal runaway. that was caused by a themistor with a broken connection causing an intermittent problem so I solved that and decided to upgrade Marlin and Pronterface then the HDD failed,

Any way, thanks for your time helping and

Best regards

TerryD (whose brain loss is in inverse logarithmic proportion to my years!)
Re: Pronterface s not connecting
May 23, 2023 07:38AM
Hi Dust,

I tried your sugestions to no avail, but I have managed to connect by using an earlier version of Marlin (2.0 bugfix) so it seems like a firmware issue. I had read about this on another forum. However I seem to have no control with pronterface, if I try to move an axis I just get a scream from my controller, but at least I have a connection now

Sorry, only registered users may post in this forum.

Click here to login