Welcome! Log In Create A New Profile


Manual Slic3r update problem

Posted by spaceman 
Manual Slic3r update problem
July 03, 2012 09:57PM
I was manually updating the Slic3r for a friend following the instructions from www.slic3r.org with GIT. When I tried to run the command cpanm htts://github.com/alexrj/Math-Libm/tarball/master (the https was deliberately changed to htts because the forum sw will only put a link)

I got the following error:

Can't write to cpanm home '/.cpanm': You should fix it with chown/chmod first.

His pc is a Windows based running 7. I tried looking for /.cpanm to change the permissions but with no luck. Can anyone point me in the right direction?
Re: Manual Slic3r update problem
July 07, 2012 05:34PM
I solved this problem on my own. You have to Shift-Right-click on the C: drive and click Open Command Window Here from the drop down list. Then in the command window type mkdir .cpanm You can close the command window and continue the install
Re: Manual Slic3r update problem
July 07, 2012 06:33PM
Glad you figured it out. A lot of us are Linux users and have no idea how to help with Windows specific problems. There are also a lot of Mac users too.

FFF Settings Calculator Gcode post processors Geometric Object Deposition Tool Blog
Tantillus.org Mini Printable Lathe How NOT to install a Pololu driver
Re: Manual Slic3r update problem
July 08, 2012 09:27AM
@spaceman: Hey thanks, I have been trying to figure it out for some days now... I will try to add that detail to the slic3r - windows manual..

Manufacturer of low tolerance Filaments PLA, ABS, ASA, PETG, TPU, PA, PVA,
Re: Manual Slic3r update problem
July 08, 2012 05:50PM
I've installed the packages successfully without this step. And then I tried to install it on another computer and that is where I got stuck. I don't know why on some computers, that step is not necessary and on others it is. My edumacated guess is some resident MS service selected during Windows install won't let a (dot) .file be created at root through Windows Explorer. The solution of creating the folder in a command window as Administrator bypasses the problem.
Sorry, only registered users may post in this forum.

Click here to login