Welcome! Log In Create A New Profile


Help please - unable to compile Slic3r

Posted by Alzibiff 
Help please - unable to compile Slic3r
October 13, 2012 03:01AM
EDIT: I seem to have got it working on a Windows XP machine ..... now I need to find out how to do the same for Windows 7!

I am trying to install the Perl dependencies so that I can compile a version of Slic3r on my Windows 7 machine following Alexrj's instructions here:


However, I am getting an error at the stage in the instructions which runs cpanm to get a file on github: /alexrj/Math-Libm/tarball/master

The message I get is as follows:

/usr/bin/tar: pax_global_header: Unknown file type 'g', extracted as normal file
! Bad archive master
! Failed to unpack master, no directory
! Failed to fetch distribution

Can anyone point me in the right direction?
Thank you,

Edited 2 time(s). Last edit at 10/13/2012 07:38AM by Alzibiff.
Re: Help please - unable to compile Slic3r
October 15, 2012 06:57PM

I have got Strawberry Perl running on my Windows 7 PC and I use it to compile Slic3r.
I'm not a programmer and I remember it was horribly complicated but I can't remember how I got it working in the end.

So, I checked my folder creation date and then searched my Downloads folder for files I downloaded on that date.
Apart from the Strawberry installation file, the only other one I downloaded that day is called Math-PlanePath-81.tar.gz
It's too large to attach here but I remember finding it in one of the standard repositories.
You may have it already, but if you need me to send you a copy just drop me a message.
It may or may not help solve your problem.

Good luck.
Re: Help please - unable to compile Slic3r
October 16, 2012 12:51PM
Thank you Richard. I tried Strawberry Perl as well as Citrus Perl but got the same result. Thinking that it might be a permissions thing, I ran the command prompt as administrator but that didn't make any difference. I will do some more furtling around now that I know that it is possible to get it running on a Windows 7 machine - somehow!
Re: Help please - unable to compile Slic3r
October 28, 2012 03:35PM
I get the same result on Win7. Has anyone resolved this is a way they can document?

Thanks for any help.
Re: Help please - unable to compile Slic3r
November 18, 2012 03:12PM
FWIW, here's how I fixed the problem. Many thanks to Fros1y on the Slic3r Issues forum for his suggestions and pointers. At least IIRC it was Fros1y - unfortunately, the issues on the Slic3r site seem to disappear after they are resolved. Also, the actual fix was *not* added to the "build from github" instructions. So I'll try to recreate my solution here and hopefully the documentation will be available here for those needing it.

I'm not a Perl jockey, so hopefully this all makes sense.

First, I downloaded the Math_Libm zip package from the repository on github and unzipped it.
In the directory I unzipped to, I then did perl Makefile.PL.
Then dmake, dmake test, and dmake install. These are separate commands on separate command lines. This process is discussed on the Strawberry Perl site under "What to do if CPAN fails" or something like that. (Strawberry Perl site seems to be messed up today and I can't get find the page.)
This got me most of the way there. The code compiled, but sometimes died on Windows. I had to repeat the CPAN and CPANM steps to update all the libraries. This was mentioned on one of the Slic3r Issue responses.

Sorry, only registered users may post in this forum.

Click here to login