Welcome! Log In Create A New Profile


Export G code Failed

Posted by leeportnoff 
Export G code Failed
June 20, 2013 09:35PM
When I try to slice, I get an error.
For example:
Argument "\x(35)\(30)..." isn't numeric in multiplication (*) at C:/Program Files/Slic3r/lib/std/Slic3r/GCode.pm line 42.

I am using windows 8 64-bit. I have tried several stl files; even a simple cube. I cannot slice anything.

Edited 2 time(s). Last edit at 06/21/2013 06:44PM by leeportnoff.
Re: Export G code Failed
June 22, 2013 09:31AM
I am also experiencing the same problem on Win7, have loaded the latest, and now at a loose end, so frustrating, any ideas?
Re: Export G code Failed
June 22, 2013 04:12PM
I've never encountered this, but people have reported that removing old configuration files after an upgrade can solve issues like this.

Your config files are just text files. Instead of removing them, you can copy them to somewhere else, and then use them to recreate the new config files through the slic3r interface.

Not sure if this will solve your issue, but its easy enough to try.
Re: Export G code Failed
June 22, 2013 04:56PM
Thanks for the suggestion.
In my case, my install was software provided by the 3d printer vendor. It installed with a config file provided by the software install. I tried slic3r with several stl mesh files and downloaded stl files also. Each slic3r had errors.
So my problem started before the upgrade for 0.9.9 to 0.9.10.
I submitted a bug report and have sent my config file to the developers.
Re: Export G code Failed
June 23, 2013 04:01AM
Hi, been having trouble as well, got it to work with this config file attached.
Under Win 7 copy it to C:\Users\xxxxx\AppData\Roaming\Slic3r where xxxxx is your user account.
This works with the latest Slic3R version 0.9.10b
spinning smiley sticking its tongue out
open | download - slic3r.ini (3.1 KB)
Re: Export G code Failed
June 23, 2013 08:24AM
Yes! that config file works. Any idea which parameter causes the error?
Re: Export G code Failed
June 23, 2013 08:42AM
Any time I've encountered a "isn't numeric in (function)" I have solved it by reviewing my settings. Everytime, it was because there was a setting missing a number. If it supposed to say "0" and instead the field is empty, then you will get the "isn't numeric" error.

You can even open the Gcode.pm and look for the line that is throwing the error. THat will give you a hint what setting is causing the error.

Deleting the ini files is solving the problem because when you start with a new ini file, all the settings have numbers in them.
Re: Export G code Failed
June 23, 2013 08:46AM
Thanks. I found it.
The ini file provided by Solidoodle has a wrong parameter.
'support_material_speed = 50%'
should be
'support_material_speed = 50'
Sorry, only registered users may post in this forum.

Click here to login