Welcome! Log In Create A New Profile


Newest slic3r bug? slow extrude

Posted by loughkb 
Newest slic3r bug? slow extrude
July 13, 2013 08:47PM

Using the most recent beta of slic3r and I think I have found a bug. I was slicing a small model I did, and the first print was pretty good. Made some changes and resliced, and noticed on the next print that during the outtermost perimeter, that the extruder was running at something less than 1/4th the speed it should, causing the extruded filament to break up into little blobs. During the rest of the perimeters, it runs at the right speed.

I've seen this on one other model with this version of slic3r, so I'm pretty sure it's a bug.

I'm running a pruse mendel I2 and the marlin firmware.

I sliced the same model with kisslicer and it printed fine. Blenders 3D printer tests show it as a clean manifold model. Slices and prints fine in cura as well.

Is this a known bug?
Re: Newest slic3r bug? slow extrude
July 14, 2013 12:22AM
What changes did you make?

Waitaki 3D Printer
Re: Newest slic3r bug? slow extrude
July 16, 2013 06:39PM
Just a small dimensional change to part of the model.. Scaled it a bit up in blender, by 1mm. I'm no stranger to modeling in blender for 3D printing. There were no errors in the model.
Re: Newest slic3r bug? slow extrude
August 14, 2013 07:43PM
Still no others seeing this? I'm waiting patiently for the next release and hoping.

I paid for Kisslicer in the interim. It's working well, but has a hard time on non-perfect stl files. Minor buggers like a couple of shared edges will trip it up and create extra perimeters. Since nobody has uploaded a clean model of the herringbone gears, I'm giving it another go in slic3r tonight. It's been exporting the g-code for 8 minutes though, so I'm not hopeful that it will even finish....

Yes, I ran the gears through netfabb's web service. They don't always clean up multi-polys sharing the same edge though.

The last time I tried slic3r, it did the slow extruder bit again. Counting revs, it was running the extruder around 30% of the required speed to match the travel speed of the nozzle. It's such a weird bug.

I've double check settings. Slicer is set to marlin firmware, relative E is not checked. Kisslicer and cura both are set to 5D firmware (marlin) with absolute E and produce consistent good prints.

Slicer was my fave for it's excellent bridging. Maybe I'll just go back a version and sit it out.
Re: Newest slic3r bug? slow extrude
August 14, 2013 08:49PM
Ha! Sliced the large herringbone gear set for wades. This time it only ran the extruder slow during the skirt. Even though I'd just manually primed the extruder and was sure it was full and ready to go, the skirt consisted of a series of dots due to the slow speed. Then it was normal for the remainder of the print.

It's just weird.
Re: Newest slic3r bug? slow extrude
August 19, 2013 06:47PM
Just dealing with this problem right now, it seems almost like it's buffering or something! It's a model that takes me around 30 minutes to slice in Slic3r.......bizarre pauses, seems to speed up on the straight lines and fast moves. I'm going to try slicing it in something else.
Sorry, only registered users may post in this forum.

Click here to login