Welcome! Log In Create A New Profile


Slic3r generating spurious features???

Posted by frankvdh 
Slic3r generating spurious features???
December 12, 2015 05:59PM
I'm running Slic3r 1.2.9 on Linux and getting something really odd. When I use Slic3r on a particular (complex) object, it generates some spurious features. Eventually, after printing about 1.7mm of this other mystery object, it seems to switch to printing my object.

Here's what it looks like in Slic3r:

Here's what the first layer looks like in OctoPrint's preview... this isn't centred on my object, but seems to be about X=50, Y=0

Looking at the generated Gcode with an editor confirms that there's something there that AFAICT looks like the image that Octoprint shows. Trying to view the Gcode with Cura doesn't display anything.

Loading the STL file into KISSlicer displays some errors, so maybe it's a problem with the STL file that has confused Slic3r. But, if that's the case, I'd prefer that Slic3r report that it can't generate the right Gcode (or even crash) to generating the wrong Gcode...

Files available at DropBox:
Slic3r config.ini
Gcode produced
Re: Slic3r generating spurious features???
December 12, 2015 09:19PM
A few thoughts...
I checked the STL in the latest version of Meshmixer, and it didn't show any errors.

Then I ran it through slic3r with my own settings, and analyzed it in my gcode debugger/viewer:

I had my viewer it keep showing the layer of funny stuff, which you can see as a shadow of stuff centered near the bottom.

With verbose gcode turned on in Slic3r I find that the outside of that stuff is skirt like this:
G1 X-0.962 Y-52.206 F16800.000 ; move to first skirt point
G11 ; unretract
G92 E0 ; reset extrusion distance
G1 X-3.229 Y-52.603 E0.06957 F2700.000 ; skirt
G1 X-5.226 Y-53.747 E0.13913 ; skirt
G1 X-6.716 Y-55.501 E0.20870 ; skirt
G1 X-7.520 Y-57.657 E0.27826 ; skirt

And the inside bit is brim, like this:
G1 X-0.537 Y-61.430 F16800.000 ; move to first brim point
G11 ; unretract
G92 E0 ; reset extrusion distance
G1 X-0.154 Y-61.662 E0.01355 F2700.000 ; brim
G1 X0.851 Y-61.662 E0.04393 ; brim
G1 X1.240 Y-61.420 E0.05778 ; brim
G1 X2.513 Y-58.831 E0.14499 ; brim

Then it prints three lines on that same first layer like this:
G1 X1.381 Y-58.877 F16800.000 ; move to first perimeter point
G1 X0.507 Y-60.677 E0.36499 F2700.000 ; perimeter
G1 X0.185 Y-60.672 E0.37475 ; perimeter
G1 X-0.734 Y-58.877 E0.43570 ; perimeter
G1 Z0.600 F16800.000 ; move to next layer (1)

So I speculated there must be a small projection on the bottom of the model.
So I tried getting rid of it using the cut feature of Slic3r:

I found it needed .8mm cut from the bottom to come out correctly, any less and the offending lines were still there.
Here's a link to the resulting STL that I re-exported from Slic3r.

You may be able to check my hypothesis by zooming in on that area of the bottom of the model using an STL editor.

Hope that helps.

My printer: Raptosaur - Large Format Delta - [www.paulwanamaker.wordpress.com]
Can you answer questions about Calibration, Printing issues, Mechanics? Write it up and improve the Wiki!
Sorry, only registered users may post in this forum.

Click here to login