Welcome! Log In Create A New Profile

Advanced

Smooth cylinders instead of facets

Posted by Allnight 
Smooth cylinders instead of facets
December 20, 2015 01:25PM
I've been trying to print a cylinder without facets or at least decrease the size of the facets. I'm not sure if the program I used caused the facets or if facets are something necessarily inherent to stl files and the circle was actually smooth in autocad but was faceted in the stl file conversion. Is it possible to print a true cylinder from a stl or is there a minimum resolution that slic3er limited the the stl or maybe the stl limited the amount of cylinder facets?
Re: Smooth cylinders instead of facets
December 20, 2015 01:42PM
STL files always turn curves into segments because they break your model into triangles. Your printer has limited resolution, so as long as you make the segments short enough, you won't see any faceting in the print. You control the length of the segments by tweaking the STL resolution in your CAD software.

Example attached...


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Attachments:
open | download - Clipboard01.jpg (83.1 KB)
Re: Smooth cylinders instead of facets
December 21, 2015 08:13AM
I thing the Arc function was supposed to solve or help with this.
Re: Smooth cylinders instead of facets
December 21, 2015 02:12PM
G code does provide for two commands - G2 and G3 - do draw smooth arcs - although I'm not sure that it's supported by any firmware. The main problem, as Digital_Dentist has pointed out, is that the STL format is really just a collection of triangular facets. It is possible to get very fine detail by controlling the size of those facets, but it would be a difficult task for the slicing software to recognize that a grouping of facets really represents an arc and that G2 or G3 should be used.

The best way to control this is with the resolution used in your CAD program.
Re: Smooth cylinders instead of facets
December 22, 2015 03:33AM
If you set the number of segments in a circle very high in OpenScad it whatever other program you use to generate your STL file, eventually you reach a point where slic3r starts combining segments. I guess it has a minimum segment length, probably to avoid overloading the printer with lots of very short moves.



Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Smooth cylinders instead of facets
December 22, 2015 11:27AM
This is definitely a CAD export issue. Look for facet settings, resolution, facet angle, something along those lines.

3D printers are essentially 2 1/2 axis cnc machines so yes they can read G2/G3 codes, otherwise your program would become prohibitively long and take longer to slice.


Sebastian

Flash Creator X
Creality CR-X
Anycubic Photon
Re: Smooth cylinders instead of facets
December 23, 2015 07:34AM
Quote
sfinke
This is definitely a CAD export issue. Look for facet settings, resolution, facet angle, something along those lines.

3D printers are essentially 2 1/2 axis cnc machines so yes they can read G2/G3 codes, otherwise your program would become prohibitively long and take longer to slice.

No, that is incorrect. The STL cannot contain any information about curves or circles, and none of the popular slicer applications makes any attempt to use G2/G3 codes (apart from a couple of experimental beta releases I've heard of). Even if the slicing software were to analyse the STL and attempt to detect curved sections, the firmware in a great many printers does not support G2/G3 moves.

Dave
Re: Smooth cylinders instead of facets
December 23, 2015 02:06PM
I am using Sketchup. I normally set the circle segments to 120 (default = 24).
For a 100mm dia circle that would yield a segment of 2.62mm, or 0.26mm for 10mm.
Default yields 13mm segments.
Re: Smooth cylinders instead of facets
December 24, 2015 03:13AM
Have you noticed how you frequently have to repair STL files before printing when you use Sketchup? That is because curves are not mathematical curves in Sketchup. They are polygons. Try this experiment: draw a line that is tangent to to circles. You can't do it. The problem is that Sketchup will only allow you to connect to the circles at vertices of the polygons- unless you are extremely lucky in the positioning of the circles, your "tangent line" will not hit the vertices. When you draw objects and pull them into 3D and try to connect multiple objects, there are usually overlaps and gaps that cause problems in the STL file that require repair before you can print.

If you like the ease of use of Sketchup, you will like DesignSpark Mechanical much more. It's as easy to use as Sketchup but much more powerful for designing precise physical objects. You won't have to repair STL files from DSM in order to print them.


Son of MegaMax 3D printer: [www.instructables.com]
Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Smooth cylinders instead of facets
December 27, 2015 02:27PM
Thanks digital dentist! I thought finding a solution for that would take me a lot longer. I was pretty ecstatic to learn how.

You were right that the issue was the cad software's resolution. For anyone using Autocad having this issue just increase "facetres" (command) to 10.

The circle looks completely smooth to me


Sorry, only registered users may post in this forum.

Click here to login